Input device not functional / missing on Lenovo X60

OSS related discussion in general (i.e. not limited to Linux/Solaris/BSD)

Moderators: cesium, dev, kodachi, hannu

Input device not functional / missing on Lenovo X60

Postby Vipu » Fri Nov 04, 2011 2:04 pm

Opening /dev/dsp in RO-mode results in permission denied (not file permission problem). I can hear the microphone by setting jack.green.mode to rec-mix.

ossinfo:
Code: Select all
Version info: OSS 4.2 (b 2005/201110291351) (0x00040100) OSS_HG
Hg revision: changeset: 939:857a45d8e5a9, tag: tip, date: Thu Oct 06 15:30:33 2011 +0300, summary: Added support for Intel Cougar Point HDaudio
Platform: Linux/i686 3.1.0 #2 SMP PREEMPT Sat Oct 29 17:25:54 EEST 2011 (minilith)

Number of audio devices:   2
Number of audio engines:   6
Number of MIDI devices:      0
Number of mixer devices:   1


Device objects
0: osscore0 OSS core services
1: oss_hdaudio0 Intel HD Audio interrupts=8818767 (21800092)
    HD Audio controller Intel HD Audio
    Vendor ID    0x808627d8
    Subvendor ID 0x17aa2010
     Codec  0: AD1981 (0x11d41981/0x17aa2025)
2: oss_usb0 USB audio core services

MIDI devices (/dev/midi*)

Mixer devices
0: High Definition Audio AD1981 (Mixer 0 of device object 1)

Audio devices
HD Audio play play                /dev/oss/oss_hdaudio0/pcm0  (device index 0)
HD Audio play (null)              /dev/oss/oss_hdaudio0/pcm1  (device index 1)

Nodes
  /dev/dsp -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_out -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_mmap -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_multich -> /dev/oss/oss_hdaudio0/pcm0


ossmix:
Code: Select all
jack.green.mode <play|rec-mix|input> (currently play)
jack.green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.green.green [<leftvol>:<rightvol>] (currently 76.4:76.4 dB)
jack.red [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
misc.mono-sel <play|mic-mix|rec-mix> (currently rec-mix)
misc.pcbeep-sel <monovol> (currently 38.9 dB)
misc.rec-mix <pcbeep-sel|play|mic|green|int-cd> (currently mic)
misc.play [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.mic [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.rec-sel1 [<leftvol>:<rightvol>] (currently 19.4:19.4 dB)
misc.rec-sel2 <mic-mix|rec-mix|mono-sel|int-cd> (currently mono-sel)
misc.green [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.int-cd [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.mute ON|OFF (currently OFF)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|OFF> (currently High)
vmix0-outvol <monovol> (currently 24.3 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm2 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB) ("mplayer")
vmix0.pcm3 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm4 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm5 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
Vipu
New Member
 
Posts: 2
Joined: Fri Nov 04, 2011 1:40 pm
Location: Helsinki, Finland

Re: Input device not functional / missing on Lenovo X60

Postby Vipu » Thu Nov 10, 2011 10:26 pm

I got the input working with this advice from another thread:
cesium wrote:Try adding "hdaudio_noskip=7" line to oss_hdaudio.conf and see if you have more settings.

Now my mixer has also non-existing jacks, blue and pink, so I'd like to know what the different values for this setting do. Anyone care to enlighten me? I understand that the value is a bitmask but then what are those checks which the bit settings affect?
Vipu
New Member
 
Posts: 2
Joined: Fri Nov 04, 2011 1:40 pm
Location: Helsinki, Finland


Return to General Discussion

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest