Logitech Z Cinema, mixer not working

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

Logitech Z Cinema, mixer not working

Postby McManiaC » Sun Oct 11, 2009 1:12 am

Hi,

I just got a new Logitech Z Cinema 2.1 sound system with integrated usb soundcard. Sound is just perfect, osstest works too, but I cant get the mixer to work. I did the ossdevlinks and ossdetect thing, restartet oss, nothing worked.
The ossmix values are kinda weird too, since everything seems to get multiplied by 257 (current value of output.vol of my paste is 25.0).

It'd be really great if anyone of you had any ideas on how to get this working with oss. I know its working on alsa (at least more or less), but I really don't want to have to use alsa just to change my volume. ;)


Here is the ossinfo -v3 (snipped the HD-Audio part):

Code: Select all
USB sound device play             /dev/oss/usb046d0a0f-1/pcm0  (device index 8)
    Legacy device /dev/dsp8
    Caps: TRIGGER MMAP
    Modes: OUTPUT
      Out engine  1: 12/USB sound device play
                     Available for use
    Input formats (0x00001000):
      AFMT_S32_LE   - 32 bit signed little endian
    Output formats (0x00001000):
      AFMT_S32_LE   - 32 bit signed little endian
    Device handle: USB-usb046d0a0f-1-au01
    Related mixer dev: 1
    Sample rate source: 12
    Preferred channel configuration: STEREO
    Supported number of channels (min - max): 2 - 2
    Native sample rates (min - max): 48000 - 48000 (48000)
    HW Type: Not indicated.
    Minimum latency: Not indicated


Nodes
  /dev/dsp -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_in -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_out -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_ac3 -> /dev/oss/oss_hdaudio0/spdout0
  /dev/dsp_mmap -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_multich -> /dev/oss/oss_hdaudio0/pcm0


And my ossmix -d1 (changing values has absolutly no effect at all):

Code: Select all
Selected mixer 1/USB sound device
Known controls are:
output.mute ON|OFF (currently OFF)
output.vol <monovol> (currently 6425)
output.bass <monovol> (currently 257)
output.treble <monovol> (currently 257)



Thanks!

McManiaC
McManiaC
New Member
 
Posts: 2
Joined: Sun Oct 11, 2009 12:55 am

Re: Logitech Z Cinema, mixer not working

Postby McManiaC » Fri Oct 30, 2009 11:34 pm

No ideas anyone?
McManiaC
New Member
 
Posts: 2
Joined: Sun Oct 11, 2009 12:55 am

Re: Logitech Z Cinema, mixer not working

Postby cesium » Sat Oct 31, 2009 12:43 am

I don't know about the device, but it may be possible to use a software mixer and modify it's volume (giving some measure of control).
I thought about attaching vmix to the device and then modifying the software mixer's volume, but there's a bug which needs to be fixed first (vmix only adds input volume display to the mixer for some reason). oss_imux driver can be used to control recording volume (see manpage) and might work though.
cesium
Developer
 
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am


Return to Linux

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron