Delta66 card ubuntu 9.10 AMD64 system -- no sound using Oss4

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

Delta66 card ubuntu 9.10 AMD64 system -- no sound using Oss4

Postby xigen » Sun Oct 11, 2009 8:38 pm

I am installing 0ss4 because of a bug in PulseAudio
https://bugs.launchpad.net/ubuntu/+sour ... bug/178442

I followed this guide:
https://help.ubuntu.com/community/OpenSound
(bottom).

$ osstest works perfectly and sounds terrific
$ ossmix see output below
$ ossinfo -v3 see output below

Also -- When I go to
System --> Preferences --> Sound
I get: "Waiting for sound system to respond"

Suggestions?

.....
wilson@wilson-desktop:~/Desktop$ ossmix
Selected mixer 0/M Audio Delta 66
Known controls are:
mon.out1/2 [<leftvol>:<rightvol>] (currently 135.0:135.0 dB)
mon.out3/4 [<leftvol>:<rightvol>] (currently 135.0:135.0 dB)
mon.spdout [<leftvol>:<rightvol>] (currently 135.0:135.0 dB)
mon.in1/2 [<leftvol>:<rightvol>] (currently 135.0:135.0 dB)
mon.in3/4 [<leftvol>:<rightvol>] (currently 135.0:135.0 dB)
mon.spdin [<leftvol>:<rightvol>] (currently 135.0:135.0 dB)
route.out1/2 <DMA|MONITOR|IN1/2|IN3/4|SPDIF> (currently DMA)
route.out3/4 <DMA|IN1/2|IN3/4|SPDIF> (currently DMA)
route.spdif <DMA|MONITOR|IN1/2|IN3/4|SPDIF> (currently DMA)
gain.out1/2 <+4DB|CONSUMER|-10DB> (currently +4DB)
gain.out3/4 <+4DB|CONSUMER|-10DB> (currently +4DB)
gain.in1/2 <+4DB|CONSUMER|-10DB> (currently +4DB)
gain.in3/4 <+4DB|CONSUMER|-10DB> (currently +4DB)
envy24.rate <8000|9600|11025|12000|16000|22050|24000|32000|44100|48000|88200|96000> (currently 48000)
envy24.sync <INTERNAL|SPDIF> (currently INTERNAL)
envy24.ratelock ON|OFF (currently ON)
envy24.actrate <decimal value> (currently 48000) (Read-only)
wilson@wilson-desktop:~/Desktop$ ossinfo -v3
Version info: OSS 4.2 (b 2000/200909100609) (0x00040100) TRIAL
Platform: Linux/x86_64 2.6.31-12-generic #41-Ubuntu SMP Wed Oct 7 19:37:12 UTC 2009 (wilson-desktop)

Number of audio devices: 9
Number of audio engines: 9
Number of MIDI devices: 0
Number of mixer devices: 1


Device objects
0: osscore0 OSS core services
1: oss_envy240 M Audio Delta 66 interrupts=15 (15)
2: oss_usb0 USB audio core services

MIDI devices (/dev/midi*)

Mixer devices
0: M Audio Delta 66 (Mixer 0 of device object 1)
Device file /dev/oss/oss_envy240/mix0, Legacy device /dev/mixer0
Priority: 0
Caps:
Device handle: PCId6321412-0000:01:07.0-mx01
Device priority: 0


Audio devices
M Audio Delta 66 out1/2 /dev/oss/oss_envy240/pcm0 (device index 0)
Legacy device /dev/dsp0
Caps: TRIGGER
Modes: OUTPUT
Out engine 1: 0/M Audio Delta 66 out1/2
Available for use
Input formats (0x00009010):
AFMT_S16_LE - 16 bit signed little endian
AFMT_S32_LE - 32 bit signed little endian
AFMT_S24_LE - 24/32 bit signed little endian
Output formats (0x00009010):
AFMT_S16_LE - 16 bit signed little endian
AFMT_S32_LE - 32 bit signed little endian
AFMT_S24_LE - 24/32 bit signed little endian
Device handle: PCId6321412-0000:01:07.0-au01
Related mixer dev: 0
Sample rate source: 0
Preferred channel configuration: STEREO
Supported number of channels (min - max): 1 - 10
Native sample rates (min - max): 8000 - 96000 (8000,9600,11025,12000,16000,22050,24000,32000,44100,48000,88200,96000)
HW Type: Not indicated.
Minimum latency: Not indicated

M Audio Delta 66 out3/4 /dev/oss/oss_envy240/pcm1 (device index 1)
Legacy device /dev/dsp1
Caps: TRIGGER
Modes: OUTPUT
Out engine 1: 1/M Audio Delta 66 out3/4
Available for use
Input formats (0x00009010):
AFMT_S16_LE - 16 bit signed little endian
AFMT_S32_LE - 32 bit signed little endian
AFMT_S24_LE - 24/32 bit signed little endian
Output formats (0x00009010):
AFMT_S16_LE - 16 bit signed little endian
AFMT_S32_LE - 32 bit signed little endian
AFMT_S24_LE - 24/32 bit signed little endian
Device handle: PCId6321412-0000:01:07.0-au02
Related mixer dev: 0
Sample rate source: 0
Preferred channel configuration: STEREO
Supported number of channels (min - max): 1 - 8
Native sample rates (min - max): 8000 - 96000 (8000,9600,11025,12000,16000,22050,24000,32000,44100,48000,88200,96000)
HW Type: Not indicated.
Minimum latency: Not indicated

M Audio Delta 66 S/PDIF out /dev/oss/oss_envy240/spdout (device index 2)
Legacy device /dev/dsp2
Caps: TRIGGER
Modes: OUTPUT
Out engine 1: 2/M Audio Delta 66 S/PDIF out
Available for use
Input formats (0x00009410):
AFMT_S16_LE - 16 bit signed little endian
AFMT_AC3 - AC3 (Dolby Digital) encoded audio
AFMT_S32_LE - 32 bit signed little endian
AFMT_S24_LE - 24/32 bit signed little endian
Output formats (0x00009410):
AFMT_S16_LE - 16 bit signed little endian
AFMT_AC3 - AC3 (Dolby Digital) encoded audio
AFMT_S32_LE - 32 bit signed little endian
AFMT_S24_LE - 24/32 bit signed little endian
Device handle: PCId6321412-0000:01:07.0-au03
Related mixer dev: 0
Sample rate source: 0
Preferred channel configuration: STEREO
Supported number of channels (min - max): 1 - 2
Native sample rates (min - max): 8000 - 96000 (8000,9600,11025,12000,16000,22050,24000,32000,44100,48000,88200,96000)
HW Type: DIGITAL_OUT Minimum latency: Not indicated

M Audio Delta 66 in1/2 /dev/oss/oss_envy240/pcmin0 (device index 3)
Legacy device /dev/dsp3
Caps: TRIGGER
Modes: INPUT
In engine 1: 3/M Audio Delta 66 in1/2
Available for use
Input formats (0x00009010):
AFMT_S16_LE - 16 bit signed little endian
AFMT_S32_LE - 32 bit signed little endian
AFMT_S24_LE - 24/32 bit signed little endian
Output formats (0x00009010):
AFMT_S16_LE - 16 bit signed little endian
AFMT_S32_LE - 32 bit signed little endian
AFMT_S24_LE - 24/32 bit signed little endian
Device handle: PCId6321412-0000:01:07.0-au04
Related mixer dev: 0
Sample rate source: 0
Preferred channel configuration: STEREO
Supported number of channels (min - max): 1 - 12
Native sample rates (min - max): 8000 - 44100 (8000,9600,11025,12000,16000,22050,24000,32000,44100,48000,88200,96000)
HW Type: Not indicated.
Minimum latency: Not indicated

M Audio Delta 66 in3/4 /dev/oss/oss_envy240/pcmin1 (device index 4)
Legacy device /dev/dsp4
Caps: TRIGGER
Modes: INPUT
In engine 1: 4/M Audio Delta 66 in3/4
Available for use
Input formats (0x00009010):
AFMT_S16_LE - 16 bit signed little endian
AFMT_S32_LE - 32 bit signed little endian
AFMT_S24_LE - 24/32 bit signed little endian
Output formats (0x00009010):
AFMT_S16_LE - 16 bit signed little endian
AFMT_S32_LE - 32 bit signed little endian
AFMT_S24_LE - 24/32 bit signed little endian
Device handle: PCId6321412-0000:01:07.0-au05
Related mixer dev: 0
Sample rate source: 0
Preferred channel configuration: STEREO
Supported number of channels (min - max): 1 - 10
Native sample rates (min - max): 8000 - 44100 (8000,9600,11025,12000,16000,22050,24000,32000,44100,48000,88200,96000)
HW Type: Not indicated.
Minimum latency: Not indicated

M Audio Delta 66 S/PDIF in /dev/oss/oss_envy240/spdin (device index 5)
Legacy device /dev/dsp5
Caps: TRIGGER
Modes: INPUT
In engine 1: 5/M Audio Delta 66 S/PDIF in
Available for use
Input formats (0x00009010):
AFMT_S16_LE - 16 bit signed little endian
AFMT_S32_LE - 32 bit signed little endian
AFMT_S24_LE - 24/32 bit signed little endian
Output formats (0x00009010):
AFMT_S16_LE - 16 bit signed little endian
AFMT_S32_LE - 32 bit signed little endian
AFMT_S24_LE - 24/32 bit signed little endian
Device handle: PCId6321412-0000:01:07.0-au06
Related mixer dev: 0
Sample rate source: 0
Preferred channel configuration: STEREO
Supported number of channels (min - max): 1 - 4
Native sample rates (min - max): 8000 - 44100 (8000,9600,11025,12000,16000,22050,24000,32000,44100,48000,88200,96000)
HW Type: Not indicated.
Minimum latency: Not indicated

M Audio Delta 66 input from mon. mixer /dev/oss/oss_envy240/mon (device index 6)
Legacy device /dev/dsp6
Caps: TRIGGER
Modes: INPUT
In engine 1: 6/M Audio Delta 66 input from mon. mixer
Available for use
Input formats (0x00009010):
AFMT_S16_LE - 16 bit signed little endian
AFMT_S32_LE - 32 bit signed little endian
AFMT_S24_LE - 24/32 bit signed little endian
Output formats (0x00009010):
AFMT_S16_LE - 16 bit signed little endian
AFMT_S32_LE - 32 bit signed little endian
AFMT_S24_LE - 24/32 bit signed little endian
Device handle: PCId6321412-0000:01:07.0-au07
Related mixer dev: 0
Sample rate source: 0
Preferred channel configuration: STEREO
Supported number of channels (min - max): 1 - 2
Native sample rates (min - max): 8000 - 44100 (8000,9600,11025,12000,16000,22050,24000,32000,44100,48000,88200,96000)
HW Type: Not indicated.
Minimum latency: Not indicated

M Audio Delta 66 (all outputs) /dev/oss/oss_envy240/10ch_out (device index 7)
Legacy device /dev/dsp7
Caps: TRIGGER MMAP
Modes: OUTPUT
Out engine 1: 7/M Audio Delta 66 (all outputs)
Available for use
Input formats (0x00001000):
AFMT_S32_LE - 32 bit signed little endian
Output formats (0x00001000):
AFMT_S32_LE - 32 bit signed little endian
Device handle: PCId6321412-0000:01:07.0-au08
Related mixer dev: 0
Sample rate source: 0
Preferred channel configuration: MULTICH
Supported number of channels (min - max): 10 - 10
Native sample rates (min - max): 8000 - 96000
HW Type: Not indicated.
Minimum latency: Not indicated

M Audio Delta 66 (all inputs) /dev/oss/oss_envy240/12ch_in (device index 8)
Legacy device /dev/dsp8
Caps: TRIGGER MMAP
Modes: INPUT
In engine 1: 8/M Audio Delta 66 (all inputs)
Available for use
Input formats (0x00001000):
AFMT_S32_LE - 32 bit signed little endian
Output formats (0x00001000):
AFMT_S32_LE - 32 bit signed little endian
Device handle: PCId6321412-0000:01:07.0-au09
Related mixer dev: 0
Sample rate source: 0
Preferred channel configuration: MULTICH
Supported number of channels (min - max): 12 - 12
Native sample rates (min - max): 8000 - 96000
HW Type: Not indicated.
Minimum latency: Not indicated


Nodes
/dev/dsp -> /dev/oss/oss_envy240/pcm0
/dev/dsp_in -> /dev/oss/oss_envy240/pcmin0
/dev/dsp_out -> /dev/oss/oss_envy240/pcm0
/dev/dsp_ac3 -> /dev/oss/oss_envy240/spdout
/dev/dsp_multich -> /dev/oss/oss_envy240/pcm0
/dev/dsp_spdifout -> /dev/oss/oss_envy240/spdout
xigen
New Member
 
Posts: 8
Joined: Sun Oct 11, 2009 8:29 pm

Re: Delta66 card ubuntu 9.10 AMD64 system -- no sound using Oss4

Postby Temüjin » Mon Oct 12, 2009 1:15 am

See this to configure gstreamer properties: viewtopic.php?f=3&t=3324#p13408

What programs have you tried to get sound from?
Temüjin
Member
 
Posts: 84
Joined: Tue Jul 24, 2007 7:55 pm
Location: Pennsylvania, USA

Re: Delta66 card ubuntu 9.10 AMD64 system -- no sound using Oss4

Postby xigen » Mon Oct 12, 2009 1:58 am

Totem Movie Player 2.28.1

Amarok 2.x

VLC ... which actually worked. Awesome!

firefox .. (youtube/flash stuff) ... no sound.

...

suggestions?
xigen
New Member
 
Posts: 8
Joined: Sun Oct 11, 2009 8:29 pm

Re: Delta66 card ubuntu 9.10 AMD64 system -- no sound using Oss4

Postby Temüjin » Mon Oct 12, 2009 2:19 am

Amarok uses xine via Phonon (unless you've configured Phonon to use the gstreamer backend), so: http://www.opensound.com/wiki/index.php ... OSSv4#xine
Totem uses gstreamer, so make sure you followed the instructions in the link I posted before.
For Flash, check to see if OSS4 installed libflashsupport.so in /usr/lib/
Temüjin
Member
 
Posts: 84
Joined: Tue Jul 24, 2007 7:55 pm
Location: Pennsylvania, USA

Re: Delta66 card ubuntu 9.10 AMD64 system -- no sound using Oss4

Postby xigen » Mon Oct 12, 2009 4:55 am

Amarok uses xine via Phonon (unless you've configured Phonon to use the gstreamer backend), so: http://www.opensound.com/wiki/index.php ... OSSv4#xine

Hmmmm...
wilson@wilson-desktop:~$ cat ~/.xine/config
cat: /home/wilson/.xine/config: No such file or directory

For Flash, check to see if OSS4 installed libflashsupport.so in /usr/lib/
It looks like libflashsupport.so is installed... however, I still do not get sound in flash video.
wilson@wilson-desktop:/usr/lib$ ls -l | grep libflashsupport.so
lrwxrwxrwx 1 root root 38 2009-10-11 11:43 libflashsupport.so -> /usr/lib/oss/lib/libflashsupport_64.so


Totem uses gstreamer, so make sure you followed the instructions in the link I posted before.
I went over your instructions -- and checked the settings.
It looks OK to me...
for screenshots .. http://ubuntuforums.org/showthread.php? ... ost8090405

suggestions?
xigen
New Member
 
Posts: 8
Joined: Sun Oct 11, 2009 8:29 pm

Re: Delta66 card ubuntu 9.10 AMD64 system -- no sound using Oss4

Postby Temüjin » Mon Oct 12, 2009 5:47 am

Flash: you're probably using 32-bit Flash through nspluginwrapper, unless you went out of your way to install the 64-bit Flash Alpha found here: http://labs.adobe.com/technologies/flas ... 64bit.html
Close Firefox or whatever browser you use and run:
Code: Select all
sudo ln -sT /usr/lib/oss/lib/libflashsupport_32.so /usr/lib32/libflashsupport.so

Start FF and test. If that doesn't work, please start FF from the terminal and see if Flash outputs anything when you try to play audio.

For xine, you can create that directory and file. You could also edit the system xine config in /etc, but it's better not to modify system configuration files when you can make per-user changes.

The following code should output a test tone (make sure your volume isn't too loud or soft)
Code: Select all
gst-launch-0.10  audiotestsrc  !  audioconvert  !  audioresample   !  osssink

If this outputs a test tone, then you probably just need to install gstreamer codecs/plugins to get sound from Totem.
Temüjin
Member
 
Posts: 84
Joined: Tue Jul 24, 2007 7:55 pm
Location: Pennsylvania, USA

Re: Delta66 card ubuntu 9.10 AMD64 system -- no sound using Oss4

Postby xigen » Mon Oct 12, 2009 7:58 am

sudo ln -sT /usr/lib/oss/lib/libflashsupport_32.so /usr/lib32/libflashsupport.so
done

Start FF and test. If that doesn't work, please start FF from the terminal and see if Flash outputs anything when you try to play audio.

No sound. Here is the output from $ firefox
when I went to youtube.

ALSA lib ../../src/conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib ../../../src/pcm/pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM default
ALSA lib ../../../src/pcm/pcm_hw.c:1433:(_snd_pcm_hw_open) Invalid value for card
ALSA lib ../../src/confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib ../../src/confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib ../../src/confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib ../../src/conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib ../../../src/pcm/pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM default
ALSA lib ../../../src/pcm/pcm_hw.c:1433:(_snd_pcm_hw_open) Invalid value for card
ALSA lib ../../src/confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib ../../src/confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib ../../src/confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib ../../src/conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib ../../../src/pcm/pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM default
ALSA lib ../../../src/pcm/pcm_hw.c:1433:(_snd_pcm_hw_open) Invalid value for card
ALSA lib ../../src/confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib ../../src/confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib ../../src/confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib ../../src/conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib ../../../src/pcm/pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM default
ALSA lib ../../../src/pcm/pcm_hw.c:1433:(_snd_pcm_hw_open) Invalid value for card
ALSA lib ../../src/confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib ../../src/confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib ../../src/confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib ../../src/conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib ../../../src/pcm/pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM default
ALSA lib ../../../src/pcm/pcm_hw.c:1433:(_snd_pcm_hw_open) Invalid value for card
ALSA lib ../../src/confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib ../../src/confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib ../../src/confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib ../../src/conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib ../../../src/pcm/pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM default
ALSA lib ../../../src/pcm/pcm_hw.c:1433:(_snd_pcm_hw_open) Invalid value for card
ALSA lib ../../src/confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib ../../src/confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib ../../src/confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib ../../src/conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib ../../../src/pcm/pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM default
ALSA lib ../../../src/pcm/pcm_hw.c:1433:(_snd_pcm_hw_open) Invalid value for card
ALSA lib ../../src/confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib ../../src/confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib ../../src/conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: N

....
The following code should output a test tone (make sure your volume isn't too loud or soft)
unfortunately.. no sound.

Suggestions?


wilson@wilson-desktop:~$ gst-launch-0.10 audiotestsrc ! audioconvert ! audioresample ! osssink
Setting pipeline to PAUSED ...
ERROR: Pipeline doesn't want to pause.
ERROR: from element /GstPipeline:pipeline0/GstOssSink:osssink0: Could not open audio device for playback. Device is being used by another application.
Additional debug info:
gstosssink.c(403): gst_oss_sink_open (): /GstPipeline:pipeline0/GstOssSink:osssink0
Setting pipeline to NULL ...
Freeing pipeline ...
wilson@wilson-desktop:~$
xigen
New Member
 
Posts: 8
Joined: Sun Oct 11, 2009 8:29 pm

Re: Delta66 card ubuntu 9.10 AMD64 system -- no sound using Oss4

Postby Temüjin » Mon Oct 12, 2009 8:11 am

About Flash: Sorry, I forgot that I built the 32-bit version myself and that you won't have it (I also forgot to tell you to run ldconfig). So:
Code: Select all
sudo rm /usr/lib32/libflashsupport.so
cd ~/
wget http://www.fileupyours.com/view/77985/libflashsupport.so
sudo chown root:root libflashsupport.so
sudo chmod 644 libflashsupport.so
sudo mv libflashsupport.so /usr/lib32/
sudo ldconfig

Now try again :P

About the gstreamer test: Did you have any other app using sound at the time? If you run 'ossxmix' is vmix available?
Last edited by Temüjin on Mon Oct 12, 2009 8:38 am, edited 1 time in total.
Temüjin
Member
 
Posts: 84
Joined: Tue Jul 24, 2007 7:55 pm
Location: Pennsylvania, USA

Re: Delta66 card ubuntu 9.10 AMD64 system -- no sound using Oss4

Postby xigen » Mon Oct 12, 2009 8:22 am

I think something is ... not quite right...
still no sound.


wilson@wilson-desktop:~$ sudo rm /usr/lib32/libflashsupport.so
[sudo] password for wilson:
wilson@wilson-desktop:~$ cd ~/
wilson@wilson-desktop:~$
wilson@wilson-desktop:~$
wilson@wilson-desktop:~$ wget http://www.fileupyours.com/view/77985/l ... support.so
--2009-10-12 01:20:14-- http://www.fileupyours.com/view/77985/l ... support.so
Resolving www.fileupyours.com... 75.125.38.53
Connecting to www.fileupyours.com|75.125.38.53|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: /files/77985/libflashsupport.so [following]
--2009-10-12 01:20:14-- http://www.fileupyours.com/files/77985/ ... support.so
Reusing existing connection to www.fileupyours.com:80.
HTTP request sent, awaiting response... 200 OK
Length: 4296 (4.2K) [application/octet-stream]
Saving to: `libflashsupport.so'

100%[======================================>] 4,296 --.-K/s in 0.06s

2009-10-12 01:20:14 (70.6 KB/s) - `libflashsupport.so' saved [4296/4296]

wilson@wilson-desktop:~$ sudo chown root:root libflashsupport.so
wilson@wilson-desktop:~$ sudo chmod 644 libflashsupport.so
wilson@wilson-desktop:~$ sudo mv libflashsupport.so
mv: missing destination file operand after `libflashsupport.so'
Try `mv --help' for more information.
wilson@wilson-desktop:~$ sudo ldconfig
wilson@wilson-desktop:~$
xigen
New Member
 
Posts: 8
Joined: Sun Oct 11, 2009 8:29 pm

Re: Delta66 card ubuntu 9.10 AMD64 system -- no sound using Oss4

Postby xigen » Mon Oct 12, 2009 8:27 am

About the gstreamer test: Did you have any other app using sound at the time? If you run 'ossxmix' is vmix available?

I had vlc running when I tried to get audio in flash to work.

$ ossxmix
brings up a lovely gui
please see:
for a picture

Here is what I get when i try vmix...
wilson@wilson-desktop:~$ vmix
No command 'vmix' found, did you mean:
Command 'wmix' from package 'wmix' (universe)
Command 'smix' from package 'siggen' (universe)
Command 'kmix' from package 'kmix' (main)
Command 'xmix' from package 'xmix' (universe)
Command 'mix' from package 'anon-proxy' (universe)
vmix: command not found
wilson@wilson-desktop:~$
xigen
New Member
 
Posts: 8
Joined: Sun Oct 11, 2009 8:29 pm

Re: Delta66 card ubuntu 9.10 AMD64 system -- no sound using Oss4

Postby Temüjin » Mon Oct 12, 2009 8:40 am

Sorry, I need sleep :/
Code: Select all
sudo mv ~/libflashsupport.so /usr/lib32/
sudo ldconfig
Temüjin
Member
 
Posts: 84
Joined: Tue Jul 24, 2007 7:55 pm
Location: Pennsylvania, USA

Re: Delta66 card ubuntu 9.10 AMD64 system -- no sound using Oss4

Postby xigen » Mon Oct 12, 2009 8:32 pm

I have sound !!! Yea.

strangely ... youtube sounds ... scratchy.

I will test more stuff and see if this is just a querk of the particular stuff I was watching. (movie previews)
xigen
New Member
 
Posts: 8
Joined: Sun Oct 11, 2009 8:29 pm

Re: Delta66 card ubuntu 9.10 AMD64 system -- no sound using Oss4

Postby xigen » Tue Oct 13, 2009 11:09 pm

I have tested a bunch of flash videos -- they sound terrible.

I wonder -- am I using a 32bit library when I need a library for AMD64?

As always -- thank you for all of your help. I really appreciate it.
xigen
New Member
 
Posts: 8
Joined: Sun Oct 11, 2009 8:29 pm

Re: Delta66 card ubuntu 9.10 AMD64 system -- no sound using Oss4

Postby Temüjin » Wed Oct 14, 2009 6:32 pm

I wonder -- am I using a 32bit library when I need a library for AMD64?


Yes, you are, because you're using a 32-bit version of Flash (Ubuntu64 uses this by default). To try the 64-bit version of Flash Alpha: http://ubuntuforums.org/showthread.php?t=1259102
Temüjin
Member
 
Posts: 84
Joined: Tue Jul 24, 2007 7:55 pm
Location: Pennsylvania, USA


Return to Linux

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 1 guest

cron