ossxmix not working in kubuntu hardy

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

ossxmix not working in kubuntu hardy

Postby phil42 » Thu Jun 03, 2010 11:57 am

i recently upgraded from 4.2-2002 to 4.2-2003, ossxmix now fails with:

root@user:~# ossxmix: symbol lookup error: ossxmix: undefined symbol: g_malloc0_n
[1]+ Exit 127 ossxmix

in 64bit kubuntu hardy heron.

ossmix works.
phil42
New Member
 
Posts: 9
Joined: Thu Jun 03, 2010 11:50 am

Re: ossxmix not working in kubuntu hardy

Postby cesium » Thu Jun 03, 2010 12:08 pm

Are libgtk2.0-0 and libglib2.0-0 packages installed?
cesium
Developer
 
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am

Re: ossxmix not working in kubuntu hardy

Postby phil42 » Thu Jun 03, 2010 12:22 pm

yes, they are installed. please note that ossxmix worked before updating to 2003.
phil42
New Member
 
Posts: 9
Joined: Thu Jun 03, 2010 11:50 am

Re: ossxmix not working in kubuntu hardy

Postby phil42 » Thu Jun 03, 2010 12:28 pm

the problem posted in this link seems very similar:
http://ubuntuforums.org/showthread.php?t=1441284
phil42
New Member
 
Posts: 9
Joined: Thu Jun 03, 2010 11:50 am

Re: ossxmix not working in kubuntu hardy

Postby cesium » Thu Jun 03, 2010 12:34 pm

Well, OSS's executables have same arch as modules, so it should be 64-bit ossxmix too.. What do 'ldd /usr/bin/ossxmix' and 'file /usr/bin/ossxmix' display?
cesium
Developer
 
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am

Re: ossxmix not working in kubuntu hardy

Postby phil42 » Thu Jun 03, 2010 12:37 pm

root@user:~# ldd /usr/bin/ossxmix
linux-vdso.so.1 => (0x00007fff08af8000)
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x00007f4ff88a6000)
libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x00007f4ff860c000)
libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x00007f4ff83ec000)
libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0x00007f4ff817b000)
libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x00007f4ff7f4f000)
libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x00007f4ff7d35000)
libm.so.6 => /lib/libm.so.6 (0x00007f4ff7ab4000)
libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x00007f4ff78a9000)
libcairo.so.2 => /usr/lib/libcairo.so.2 (0x00007f4ff763e000)
libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x00007f4ff73fa000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007f4ff717d000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00007f4ff6f4c000)
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x00007f4ff6d07000)
libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x00007f4ff6b04000)
libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0x00007f4ff6900000)
librt.so.1 => /lib/librt.so.1 (0x00007f4ff66f7000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007f4ff6437000)
libpthread.so.0 => /lib/libpthread.so.0 (0x00007f4ff621b000)
libc.so.6 => /lib/libc.so.6 (0x00007f4ff5eb9000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x00007f4ff5bb6000)
libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x00007f4ff59b4000)
libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x00007f4ff57b2000)
libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00007f4ff55ad000)
libdl.so.2 => /lib/libdl.so.2 (0x00007f4ff53a9000)
libXext.so.6 => /usr/lib/libXext.so.6 (0x00007f4ff5198000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00007f4ff4f8f000)
libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x00007f4ff4d8d000)
libXi.so.6 => /usr/lib/libXi.so.6 (0x00007f4ff4b84000)
libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x00007f4ff497d000)
libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x00007f4ff4773000)
libselinux.so.1 => /lib/libselinux.so.1 (0x00007f4ff4557000)
libz.so.1 => /usr/lib/libz.so.1 (0x00007f4ff4340000)
libpng12.so.0 => /usr/lib/libpng12.so.0 (0x00007f4ff411c000)
libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0x00007f4ff3eee000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f4ff3be3000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00007f4ff39d5000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007f4ff37b1000)
/lib64/ld-linux-x86-64.so.2 (0x00007f4ff8e75000)
libpcre.so.3 => /usr/lib/libpcre.so.3 (0x00007f4ff358b000)
libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0x00007f4ff338a000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007f4ff316f000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x00007f4ff2f6d000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007f4ff2d68000)
root@user:~#

root@user:~# file /usr/bin/ossxmix
/usr/bin/ossxmix: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), for GNU/Linux 2.6.15, dynamically linked (uses shared libs), stripped
root@user:~#
phil42
New Member
 
Posts: 9
Joined: Thu Jun 03, 2010 11:50 am

Re: ossxmix not working in kubuntu hardy

Postby cesium » Thu Jun 03, 2010 12:46 pm

This guy ended up reinstalling the distro to fix a similar issue... Try instead to reinstall libgtk2.0-0, libglib2.0-0...
cesium
Developer
 
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am

Re: ossxmix not working in kubuntu hardy

Postby phil42 » Thu Jun 03, 2010 12:54 pm

ossxmix from the 2002 .deb package works with the 2003 version.
phil42
New Member
 
Posts: 9
Joined: Thu Jun 03, 2010 11:50 am

Re: ossxmix not working in kubuntu hardy

Postby cesium » Thu Jun 03, 2010 1:08 pm

The ossxmix source hasn't changed a bit between the versions... And the build scripts are largely the same AFAIK.
cesium
Developer
 
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am

Re: ossxmix not working in kubuntu hardy

Postby phil42 » Thu Jun 03, 2010 1:11 pm

i am guessing that the users of antiquated distros will need to compile oss4 from source.
phil42
New Member
 
Posts: 9
Joined: Thu Jun 03, 2010 11:50 am

Re: ossxmix not working in kubuntu hardy

Postby phil42 » Thu Jun 03, 2010 1:24 pm

reinstalling libgtk2.0-0 and libglib2.0-0 did not help. i can't reboot now, will try that later.
phil42
New Member
 
Posts: 9
Joined: Thu Jun 03, 2010 11:50 am

Re: ossxmix not working in kubuntu hardy

Postby spinoza » Thu Jun 03, 2010 4:54 pm

I had the exact same problem when installing from the .deb, but this was fixed when installing from source (Mercurial option) according to this: https://help.ubuntu.com/community/OpenSound.
spinoza
Member
 
Posts: 11
Joined: Sun May 30, 2010 8:37 am

Re: ossxmix not working in kubuntu hardy

Postby phil42 » Fri Jun 04, 2010 10:44 pm

rebooting didn't help
phil42
New Member
 
Posts: 9
Joined: Thu Jun 03, 2010 11:50 am

Re: ossxmix not working in kubuntu hardy

Postby spinoza » Sat Jun 05, 2010 8:17 am

I should add that I am using Ubuntu 9.10, so this is probably not anything to do with you using an old distro. Have you tried the source install that I suggested?
spinoza
Member
 
Posts: 11
Joined: Sun May 30, 2010 8:37 am

Re: ossxmix not working in kubuntu hardy

Postby phil42 » Sat Jun 12, 2010 10:02 am

no, i have been using ossxmix from the -2002 .deb package
phil42
New Member
 
Posts: 9
Joined: Thu Jun 03, 2010 11:50 am

Next

Return to Linux

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 1 guest

cron