A magic patch is needed for "Google Call phone" (for OSS4)

OSS specific Linux discussion (x86/amd64)

Moderators: hannu, dev, kodachi, cesium

A magic patch is needed for "Google Call phone" (for OSS4)

Postby igorzwx » Tue Aug 31, 2010 3:49 pm

Call phone is now available in Google Mail http://www.google.com/chat/voice/
You can call to US phone numbers from any country for free. In short, calls to USA and Canada are now free (if you call from GoogleMail).

NOTE: To get "Call phones" icon in GMail, you have to change to English (US) language in the Settings of GMail.

The simplest thing to try is Google Voice/Video Chat
Video: Grandmother's Guide to Video Chat http://www.youtube.com/watch?v=CDvgjV54wIg
Gmail voice and video chat: http://gmailblog.blogspot.com/2008/11/s ... -chat.html
How to call phones from GMail: http://www.google.com/chat/voice/
Call phones from Gmail: http://gmailblog.blogspot.com/2010/08/c ... gmail.html
Make and receive calls in Gmail: http://googlevoiceblog.blogspot.com/201 ... gmail.html

To make Google Voice/Video Chat and Call phones work, you have to install "google-talkplugin". It is available for Windows XP+ / Mac OS X 10.4+ / Linux (ALSA)

For Ubuntu/Debian, they offer google-talkplugin_current_i386.deb
For Arch Linux, there is a package in AUR repository (it depends on alsa-utils).

To test how it works, I created a "real" US phone number (for free). It is real in the sense that I can receive calls on my Arch computer with Twinkle (all this is for free, of course).


Two computers:
1. Ubuntu 9.04 + OSS4 + Google Chrome web browser
2. Arch Linux + OSS4 + Twinkle, which imitates a "real" US phone

On Ubuntu 9.04, I opened my GMail account with Chrome browser, clicked on "Call phone" icon, and I was proposed to install voice plugin.
In short, the proper deb-package was installed about automatically.
Then, I dialed my "real" US phone number on Ubuntu, and Twinkle on Arch began to ring.
It works, but playback/recording does not work with google-talkplugin and OSS4.
The same problem for Google Voice/Video Chat


On Ubuntu, I enabled ALSA emulation with ~/.asoundrc
Code: Select all
   type oss
   device /dev/dsp
   type oss
   device /dev/dsp

and restarted the browser.

As a result, I got playback in "Goolge Call phone", but microphone does not work.
Thus, I can now tell something to Twinkle "US phone" and hear it in Ubuntu,
but with latency (time-delay) of about 1 second (it is too much for softphone).
The same problem for Google Voice/Video Chat

CONCLUSION: Any sort of ALSA emulation is of no use, because of latency (time-delay).

The question is, therefore, how to fix google-talkplugin for OSS4.

I made already test ALSA <-> OSS4
It works, both playback and microphone.

In short, two computers:
1. (ALSA) IBM notebook + iMic USB + Archiso LiveCD + Firefox + google-talkplugin
2. (OSS4) Arch Linux + Twinkle (which imitates a "real" US phone)

Archiso-live 20100825 Release
http://godane.wordpress.com/2010/08/25/ ... 5-release/

PulseAudio was removed, but there was still a small latency (time-delay), and ALSA sound was not very nice. However, it was already usable, actually normal. Perhaps, you cannot get anything better with ALSA.

In a word, Skype, Twinkle, and other softphones and web conferencing tools tend to compress sound to 16 kHz (or even 8 kHz) sample rate. Ordinary internal sound cards usually cannot play such things (or they have very bad resamplers inside). This actually means software resampling, and this is the reason for bad sound quality, noise, harmonic distortions, and latency (and CPU load) with ALSA and, especially, with PulseAudio.
Software resampling with ALSA means not only latency, but also overtones of 50Hz (for notebooks and netbooks with poor electromagnetic shielding), that is, unpleasant noise. The same problem is for Windows. A practical solution for both ALSA and MS Windows (to improve sound quality) is iMic USB with a cheap analog headset (earphones + mic).

NOTE: My IBM notebook has very good electromagnetic shielding, but, newertheless, you get overtones of 50Hz in the recording (with iMic USB and without), if you run Ubuntu + ALSA + PulseAudio, even if it works only on battery (!!!) - the 50Hz come from DSL modem (and PulseAudio - especially overtones).

30 EURO - Griffin iMic2 USB Audio-Adapter von Griffin (it does not work with OSS4)
http://www.amazon.de/Griffin-GC16031-iM ... 239&sr=8-1

To get a normal sound quality without audible latency, you need pure OSS4.
The best results are achieved with "Production quality" enabled.
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: A magic patch is needed for "Google Call phone" (for OSS

Postby pecijackson » Tue Jan 31, 2012 4:27 am

i'm new here and still don't understand about OSS very much. but i've tried the video call/voice call using googlemail and it works. :D
Posts: 1
Joined: Tue Jan 31, 2012 4:19 am

Re: A magic patch is needed for "Google Call phone" (for OSS

Postby igorzwx » Tue Jan 31, 2012 3:00 pm

pecijackson wrote:i'm new here and still don't understand about OSS very much. but i've tried the video call/voice call using googlemail and it works. :D

It seems that you have ALSA installed. Right?
Type on terminal:
Code: Select all
$ lsmod | grep oss
$ lsmod | grep snd
$ ossinfo

and post the output of these commands here.
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Return to Linux

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest