AudigyLS interrupts changed on reboot

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

AudigyLS interrupts changed on reboot

Postby electrosurfer » Sat Oct 09, 2010 7:16 am

Forgive me if I sound like a newbie but this is the first time I have ever asked for help after using ubuntu for 2 years.
I have been struggling for a week to seek out and find the answer to this problem on my own and am very frustrated. :?

I have a fresh, clean install of Ubuntu 10.04.1 LTS \n \l updated to kernal 2.6.32-25-generic.
After installing and updating and rebooting, I successfully replaced pulseaudio and alsamixer with oss4.2.
My sound card is a Sound Blaster X-Fi Extreme Audio pci (no e) ca0160
I ran osstest and had 5.1 working beautifully.
Then, I rebooted.
I ran osstest again and only sound came from front right, front left, center, and sub-woofer.
No sound came from surround left or surround right speakers.
I compared osstest results from before and after reboot and they match exactly.
I compared ossinfo -v3 results from before and after reboot and found this one and only mis-match between the two:

ossinfo -v3 before reboot shows: 1: oss_audigyls0 AudigyLS interrupts=744 (744)
ossinfo -v3 after reboot shows: 1: oss_audigyls0 AudigyLS interrupts=2215 (2215) :?

If this is the problem, how can I force the interrupts to where they should be and then make them stay the same on reboot?
I haven't tried yet but wonder if a work around is to run my oss4.2 installation script every time I start up :roll:

The other thing I see when I run ossinfo -v3 is this message:
tag: tip, date: Sat Sep 25 18:02:53 2010 +0300, summary: Fix a compatibility problem with Linux 2.6.36+.
Is this possible to do when the package manager shows 2.6.32.25.27 as the latest version?
Alternatively, should I try a different Linux all together such as Fedora?
electrosurfer
New Member
 
Posts: 1
Joined: Fri Oct 08, 2010 4:28 pm

Re: AudigyLS interrupts changed on reboot

Postby igorzwx » Sat Oct 09, 2010 10:14 am

electrosurfer wrote:Forgive me if I sound like a newbie but this is the first time I have ever asked for help after using ubuntu for 2 years.
I have been struggling for a week to seek out and find the answer to this problem on my own and am very frustrated. :?

I have a fresh, clean install of Ubuntu 10.04.1 LTS \n \l updated to kernal 2.6.32-25-generic.
After installing and updating and rebooting, I successfully replaced pulseaudio and alsamixer with oss4.2.
My sound card is a Sound Blaster X-Fi Extreme Audio pci (no e) ca0160
I ran osstest and had 5.1 working beautifully.
Then, I rebooted.
I ran osstest again and only sound came from front right, front left, center, and sub-woofer.
No sound came from surround left or surround right speakers.
I compared osstest results from before and after reboot and they match exactly.
I compared ossinfo -v3 results from before and after reboot and found this one and only mis-match between the two:

ossinfo -v3 before reboot shows: 1: oss_audigyls0 AudigyLS interrupts=744 (744)
ossinfo -v3 after reboot shows: 1: oss_audigyls0 AudigyLS interrupts=2215 (2215) :?

If this is the problem, how can I force the interrupts to where they should be and then make them stay the same on reboot?
I haven't tried yet but wonder if a work around is to run my oss4.2 installation script every time I start up :roll:

The other thing I see when I run ossinfo -v3 is this message:
tag: tip, date: Sat Sep 25 18:02:53 2010 +0300, summary: Fix a compatibility problem with Linux 2.6.36+.
Is this possible to do when the package manager shows 2.6.32.25.27 as the latest version?
Alternatively, should I try a different Linux all together such as Fedora?


Do you want to prevent changes during reboot?
I solved this problem though the help of immutable bit.

The problem was that mic did not work on ICH6 after the first reboot.
An "optimal solution" was found by "trial and error".
Some folders were made immutable (recursively):
/usr/lib/oss/conf
/usr/lib/oss/etc
In this case, kernel upgrades do not create any problem.
The oss-package was made non-upgradable (it was recompiled to enable "production quality").

NOTE: Before changing anything in a working system, it might be reasonable to train with Arch LiveCD (it has OSS4 inside) viewtopic.php?f=3&t=3933

electrosurfer wrote:Alternatively, should I try a different Linux all together such as Fedora?


Arch Linux seems to be a distro for very lazy users (like me). It has a very simple design and a small Wiki (which is sufficient). Therefore, you do not need to think and read too much.
http://wiki.archlinux.org/index.php/Beginners'_Guide

On Arch, almost everything is installed with one command:

Code: Select all
# pacman -S oss

$ yaourt skype-oss
1 community/skype-oss 2.0.0.72-2 [installed]
    P2P software for high-quality voice communication (OSS-compatible version)
2 aur/bin32-skype-oss 2.0.0.72-3 (52)
    P2P software for high-quality voice communication (OSS-compatible version)
==> Enter n° (separated by blanks, or a range) of packages to be installed
==> ----------------------------------------------------------------------
==>
igorzwx
Known Member
 
Posts: 1001
Joined: Sun Jun 28, 2009 9:31 pm

Re: AudigyLS interrupts changed on reboot

Postby cesium » Sun Oct 10, 2010 6:24 pm

The interrupts line usually doesn't matter much.

Before going to all that effort, can you paste here the output of 'ossinfo -v3' and of 'ossmix'? Also, is it the X-Fi driver or AudigyLS driver or hdaudio compat (some X-Fis have hdaudio compat mode)? I have some ideas:

A. Maybe the mixer has some wrong defs. If it's the audigyls driver, Try enabling "spread" option in the mixer. 'ossmix' output can help here.
B. Maybe it worked the first time because ALSA inited the card? You can try loading ALSA manually**, and than running soundon.

** cd /lib/modules/$(uname -r); sudo tar xvf sound-preoss.tar.bz2; sudo depmod -a; sudo soundoff; sudo modprobe snd[something like that]; sudo soundon
cesium
Developer
 
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am


Return to Linux

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron