Recording external input

OSS specific Linux discussion (x86/amd64)

Moderators: hannu, dev, cesium, kodachi

Recording external input

Postby sev » Mon Dec 06, 2010 7:11 pm

Hi

I am unable to record sound that I input to my m-audio 2496.Capturing on board sound is fine.
When trying to record input,I can hear it but nothing registers on the peak out 1/2 fader level
Any ideas?

Code: Select all
sevy@sevy-desktop:~$ ossinfo
Version info: OSS 4.2 (b 2002/201012061830) (0x00040100) OSS_HG
Hg revision: changeset: 874:3c6677155802, tag: tip, date: Sat Nov 07 10:17:46 2009 +0200, summary: Changed build ID to v4.2-build2002
Platform: Linux/i686 2.6.35-23-generic #41-Ubuntu SMP Wed Nov 24 10:18:49 UTC 2010 (sevy-desktop)

Number of audio devices:   8
Number of audio engines:   12
Number of MIDI devices:      1
Number of mixer devices:   1


Device objects
0: osscore0 OSS core services
1: oss_envy240 M Audio Audiophile 2496 interrupts=79716 (79716)
2: oss_usb0 USB audio core services

MIDI devices (/dev/midi*)
0: M Audio Audiophile 2496 #1 (MIDI port 1 of device object 1)

Mixer devices
0: M Audio Audiophile 2496 (Mixer 0 of device object 1)

Audio devices
M Audio Audiophile 2496 out1/2    /dev/oss/oss_envy240/pcm0  (device index 0)
M Audio Audiophile 2496 S/PDIF out   /dev/oss/oss_envy240/spdout  (device index 1)
M Audio Audiophile 2496 in1/2     /dev/oss/oss_envy240/pcmin0  (device index 2)
M Audio Audiophile 2496 S/PDIF in   /dev/oss/oss_envy240/spdin  (device index 3)
M Audio Audiophile 2496 input from mon. mixer   /dev/oss/oss_envy240/mon  (device index 4)
M Audio Audiophile 2496 (all outputs)  /dev/oss/oss_envy240/10ch_out  (device index 5)
M Audio Audiophile 2496 (all inputs)  /dev/oss/oss_envy240/12ch_in  (device index 6)
M Audio Audiophile 2496 out1/2 (vmix) loopback record  /dev/oss/oss_envy240/loop0  (device index 7)

Nodes
  /dev/dsp -> /dev/oss/oss_envy240/pcm0
  /dev/dsp_in -> /dev/oss/oss_envy240/pcmin0
  /dev/dsp_out -> /dev/oss/oss_envy240/pcm0
  /dev/dsp_ac3 -> /dev/oss/oss_envy240/spdout
  /dev/dsp_mmap -> /dev/oss/oss_envy240/pcm0
  /dev/dsp_multich -> /dev/oss/oss_envy240/pcm0
  /dev/dsp_spdifout -> /dev/oss/oss_envy240/spdout
sevy@sevy-desktop:~$
sev
 
Posts: 9
Joined: Sun Jun 13, 2010 9:33 pm

Re: Recording external input

Postby sev » Mon Dec 06, 2010 7:47 pm

When I try to record and then dmesg I get this error

Code: Select all
[13848.889683] copy_to_user(512) failed (1)
[13848.889690] osscore: audio: uiomove(UIO_READ) failed
sev
 
Posts: 9
Joined: Sun Jun 13, 2010 9:33 pm

Re: Recording external input

Postby sev » Mon Dec 06, 2010 8:38 pm

OK Ive got it working,just had to change the ossrecord command :oops:
Now Ive got to get audacity to record :x
sev
 
Posts: 9
Joined: Sun Jun 13, 2010 9:33 pm


Return to Linux

Who is online

Users browsing this forum: Yahoo [Bot] and 8 guests