[SOLVED] No sound at all

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

Re: No sound at all

Postby yonyz » Tue Dec 21, 2010 9:04 am

Damn. No sound again, because I shut the computer down last night. What can I do to bring it back? Reinstall after every reboot?
yonyz
Member
 
Posts: 14
Joined: Mon Dec 20, 2010 12:01 pm

Re: No sound at all

Postby igorzwx » Tue Dec 21, 2010 9:49 am

yonyz wrote:Damn. No sound again, because I shut the computer down last night. What can I do to bring it back? Reinstall after every reboot?


Don't panic!
Type on terminal:

Code: Select all
$ lspci -v


and post the output here.

And also this:

Code: Select all
$ ossmix
igorzwx
Known Member
 
Posts: 1004
Joined: Sun Jun 28, 2009 9:31 pm

Re: No sound at all

Postby yonyz » Tue Dec 21, 2010 3:00 pm

Code: Select all
yonyz@yonyz-Ubuntu:~$ lspci -v
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
   Subsystem: Giga-byte Technology Device 5000
   Flags: bus master, fast devsel, latency 0
   Capabilities: <access denied>
   Kernel modules: intel-agp

00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 02) (prog-if 00 [Normal decode])
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
   I/O behind bridge: 0000a000-0000afff
   Memory behind bridge: f4000000-f7ffffff
   Prefetchable memory behind bridge: 00000000e0000000-00000000efffffff
   Capabilities: <access denied>
   Kernel driver in use: pcieport
   Kernel modules: shpchp

00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02) (prog-if 00 [UHCI])
   Subsystem: Giga-byte Technology Device 5004
   Flags: bus master, medium devsel, latency 0, IRQ 16
   I/O ports at e000 [size=32]
   Capabilities: <access denied>
   Kernel driver in use: uhci_hcd

00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02) (prog-if 00 [UHCI])
   Subsystem: Giga-byte Technology Device 5004
   Flags: bus master, medium devsel, latency 0, IRQ 21
   I/O ports at e100 [size=32]
   Capabilities: <access denied>
   Kernel driver in use: uhci_hcd

00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02) (prog-if 00 [UHCI])
   Subsystem: Giga-byte Technology Device 5004
   Flags: bus master, medium devsel, latency 0, IRQ 18
   I/O ports at e500 [size=32]
   Capabilities: <access denied>
   Kernel driver in use: uhci_hcd

00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02) (prog-if 20 [EHCI])
   Subsystem: Giga-byte Technology Device 5006
   Flags: bus master, medium devsel, latency 0, IRQ 18
   Memory at fa201000 (32-bit, non-prefetchable) [size=1K]
   Capabilities: <access denied>
   Kernel driver in use: ehci_hcd

00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02) (prog-if 00 [Normal decode])
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
   I/O behind bridge: 00009000-00009fff
   Memory behind bridge: 7ff00000-800fffff
   Prefetchable memory behind bridge: 0000000080100000-00000000802fffff
   Capabilities: <access denied>
   Kernel driver in use: pcieport
   Kernel modules: shpchp

00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 02) (prog-if 00 [Normal decode])
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
   I/O behind bridge: 0000b000-0000bfff
   Memory behind bridge: fa000000-fa0fffff
   Prefetchable memory behind bridge: 0000000080300000-00000000804fffff
   Capabilities: <access denied>
   Kernel driver in use: pcieport
   Kernel modules: shpchp

00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 02) (prog-if 00 [Normal decode])
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=04, subordinate=04, sec-latency=0
   I/O behind bridge: 0000c000-0000cfff
   Memory behind bridge: f8000000-f9ffffff
   Prefetchable memory behind bridge: 0000000080500000-00000000806fffff
   Capabilities: <access denied>
   Kernel driver in use: pcieport
   Kernel modules: shpchp

00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02) (prog-if 00 [UHCI])
   Subsystem: Giga-byte Technology Device 5004
   Flags: bus master, medium devsel, latency 0, IRQ 23
   I/O ports at e200 [size=32]
   Capabilities: <access denied>
   Kernel driver in use: uhci_hcd

00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02) (prog-if 00 [UHCI])
   Subsystem: Giga-byte Technology Device 5004
   Flags: bus master, medium devsel, latency 0, IRQ 19
   I/O ports at e300 [size=32]
   Capabilities: <access denied>
   Kernel driver in use: uhci_hcd

00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02) (prog-if 00 [UHCI])
   Subsystem: Giga-byte Technology Device 5004
   Flags: bus master, medium devsel, latency 0, IRQ 18
   I/O ports at e400 [size=32]
   Capabilities: <access denied>
   Kernel driver in use: uhci_hcd

00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02) (prog-if 20 [EHCI])
   Subsystem: Giga-byte Technology Device 5006
   Flags: bus master, medium devsel, latency 0, IRQ 23
   Memory at fa200000 (32-bit, non-prefetchable) [size=1K]
   Capabilities: <access denied>
   Kernel driver in use: ehci_hcd

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92) (prog-if 01 [Subtractive decode])
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=05, subordinate=05, sec-latency=32
   I/O behind bridge: 0000d000-0000dfff
   Memory behind bridge: fa100000-fa1fffff
   Capabilities: <access denied>

00:1f.0 ISA bridge: Intel Corporation 82801IR (ICH9R) LPC Interface Controller (rev 02)
   Subsystem: Giga-byte Technology Device 5001
   Flags: bus master, medium devsel, latency 0
   Capabilities: <access denied>
   Kernel modules: iTCO_wdt

00:1f.2 IDE interface: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA IDE Controller (rev 02) (prog-if 8a [Master SecP PriP])
   Subsystem: Giga-byte Technology Device b002
   Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 19
   I/O ports at 01f0 [size=8]
   I/O ports at 03f4 [size=1]
   I/O ports at 0170 [size=8]
   I/O ports at 0374 [size=1]
   I/O ports at f000 [size=16]
   I/O ports at fc00 [size=16]
   Capabilities: <access denied>
   Kernel driver in use: ata_piix

00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
   Subsystem: Giga-byte Technology Device 5001
   Flags: medium devsel, IRQ 9
   Memory at fa202000 (64-bit, non-prefetchable) [size=256]
   I/O ports at 0500 [size=32]
   Kernel modules: i2c-i801

00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA IDE Controller (rev 02) (prog-if 85 [Master SecO PriO])
   Subsystem: Giga-byte Technology Device b002
   Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 19
   I/O ports at e700 [size=8]
   I/O ports at e800 [size=4]
   I/O ports at e900 [size=8]
   I/O ports at ea00 [size=4]
   I/O ports at eb00 [size=16]
   I/O ports at ec00 [size=16]
   Capabilities: <access denied>
   Kernel driver in use: ata_piix

01:00.0 VGA compatible controller: nVidia Corporation G92 [GeForce GTS 250] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: CardExpert Technology Device 0401
   Flags: bus master, fast devsel, latency 0, IRQ 16
   Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
   Memory at e0000000 (64-bit, prefetchable) [size=256M]
   Memory at f4000000 (64-bit, non-prefetchable) [size=32M]
   I/O ports at a000 [size=128]
   [virtual] Expansion ROM at f7000000 [disabled] [size=128K]
   Capabilities: <access denied>
   Kernel driver in use: nvidia
   Kernel modules: nvidia-current, nouveau, nvidiafb

03:00.0 SATA controller: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 02) (prog-if 01 [AHCI 1.0])
   Subsystem: Giga-byte Technology GA-EP45-DS5 Motherboard
   Flags: bus master, fast devsel, latency 0, IRQ 19
   Memory at fa000000 (32-bit, non-prefetchable) [size=8K]
   Capabilities: <access denied>
   Kernel driver in use: ahci
   Kernel modules: ahci

03:00.1 IDE interface: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 02) (prog-if 85 [Master SecO PriO])
   Subsystem: Giga-byte Technology GA-EP45-DS5 Motherboard
   Flags: bus master, fast devsel, latency 0, IRQ 16
   I/O ports at b000 [size=8]
   I/O ports at b100 [size=4]
   I/O ports at b200 [size=8]
   I/O ports at b300 [size=4]
   I/O ports at b400 [size=16]
   Capabilities: <access denied>
   Kernel driver in use: pata_jmicron
   Kernel modules: pata_jmicron

04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
   Subsystem: Giga-byte Technology GA-EP45-DS5 Motherboard
   Flags: bus master, fast devsel, latency 0, IRQ 44
   I/O ports at c000 [size=256]
   Memory at f9000000 (64-bit, non-prefetchable) [size=4K]
   [virtual] Expansion ROM at 80500000 [disabled] [size=128K]
   Capabilities: <access denied>
   Kernel driver in use: r8169
   Kernel modules: r8169

05:00.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)
   Subsystem: Device 3031:4553
   Flags: bus master, medium devsel, latency 32, IRQ 20
   I/O ports at d000 [size=32]
   I/O ports at d100 [size=128]
   Capabilities: <access denied>
   Kernel driver in use: oss_envy24ht
   Kernel modules: snd-ice1724

05:01.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev 46) (prog-if 10 [OHCI])
   Flags: bus master, stepping, medium devsel, latency 32, IRQ 19
   Memory at fa100000 (32-bit, non-prefetchable) [size=2K]
   I/O ports at d200 [size=128]
   Capabilities: <access denied>
   Kernel driver in use: firewire_ohci
   Kernel modules: firewire-ohci, ohci1394


Code: Select all
yonyz@yonyz-Ubuntu:~$ ossmix
Selected mixer 0/Ego Systems Juli@
Known controls are:
route.front <DMA|ANALOGIN|DIGITALIN> (currently DMA)
route.spdifout <DMA|ANALOGIN|DIGITALIN> (currently DMA)
envy24.rate <8000|9600|11025|12000|16000|22050|24000|32000|44100|48000|64000|88200|96000|176400|192000> (currently 48000)
envy24.sync <INTERNAL|SPDIF> (currently INTERNAL)
envy24.src ON|OFF (currently OFF)
envy24.ratelock ON|OFF (currently OFF)
envy24.actrate <decimal value> (currently 48000) (Read-only)
vol.mute ON|OFF (currently OFF)
vol.pcm [<leftvol>:<rightvol>] (currently 0:0)
vol.linein [<leftvol>:<rightvol>] (currently 0:0)
vol.spdifout [<leftvol>:<rightvol>] (currently 0:0)
vol.spdifin [<leftvol>:<rightvol>] (currently 0:0)
monitor.linein ON|OFF (currently OFF)
monitor.spdifout ON|OFF (currently OFF)
monitor.spdifin ON|OFF (currently OFF)
monitor.deemph <OFF|50/15usec> (currently OFF)
spdif.audio <AUDIO|DATA> (currently AUDIO)
spdif.vbit ON|OFF (currently OFF)
spdif.preemph <OFF|50/16usec> (currently OFF)
spdif.mode <CONSUMER|PRO> (currently CONSUMER)
spdif.copyright <YES|NO> (currently YES)
spdif.generat <COPY|ORIGINAL> (currently COPY)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-src <Fast|High|High+|Production|OFF> (currently Production)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm4 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm5 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm6 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm7 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
yonyz
Member
 
Posts: 14
Joined: Mon Dec 20, 2010 12:01 pm

Re: No sound at all

Postby igorzwx » Tue Dec 21, 2010 4:28 pm

Look here:
Code: Select all
vol.pcm [<leftvol>:<rightvol>] (currently 0:0)


This means that sound is muted in the mixer.

Run "ossxmix" and set it right

Or from terminal:

Code: Select all
$ ossmix vol.pcm 50:50


"ossxmix" is OSS Mixer (GUI). You can start is from terminal with command

Code: Select all
$ ossxmix


"ossmix" is OSS Mixer "command line" (without GUI).

There is a command "savemixer"
Read this:
http://man.cx/savemixer(1)

There is also a script /usr/lib/oss/soundon.user
igorzwx
Known Member
 
Posts: 1004
Joined: Sun Jun 28, 2009 9:31 pm

Re: No sound at all

Postby yonyz » Tue Dec 21, 2010 5:56 pm

I looked at the mixer, and it's not muted. Therefore, running the command change nothing as well.
As always, the mixer does show audio activity when playing media files.

Edit:Holy sh*t, there IS sound. It's just very, very very quiet. In fact, I have to set my speakers to maximum volume just to hear words (in movies) properly. The volume is the same on YouTube, VLC and everything else, so it's definitely an OSS problem.
yonyz
Member
 
Posts: 14
Joined: Mon Dec 20, 2010 12:01 pm

Re: No sound at all

Postby igorzwx » Tue Dec 21, 2010 6:08 pm

yonyz wrote:I looked at the mixer, and it's not muted. Therefore, running the command change nothing as well.
As always, the mixer does show audio activity when playing media files.

Edit:Holy sh*t, there IS sound. It's just very, very very quiet. In fact, I have to set my speakers to maximum volume just to hear words (in movies) properly. The volume is the same on YouTube, VLC and everything else, so it's definitely an OSS problem.


Run this command:

Code: Select all
$ ossmix vol.pcm 70:70 && ossmix | grep vol


and post the output here.

You may also try this command:

Code: Select all
$ cat /dev/urandom >/dev/dsp


It should play "white noise" through the speaker.
igorzwx
Known Member
 
Posts: 1004
Joined: Sun Jun 28, 2009 9:31 pm

Re: No sound at all

Postby yonyz » Tue Dec 21, 2010 6:29 pm

The white noise's volume is much better. It is audible at the lowest speaker volume.
Here are the results of the other command:
Code: Select all
yonyz@yonyz-Ubuntu:~$ ossmix vol.pcm 70:70 && ossmix | grep vol
Value of mixer control vol.pcm set to 70.0:70.0
vol.mute ON|OFF (currently OFF)
vol.pcm [<leftvol>:<rightvol>] (currently 70:70)
vol.linein [<leftvol>:<rightvol>] (currently 0:0)
vol.spdifout [<leftvol>:<rightvol>] (currently 0:0)
vol.spdifin [<leftvol>:<rightvol>] (currently 0:0)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm4 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm5 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm6 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm7 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
yonyz
Member
 
Posts: 14
Joined: Mon Dec 20, 2010 12:01 pm

Re: No sound at all

Postby igorzwx » Tue Dec 21, 2010 6:32 pm

If you hear "white noise", it works.
Does "osstest" play music?

On terminal:

Code: Select all
$ osstest
igorzwx
Known Member
 
Posts: 1004
Joined: Sun Jun 28, 2009 9:31 pm

Re: No sound at all

Postby yonyz » Tue Dec 21, 2010 7:08 pm

It plays, but at a low volume.
yonyz
Member
 
Posts: 14
Joined: Mon Dec 20, 2010 12:01 pm

Re: No sound at all

Postby igorzwx » Tue Dec 21, 2010 7:10 pm

yonyz wrote:It plays, but at a low volume.


If osstest plays music everything works.
igorzwx
Known Member
 
Posts: 1004
Joined: Sun Jun 28, 2009 9:31 pm

Re: No sound at all

Postby yonyz » Tue Dec 21, 2010 7:13 pm

*facepalm*

I was wrong all along. The volume was actually set to the lowest, but looking at it, I thought it was actually set to max. I just didn't read the volume controls properly. I thought that when those blue bars appear, that means the volume is set to max, but it's exactly the opposite. So, bottom line, the problem is fixed, and I can hear just fine, volume-wise. Sorry for wasting your time. :|
And of course, thank you for your help all along. :)
yonyz
Member
 
Posts: 14
Joined: Mon Dec 20, 2010 12:01 pm

Previous

Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest