[solved] ERROR: Module <foo> in use and noise problem

OSS specific Linux discussion (x86/amd64)

Moderators: hannu, dev, kodachi, cesium

[solved] ERROR: Module <foo> in use and noise problem

Postby nexx » Fri Jan 07, 2011 9:16 am

Hi folks,

I just compiled and installed (via .deb) OSS4 on my squeeze machine yesterday, it ran fine. Turning on the PC today, no sound. If I do soundon, this is the output:

Code: Select all
ERROR: Module snd_seq is in use
ERROR: Module snd_timer is in use by snd_seq
ERROR: Module snd_seq_device is in use by snd_seq


No /dev/dsp* symlinks and no /dev/oss folder (guess they get created on oss start?). Of course, i cant to ossinfo etc. now.

Some data:
Squeeze 64bit
Kernel 2.6.32-5
oss v4.2-2004 (code from januar 5th) with no errors/issues at building, everything like charm
Creative SB Audigy 1

cat /var/log/soundon.log
Code: Select all
Open Sound System starting Fr 7. Jan 10:10:17 CET 2011
OSS version:  4.2 (b 2004/201101062104)
Kernel version:  2.6.32-5-amd64
Kernel vermagic:  2.6.32-5-amd64 SMP mod_unload modversions
OSS    vermagic:  2.6.32-5-amd64 SMP mod_unload modversions
killing
Cannot find any processes using the conflicting sound driver


If you need more infos, let me know.

Edit: concerning the noise problem: see the last posts.
Last edited by nexx on Sun Jan 09, 2011 5:16 pm, edited 2 times in total.
nexx
 
Posts: 18
Joined: Fri Feb 19, 2010 6:56 pm

Re: ERROR: Module <foo> in use

Postby nexx » Fri Jan 07, 2011 10:32 am

I just installed the *deb again, now it works.
Seems as if alsa is starting on boot and blocks the modules?!? There was/is at least no alsa-process...

Code: Select all
Shutting down ALSA...warning: 'alsactl store' failed with error message 'alsactl: save_state:1504: No soundcards found...'...failed.
Terminating processes: 1538.
Unloading ALSA sound driver modules: snd-seq snd-timer snd-seq-device.


That was the message i got while dpkg -i oss.deb

So it definately has got something to do with alsa. Cant get if myself, help needed :)
nexx
 
Posts: 18
Joined: Fri Feb 19, 2010 6:56 pm

Re: ERROR: Module <foo> in use

Postby igorzwx » Fri Jan 07, 2011 12:19 pm

You may try to blacklist ALSA modules.
Read this: https://help.ubuntu.com/community/OpenS ... acklisting ALSA Kernel Modules
and this: http://brainstorms.in/?p=172

Usually, it works perfectly, but it can also produce problems. That is why Cesium claims that you should not do that.
It depends on the particular soundcard.

Arch Wiki also recommends to blacklist ALSA modules https://wiki.archlinux.org/index.php/OSS#Install

Install OSS by running:

Code: Select all
# pacman -S oss


This will install the OSS files and run the OSS install script that will temporarily disable the ALSA modules, and install the OSS kernel modules. Since ALSA is enabled by default in the boot scripts, you need to disable it for it not to conflict with OSS when booting. You can do this by editing rc.conf and adding:

Code: Select all
MODULES=(!soundcore ...


EDIT: You can make experiments with Arch LiveCD

EXPERIMENT 1:
1. boot Arch LiveCD
2. install OSS over ALSA

EXPERIMENT 2:
1. boot Arch LiveCD
2. unload ALSA modules
3. install OSS

The manual is here: viewtopic.php?f=3&t=3933

EXPERIMENT 3: Compile OSS on Arch LiveCD and try to install it (see Experiments 1 and 2).
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: ERROR: Module <foo> in use

Postby nexx » Fri Jan 07, 2011 2:34 pm

Thanks igor, I removed alsa-utils and alsa-base and did a dpkg-reconfigure linux-sound-base. soundoff & soundon works well, even vmix works now! This is very nice, just gonna test if it works after reboot, but it guess it will.
nexx
 
Posts: 18
Joined: Fri Feb 19, 2010 6:56 pm

Re: ERROR: Module <foo> in use

Postby igorzwx » Fri Jan 07, 2011 2:38 pm

I had very strange problems with OSS4, ICH7, and Ubuntu 8.04
To have mic working, you have to install OSS over ALSA. However, it does not work after the first reboot.

EDIT: It makes sense to reboot several times and test everything carefully.
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: ERROR: Module <foo> in use

Postby nexx » Sat Jan 08, 2011 7:19 am

Everything works fine! Except for one thing... I got noise when vmix0 is enabled, but not on every output. Sometimes (e.g. on pause/play of the media player) its noise, sometimes the normal music.
But thats worth some searching in the forum or yet another topic :p

Again, thanks igor!
nexx
 
Posts: 18
Joined: Fri Feb 19, 2010 6:56 pm

Re: [solved] ERROR: Module <foo> in use

Postby nexx » Sat Jan 08, 2011 7:46 am

Wehey, there just came an remembrance! If i'm not totally wrong, i had a patched oss_sblive.c which removed the noise... I guess i had it from somewhere in the forum, lets see if i find it

Yes!
Here is the patch for sblive_c
http://4front-tech.com/forum/viewtopic. ... 932#p16277

Well, this time the patch didnt work. Too bad...
nexx
 
Posts: 18
Joined: Fri Feb 19, 2010 6:56 pm

Re: [solved] ERROR: Module <foo> in use

Postby igorzwx » Sat Jan 08, 2011 11:03 am

nexx wrote:Wehey, there just came an remembrance! If i'm not totally wrong, i had a patched oss_sblive.c which removed the noise... I guess i had it from somewhere in the forum, lets see if i find it

Yes!
Here is the patch for sblive_c
http://4front-tech.com/forum/viewtopic. ... 932#p16277

Well, this time the patch didnt work. Too bad...


Have you tried to correct those lines by hand?

If your patch is this http://4front-tech.com/forum/viewtopic. ... 932#p16277 , you have to correct file
/kernel/drv/oss_sblive/oss_sblive.c

In any case, you can open a patch with Meld, and see what is inside.

The old patch may not work, simply because the devs added a few lines to the code,
or because the code is already patched (you should see this in the terminal messages).

It is not difficult to make your own patches https://wiki.archlinux.org/index.php/Patching_in_ABS

EDIT: If vmix is enabled, noise can be caused by buggy resamplers. In essence, vmix is a kind of PulseAudio.

http://www.4front-tech.com/forum/viewtopic.php?f=19&t=4206
Thu Jan 06, 2011 6:11 am
Open Sound System v4.2 build 2004 has been announced for Linux (x86/amd64), Solaris (x86, amd64, sparc), FreeBSD 8 (x86, amd64), UnixWare, and Open Server.

* Added channel mapping to VMIX
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: [solved] ERROR: Module <foo> in use

Postby nexx » Sat Jan 08, 2011 12:27 pm

@igor:

Yes, i changed the line by hand. The only change is from 32 to 31, so it was kinda quick ;)
The file wasnt patched.
Well, without vmix i got no noise, correct. But the problem is, then i can only have _one_ output at a time, e.g. no flash-sound if the music player is running. Thats more than annoying, so vmix gotta stay enabled...
nexx
 
Posts: 18
Joined: Fri Feb 19, 2010 6:56 pm

Re: [solved] ERROR: Module <foo> in use

Postby igorzwx » Sat Jan 08, 2011 12:41 pm

nexx wrote:@igor:

Yes, i changed the line by hand. The only change is from 32 to 31, so it was kinda quick ;)
The file wasnt patched.
Well, without vmix i got no noise, correct. But the problem is, then i can only have _one_ output at a time, e.g. no flash-sound if the music player is running. Thats more than annoying, so vmix gotta stay enabled...


If I understood you correctly, a similar problem was reported here: viewtopic.php?f=3&t=4159
Perhaps, it might be reasonable to try to find out the cause of noise.
You may try to ask Cesium https://help.ubuntu.com/community/OpenSound#IRC
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: [solved] ERROR: Module <foo> in use

Postby nexx » Sat Jan 08, 2011 12:50 pm

igorzwx wrote:You may try to ask Cesium https://help.ubuntu.com/community/OpenSound#IRC


I am permanently in this irc-channel, but cesium isnt there very often.
Well, in fact my problem is the other way around: no problems without vmix, noise with vmix
The other topic is quite abstract for me, gotta fight me through first ;)

Edit:
fiddled around a bit in ossxmix. dependant on the chosen vmix0-src, the noise comes more frequently. on "fast" its the most likely to get noise, "high" and "off" get noise a lot less often. but its still there. changing the value of "spkmode" doesnt change anything. setting down the vmix0-outvol, too.
Last edited by nexx on Sat Jan 08, 2011 1:05 pm, edited 1 time in total.
nexx
 
Posts: 18
Joined: Fri Feb 19, 2010 6:56 pm

Re: [solved] ERROR: Module <foo> in use

Postby igorzwx » Sat Jan 08, 2011 12:59 pm

nexx wrote:
igorzwx wrote:You may try to ask Cesium https://help.ubuntu.com/community/OpenSound#IRC


I am permanently in this irc-channel, but cesium isnt there very often.
The other topic is quite abstract for me, gotta fight me through first ;)


You may try a kind of "experimental physics".
1. Try to reproduce noise on Arch LiveCD viewtopic.php?f=3&t=3933#p16711
2. Try different players.
3. Try to remove "libpulse".
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: [solved] ERROR: Module <foo> in use

Postby nexx » Sun Jan 09, 2011 5:15 pm

I guess my noise/distortion problem is gone now.
I applied the following patch to osscore.c, recompiled & reinstalled oss and everythings fine now ;)

Code: Select all
diff -r 09a210f84f55 setup/Linux/oss/build/osscore.c
--- a/setup/Linux/oss/build/osscore.c   Thu Jan 06 07:55:36 2011 +0200
+++ b/setup/Linux/oss/build/osscore.c   Sat Jan 08 17:42:37 2011 +0200
@@ -808,7 +808,7 @@
     flags |= GFP_DMA32;
#endif

-  if (memlimit < 0x00000000ffffffffLL)
+  if (memlimit <= 0x00000000ffffffffLL)
     flags |= GFP_DMA;

   start_addr = NULL;


A former patch to the oss_sblive.c did not work, though it worked in the 2003 release.

So finally, this thread deserves its [solved]-state ;)

Thanks to the helpers igor and cesium!
nexx
 
Posts: 18
Joined: Fri Feb 19, 2010 6:56 pm


Return to Linux

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 6 guests