Distortion in output + balance

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

Distortion in output + balance

Postby Jack » Sun Jan 23, 2011 9:58 pm

Hi all, just installed OSS, much less PITA than pulse, though I do have a couple of issues, wondering if it's anything in the scope of OSS.

1. If sound output gets too loud on a software level (reaches the "yellow" portion of the meter in ossxmix) it crackles and distorts. Adjusting the PCM values doesn't seem to change anything as it did in alsamixer.

2. Output is imbalanced. The left channel is much quieter than the right; I have to lower the right channel's volume by about half to balance it, and this means that I can't get output as loud as I'd sometimes like it before it starts distorting.

Any idea what I could check? Thanks.
Jack
New Member
 
Posts: 4
Joined: Sun Jan 23, 2011 9:54 pm

Re: Distortion in output + balance

Postby igorzwx » Sun Jan 23, 2011 10:14 pm

Perhaps, you have a BETA driver, or you did something wrong. It may also depend on how you install OSS4.
Did you really remove PulseAudio? Had you blacklisted ALSA modules before installing OSS4?

It might be difficult to help you, because you do not provide any information about your hardware and operating system.

Code: Select all
$ lspci -v
$ ossinfo
$ ossmix


etc.
Last edited by igorzwx on Sun Jan 23, 2011 10:50 pm, edited 1 time in total.
igorzwx
Supporter
 
Posts: 987
Joined: Sun Jun 28, 2009 9:31 pm

Re: Distortion in output + balance

Postby Jack » Sun Jan 23, 2011 10:45 pm

Oh yeah, sorry, forgot all the basics.

Linux old-rusty 2.6.36-gentoo-r5 #1 SMP Sun Jan 23 14:43:47 CST 2011 x86_64 AMD Phenom(tm) 9150e Quad-Core Processor AuthenticAMD GNU/Linux

lspci -v: http://paste.pocoo.org/show/325702/
ossinfo: http://paste.pocoo.org/show/325703/
ossmix: http://paste.pocoo.org/show/325704/

I probably did something wrong, it's usually how it goes. :P
Jack
New Member
 
Posts: 4
Joined: Sun Jan 23, 2011 9:54 pm

Re: Distortion in output + balance

Postby igorzwx » Sun Jan 23, 2011 11:00 pm

This soundcard should work without problems.

You may test it with Arch LiveCDs
viewtopic.php?f=3&t=3933#p15851

There are several Archiso LiveCDs, there is also Chakra LiveCD for 64bit.
You may find one which is bootable on your computer.
igorzwx
Supporter
 
Posts: 987
Joined: Sun Jun 28, 2009 9:31 pm

Re: Distortion in output + balance

Postby cesium » Mon Jan 24, 2011 10:16 am

I'm willing to bet you have an ALC1200 (a different revision of ALC888 - ossinfo doesn't show the difference, but your MB spec knows). There's a known bug in the oss_hdaudio driver - for some reason one channel is much louder than the other under this chipset... I have no idea how to work around this.
cesium
Developer
 
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am


Return to Linux

Who is online

Users browsing this forum: Google [Bot] and 1 guest