Async USB DAC

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

Async USB DAC

Postby seroper » Sun Mar 06, 2011 12:03 pm

Hi,

I have previously asked for help with this problem, but my PSU died and I couldn't reply. See post viewtopic.php?f=3&t=4113&p=16346&hilit=rdac#p16346 I did do cesium's last request "Can you add "detect_trace=1" line to /usr/lib/oss/conf/osscore.conf and "usb_trace=3" to /usr/lib/oss/conf/oss_usb.conf? Then restart OSS. Maybe the output would be helpful..." but not sure where to look for the output.

I have got it going again and done some more tests, but am still not getting the USB DAC to work correctly. I have a Lynx AES16 which works perfectly and an ARCAM USB asynchronous rDAC. OS is vortexbox, v1.6 based on Fedora 14. I have tested with ALSA and the rDAC works perfectly, but the Lynx doesn't as they don't support it. With OSS I'm getting glitches of about 120ms where the output stops altogether, then restarts. I've verified this using ossplay to play a sinewave wav file and monitor the analogue outputs on a scope. Given it doesn't work with ossplay I'm confident it's a driver issue. The gaps mean it's unusable for music listening.

I would love to get both cards working in the same PC. I have requested help from opensound support over a week ago, but not got a reply. Any help would be much appreciated. soundon.log attached.

Thanks
Simon
Attachments
soundon.log
(96.96 KiB) Downloaded 558 times
seroper
New Member
 
Posts: 5
Joined: Thu Nov 11, 2010 9:10 am

Re: Async USB DAC

Postby seroper » Thu Mar 10, 2011 4:51 pm

Anyone?

Is it possible to get the device working with OSS? Please help me.
seroper
New Member
 
Posts: 5
Joined: Thu Nov 11, 2010 9:10 am


Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest