buggy "locking" oss_cmpci

OSS specific Linux discussion (x86/amd64)

Moderators: hannu, dev, kodachi, cesium

buggy "locking" oss_cmpci

Postby iMil » Sat Apr 16, 2011 8:11 am

Hi,

I'm facing a weird issue with an oss_cmpci supported card, CMedia CM8768 (rev 68).

Sound actually works when the machine starts, and for something like 24 hours. But at some point, without any particular action, no sound will be played by any application and the kernel will output this kind of messages:

[118330.573576] osscore: Output timed out on audio engine 1/'CMedia CM8768 (rev 68) (vmix)' (count=0)
[118331.581525] osscore: Output timed out on audio engine 1/'CMedia CM8768 (rev 68) (vmix)' (count=0)
[118332.588531] osscore: Output timed out on audio engine 1/'CMedia CM8768 (rev 68) (vmix)' (count=0)
[...]
[1064424.384026] osscore: Output timed out (sync) on audio engine 1

Now, stranger thing is, i'll try to play something using mplayer for example, and it will appear like "locked", but if i start 'osstest' at the same time, mplayer would "unlock" and the sound will play... until osstest finished the test.

I've tried pretty much every hint as described on the Tips & Tricks page, no one would fix this issue. Of course i tried every possible combination of ossdetect / osstest / soundon / soundoff.

This happens on a Debian Squeeze GNU/Linux system (2.6.32-5-686-bigmem) either with debian's oss4 packages (build 2003) or compiled oss4 (build 2004). Here's what ossinfo shows (yes there's 2 sound cards on this machine, the hd_audio one works, and i tried unloading everything except oss_cmpci and osscore):
Code: Select all
Version info: OSS 4.2 (b 2004/201104160745) (0x00040100) GPL
Platform: Linux/i686 2.6.32-5-686-bigmem #1 SMP Tue Mar 8 22:14:55 UTC 2011 (tatooine)

Number of audio devices:   11
Number of audio engines:   19
Number of MIDI devices:      0
Number of mixer devices:   3


Device objects
0: osscore0 OSS core services
1: oss_cmpci0 CMedia CM8738 interrupts=71 (610)
2: oss_hdaudio0 Intel HD Audio interrupts=610 (610)
    HD Audio controller Intel HD Audio
    Vendor ID    0x808627d8
    Subvendor ID 0x1043840b
     Codec  0: Unknown (0x10ec0887/0x1043840b)
3: oss_usb0 USB audio core services
4: usb046d09a4-0 USB sound device
5: usb046d09a4-1 USB sound device

MIDI devices (/dev/midi*)

Mixer devices
0: CMedia CMPCI (Mixer 0 of device object 1)
1: High Definition Audio 0x10ec088 (Mixer 0 of device object 2)
2: USB sound device (Mixer 0 of device object 4)

Audio devices
CMedia CM8768 (rev 68)            /dev/oss/oss_cmpci0/pcm0  (device index 0)
CMedia CM8768 (playback only)     /dev/oss/oss_cmpci0/pcm1  (device index 1)
HD Audio play pcm1                /dev/oss/oss_hdaudio0/pcm0  (device index 2)
HD Audio play pcm2                /dev/oss/oss_hdaudio0/pcm1  (device index 3)
HD Audio play pcm3                /dev/oss/oss_hdaudio0/pcm2  (device index 4)
HD Audio play pcm4                /dev/oss/oss_hdaudio0/pcm3  (device index 5)
HD Audio play pcm5                /dev/oss/oss_hdaudio0/pcm4  (device index 6)
HD Audio play spdifout            /dev/oss/oss_hdaudio0/spdout0  (device index 7)
HD Audio rec mix7                 /dev/oss/oss_hdaudio0/pcmin0  (device index 8)
HD Audio rec mix6                 /dev/oss/oss_hdaudio0/pcmin1  (device index 9)
USB sound device rec              /dev/oss/usb046d09a4-1/pcmin0  (device index 10)

Nodes
  /dev/dsp -> /dev/oss/oss_cmpci0/pcm0
  /dev/dsp_in -> /dev/oss/oss_cmpci0/pcm0
  /dev/dsp_out -> /dev/oss/oss_cmpci0/pcm0
  /dev/dsp_ac3 -> /dev/oss/oss_cmpci0/pcm0
  /dev/dsp_mmap -> /dev/oss/oss_cmpci0/pcm0
  /dev/dsp_multich -> /dev/oss/oss_cmpci0/pcm0
  /dev/dsp_spdifout -> /dev/oss/oss_cmpci0/pcm0
  /dev/dsp_spdifin -> /dev/oss/oss_cmpci0/pcm0


Any hint ?
iMil
 
Posts: 2
Joined: Sat Apr 16, 2011 7:55 am

Re: buggy "locking" oss_cmpci

Postby cesium » Mon Apr 18, 2011 10:13 am

Hmmm... I can add another piece to the puzzle: osstest bypasses vmix by default. So it might be related somehow to vmix. If you can repro this, try disabling vmix in the mixer (vmix0-enable button) and then test with mplayer (you can try also reenabling vmix).
cesium
 
Posts: 903
Joined: Sun Aug 12, 2007 12:51 am

Re: buggy "locking" oss_cmpci

Postby iMil » Sun May 01, 2011 11:18 am

Thanks for the hint. It _seems_ that when vmix_no_autoattach is enabled, i get no more timeouts, but again, this behaviour appears very randomly, i can't say if it's really working on the long term or not. I'll keep this thread alive anyway.
iMil
 
Posts: 2
Joined: Sat Apr 16, 2011 7:55 am


Return to Linux

Who is online

Users browsing this forum: Bing [Bot] and 8 guests