Creative HS-1200

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

Creative HS-1200

Postby Black » Sat May 21, 2011 12:32 pm

Hi all,

I have just bought a Creative HS-1200 (X-FI) and I want to hear something with OSSv4 under Gentoo Linux (~amd64).
I have installed oss-devel from the overlay.
soundon run correctly, drivers seems to exists (in beta), but I have no sound.
Code: Select all
# ossinfo
Version info: OSS 4.2 (b 2004/201105210950) (0x00040100) OSS_HG
Hg revision: changeset: 928:a9a237ddd426, tag: tip, date: Tue Apr 19 09:31:02 2011 +0300, summary: Intel HD Audio Cougar Point added
Platform: Linux/x86_64 2.6.39-gentoo #1 SMP Sat May 21 12:27:22 CEST 2011 (louping)

Number of audio devices:        13
Number of audio engines:        17
Number of MIDI devices:         0
Number of mixer devices:        3


Device objects
0: osscore0 OSS core services
1: oss_hdaudio0 Intel HD Audio interrupts=14453 (14453)
    HD Audio controller Intel HD Audio
    Vendor ID    0x80863b56
    Subvendor ID 0x1043840f
     Codec  0: ALC889 (0x10ec0889/0x104383c0)
2: oss_usb0 USB audio core services
3: usb041e0401-0 USB sound device
4: usb041e0401-1 USB sound device
5: usb041e0401-2 USB sound device
6: usb046d08b2-0 Logitec Quickcam Pro 4000 (mic)
7: usb046d08b2-1 Logitec Quickcam Pro 4000 (mic)

MIDI devices (/dev/midi*)

Mixer devices
0: High Definition Audio ALC889 (Mixer 0 of device object 1)
1: USB sound device (Mixer 0 of device object 3)
2: Logitec Quickcam Pro 4000 (mic) (Mixer 0 of device object 6)

Audio devices
HD Audio play front               /dev/oss/oss_hdaudio0/pcm0  (device index 0)
HD Audio play rear                /dev/oss/oss_hdaudio0/pcm1  (device index 1)
HD Audio play center/LFE          /dev/oss/oss_hdaudio0/pcm2  (device index 2)
HD Audio play side                /dev/oss/oss_hdaudio0/pcm3  (device index 3)
HD Audio play pcm4                /dev/oss/oss_hdaudio0/pcm4  (device index 4)
HD Audio play spdif-out           /dev/oss/oss_hdaudio0/spdout0  (device index 5)
HD Audio play spdifout            /dev/oss/oss_hdaudio0/spdout1  (device index 6)
HD Audio rec select               /dev/oss/oss_hdaudio0/pcmin0  (device index 7)
HD Audio rec mix                  /dev/oss/oss_hdaudio0/pcmin1  (device index 8)
HD Audio rec mix                  /dev/oss/oss_hdaudio0/pcmin2  (device index 9)
USB sound device play             /dev/oss/usb041e0401-1/pcm0  (device index 10)
USB sound device rec              /dev/oss/usb041e0401-2/pcmin0  (device index 11)
Logitec Quickcam Pro 4000 (mic) rec  /dev/oss/usb046d08b2-1/pcmin0  (device index 12)

Nodes
  /dev/dsp -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_in -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_out -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_ac3 -> /dev/oss/oss_hdaudio0/spdout0
  /dev/dsp_mmap -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_multich -> /dev/oss/oss_hdaudio0/pcm0

# osstest
Sound subsystem and version: OSS 4.2 (b 2004/201105210950) (0x00040100)
Platform: Linux/x86_64 2.6.39-gentoo #1 SMP Sat May 21 12:27:22 CEST 2011

*** Scanning sound adapter #-1 ***
/dev/oss/oss_hdaudio0/pcm0 (audio engine 0): HD Audio play front
- Performing audio playback test...
  <left> OK <right> OK <stereo> OK <measured srate 47990.00 Hz (-0.02%)>
/dev/oss/oss_hdaudio0/pcm1 (audio engine 1): HD Audio play rear
- Performing audio playback test...
  <left> OK <right> OK <stereo> OK <measured srate 47990.00 Hz (-0.02%)>
/dev/oss/oss_hdaudio0/pcm2 (audio engine 2): HD Audio play center/LFE
- Performing audio playback test...
  <left> OK <right> OK <stereo> OK <measured srate 47990.00 Hz (-0.02%)>
/dev/oss/oss_hdaudio0/pcm3 (audio engine 3): HD Audio play side
- Performing audio playback test...
  <left> OK <right> OK <stereo> OK <measured srate 47993.00 Hz (-0.01%)>
/dev/oss/oss_hdaudio0/pcm4 (audio engine 4): HD Audio play pcm4
- Performing audio playback test...
  <left> OK <right> OK <stereo> OK <measured srate 47993.00 Hz (-0.01%)>
/dev/oss/oss_hdaudio0/spdout0 (audio engine 5): HD Audio play spdif-out
- Performing audio playback test...
  <left> OK <right> OK <stereo> OK <measured srate 47993.00 Hz (-0.01%)>
/dev/oss/oss_hdaudio0/spdout1 (audio engine 6): HD Audio play spdifout
- Performing audio playback test...
  <left> OK <right> OK <stereo> OK <measured srate 47993.00 Hz (-0.01%)>
/dev/oss/oss_hdaudio0/pcmin0 (audio engine 7): HD Audio rec select
- Skipping input only device
/dev/oss/oss_hdaudio0/pcmin1 (audio engine 8): HD Audio rec mix
- Skipping input only device
/dev/oss/oss_hdaudio0/pcmin2 (audio engine 9): HD Audio rec mix
- Skipping input only device

*** Scanning sound adapter #1 ***
/dev/oss/usb041e0401-1/pcm0 (audio engine 14): USB sound device play
- Performing audio playback test...
  <left> Device returned error: Input/output error

*** Scanning sound adapter #4 ***
/dev/oss/usb041e0401-2/pcmin0 (audio engine 15): USB sound device rec
- Skipping input only device

*** Scanning sound adapter #4 ***
/dev/oss/usb046d08b2-1/pcmin0 (audio engine 16): Logitec Quickcam Pro 4000 (mic) rec
- Skipping input only device

*** Some errors were detected during the tests ***

# ossdetect -v -d
mknod /dev/sndstat c 249 0 -m 20666
mknod /dev/midi c 249 1 -m 20666
mknod /dev/mixer c 249 2 -m 20666
mknod /dev/oss/oss_hdaudio0/mix0 c 248 3 -m 20666
mknod /dev/oss/oss_hdaudio0/pcm0 c 248 4 -m 20666
mknod /dev/oss/oss_hdaudio0/pcm1 c 248 6 -m 20666
mknod /dev/oss/oss_hdaudio0/pcm2 c 248 8 -m 20666
mknod /dev/oss/oss_hdaudio0/pcm3 c 248 10 -m 20666
mknod /dev/oss/oss_hdaudio0/pcm4 c 248 12 -m 20666
mknod /dev/oss/oss_hdaudio0/spdout0 c 248 14 -m 20666
mknod /dev/oss/oss_hdaudio0/spdout1 c 248 16 -m 20666
mknod /dev/oss/oss_hdaudio0/pcmin0 c 248 18 -m 20666
mknod /dev/oss/oss_hdaudio0/pcmin1 c 248 20 -m 20666
mknod /dev/oss/oss_hdaudio0/pcmin2 c 248 22 -m 20666
mknod /dev/oss/usb041e0401-0/mix0 c 247 28 -m 20666
mknod /dev/oss/usb041e0401-1/pcm0 c 247 29 -m 20666
mknod /dev/oss/usb041e0401-2/pcmin0 c 247 31 -m 20666
mknod /dev/oss/usb046d08b2-0/mix0 c 247 33 -m 20666
mknod /dev/oss/usb046d08b2-1/pcmin0 c 247 34 -m 20666

# ossmix
Selected mixer 0/High Definition Audio ALC889
Known controls are:
jack.green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.green.mute ON|OFF (currently OFF)
jack.black.mode <front|rear|center/LFE|side|pcm4|input> (currently center/LFE)
jack.black.mute ON|OFF (currently OFF)
jack.orange.mode <front|rear|center/LFE|side|pcm4|input> (currently rear)
jack.orange.mute ON|OFF (currently OFF)
jack.gray.mode <front|rear|center/LFE|side|pcm4|input> (currently pcm4)
jack.gray.mute ON|OFF (currently OFF)
jack.pink.mode <front|rear|center/LFE|side|pcm4|input> (currently pcm4)
jack.pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.pink.mute ON|OFF (currently OFF)
jack.fp-pink.mode <front|rear|center/LFE|side|pcm4|input> (currently pcm4)
jack.fp-pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-pink.mute ON|OFF (currently OFF)
jack.blue.mode <front|rear|center/LFE|side|pcm4|input> (currently input)
jack.blue [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.blue.mute ON|OFF (currently OFF)
jack.fp-green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-green.mute ON|OFF (currently OFF)
record.select.select <mic|fp-mic|linein|input-mix> (currently mic)
record.select [<leftvol>:<rightvol>] (currently 37.9:37.9 dB)
record.mix.mute.mic1 ON|OFF (currently OFF)
record.mix.mute.fp-mic1 ON|OFF (currently OFF)
record.mix.mute.linein1 ON|OFF (currently OFF)
record.mix.mute.fp-headphone1 ON|OFF (currently OFF)
record.mix.mute.green1 ON|OFF (currently OFF)
record.mix.mute.black1 ON|OFF (currently OFF)
record.mix.mute.orange1 ON|OFF (currently OFF)
record.mix.mute.gray1 ON|OFF (currently OFF)
record.mix.mute.input-mix1 ON|OFF (currently OFF)
record.mix1 [<leftvol>:<rightvol>] (currently 37.9:37.9 dB)
record.mix.mute.mic2 ON|OFF (currently OFF)
record.mix.mute.fp-mic2 ON|OFF (currently OFF)
record.mix.mute.linein2 ON|OFF (currently OFF)
record.mix.mute.fp-headphone2 ON|OFF (currently OFF)
record.mix.mute.green2 ON|OFF (currently OFF)
record.mix.mute.black2 ON|OFF (currently OFF)
record.mix.mute.orange2 ON|OFF (currently OFF)
record.mix.mute.gray2 ON|OFF (currently OFF)
record.mix.mute.input-mix2 ON|OFF (currently OFF)
record.mix2 [<leftvol>:<rightvol>] (currently 37.9:37.9 dB)
misc.mic [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.fp-mic [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.linein [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.fp-headphone [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.green [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.black [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.orange [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.gray [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.input-mix <mic|fp-mic|linein> (currently mic)
misc.front-mute ON|OFF (currently OFF)
misc.input-mix-mute1 ON|OFF (currently OFF)
misc.front1 [<leftvol>:<rightvol>] (currently 51.9:51.9 dB)
misc.front2 <front|input-mix> (currently front)
misc.rear-mute ON|OFF (currently OFF)
misc.input-mix-mute2 ON|OFF (currently OFF)
misc.rear1 [<leftvol>:<rightvol>] (currently 51.9:51.9 dB)
misc.rear2 <rear|input-mix> (currently rear)
misc.center/lfe-mute ON|OFF (currently OFF)
misc.input-mix-mute3 ON|OFF (currently OFF)
misc.center/lfe1 [<leftvol>:<rightvol>] (currently 51.9:51.9 dB)
misc.center/lfe2 <center/LFE|input-mix> (currently center/LFE)
misc.side-mute ON|OFF (currently OFF)
misc.input-mix-mute4 ON|OFF (currently OFF)
misc.side1 [<leftvol>:<rightvol>] (currently 51.9:51.9 dB)
misc.side2 <side|input-mix> (currently side)
misc.pcm4-mute ON|OFF (currently OFF)
misc.input-mix-mute5 ON|OFF (currently OFF)
misc.pcm41 [<leftvol>:<rightvol>] (currently 51.9:51.9 dB)
misc.pcm42 <pcm4|input-mix> (currently pcm4)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm10 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm11 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm12 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm13 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)

# cat /usr/lib64/oss/etc/installed_drivers
oss_hdaudio #Intel High Definition Audio (PCH)
oss_usb #Generic USB audio/MIDI device (BETA)
oss_usb #Logitec Quickcam Pro 4000 (mic) (BETA)

# lsmod
Module                  Size  Used by
oss_usb               117159  0
oss_hdaudio           142471  0
osscore               531236  2 oss_usb,oss_hdaudio
nvidia              10475899  38
scsi_wait_scan           719  0


Have you got an idea of de problem ?

For your help,
By advance,
Thanks
Black
New Member
 
Posts: 1
Joined: Sat May 21, 2011 12:12 pm

Re: Creative HS-1200

Postby ojin11 » Tue Nov 29, 2011 5:22 am

Well, recently I too came to buy a Creative HS 1200. I too was wondering what it would be like hearing some music with OSSv4 in the Gentoo Linux. Just like you, it was only from overlay that I had installed the OSS devel. However, there seems to be no sound no matter what I try.
ojin11
New Member
 
Posts: 4
Joined: Sat Nov 26, 2011 9:11 am

Re: Creative HS-1200

Postby Kitty » Sat Jan 28, 2012 1:11 am

I seem to be having this issue too... :cry:
Kitty
New Member
 
Posts: 1
Joined: Sat Jan 28, 2012 1:09 am


Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest