very loud noise when starting oss on archlinux

OSS specific Linux discussion (x86/amd64)

Moderators: hannu, dev, cesium, kodachi

very loud noise when starting oss on archlinux

Postby xirotyu » Sun Aug 14, 2011 3:59 am

everytime i start the oss very loud noise come out...
when i stop the oss the sound is still there.
i tried to do ossinfo and ossmix.. not result anything
i have to shutdown the laptop to make the sound stop.

im using laptop compaq cq42, archlinux64, kernel 2.26.39, and 3.0 ( both failed )

here is my lspci
Code: Select all
00:00.0 Host bridge: Advanced Micro Devices [AMD] RS880 Host Bridge
00:01.0 PCI bridge: Advanced Micro Devices [AMD] RS780/RS880 PCI to PCI bridge (int gfx)
00:05.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1)
00:06.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2)
00:11.0 SATA controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
00:12.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 42)
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: ATI Technologies Inc SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge (rev 40)
00:14.5 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:16.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:16.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
01:05.0 VGA compatible controller: ATI Technologies Inc M880G [Mobility Radeon HD 4200]
01:05.1 Audio device: ATI Technologies Inc RS880 Audio Device [Radeon HD 4200]
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
xirotyu
New Member
 
Posts: 5
Joined: Sun Aug 14, 2011 3:26 am

Re: very loud noise when starting oss on archlinux

Postby igorzwx » Sun Aug 14, 2011 12:03 pm

xirotyu wrote:i tried to do ossinfo and ossmix.. not result anything

im using laptop compaq cq42, archlinux64, kernel 2.26.39, and 3.0 ( both failed )


If ossinfo and ossmix fail to produce any result, you have to remove OSS and reboot.
Then you may try to install OSS correctly. The manual is here:
https://wiki.archlinux.org/index.php/OSS

If you do not know how to remove OSS, you may read this:
viewtopic.php?f=3&t=3543&start=30#p15711

In a word, OSS seems to work on Arch Linux with kernel 3.0 without problems.
It seems to be the same old kernel, only the name is different, a kind of "Potemkin village" http://en.wikipedia.org/wiki/Potemkin_village
igorzwx
Moderator
 
Posts: 1005
Joined: Sun Jun 28, 2009 9:31 pm

Re: very loud noise when starting oss on archlinux

Postby xirotyu » Sun Aug 14, 2011 12:39 pm

actually i tried ossinfo and ossmix with a script like this
Code: Select all
#used to start oss on archlinux
rc.d start oss

#script to grab the log
ossinfo > ossinfolog
ossmix > ossmixlog


i use the script because the noise is heard when i start the oss.
if i try type the ossinfo to the terminal it shown up but after that, the laptop just freeze, with the usual loud noise...
xirotyu
New Member
 
Posts: 5
Joined: Sun Aug 14, 2011 3:26 am

Re: very loud noise when starting oss on archlinux

Postby igorzwx » Sun Aug 14, 2011 1:29 pm

xirotyu wrote:actually i tried ossinfo and ossmix with a script like this
Code: Select all
#used to start oss on archlinux
rc.d start oss

#script to grab the log
ossinfo > ossinfolog
ossmix > ossmixlog


i use the script because the noise is heard when i start the oss.
if i try type the ossinfo to the terminal it shown up but after that, the laptop just freeze, with the usual loud noise...


You are doing something very strange with your Arch Linux.
xirotyu wrote: if i try type the ossinfo to the terminal it shown up but after that, the laptop just freeze

Do you mean the "Blue Screen of Death"? http://en.wikipedia.org/wiki/Blue_Screen_of_Death
Is it really Arch Linux, or it is a kind of M$ Windows?

Does your ALSA works?
http://www.google.com/search?hl=en-US&q ... %204200%5D

You may test ALSA and OSS4 with Arch LiveCD, the manual is here: viewtopic.php?f=3&t=4387
igorzwx
Moderator
 
Posts: 1005
Joined: Sun Jun 28, 2009 9:31 pm

Re: very loud noise when starting oss on archlinux

Postby xirotyu » Sun Aug 14, 2011 11:07 pm

igorzwx wrote:You are doing something very strange with your Arch Linux.


but the sound is..... freaking loud :cry: i just cant stand it, and i dont want to broke my internal speaker.... maybe i have to unplug the internal speaker first.... but the warranty...

i think i have to use alsa.... without pulseaudio :P (rebuilding some package to disable pulse audio). maybe next time when i can grab some cd... or usb flashdrive i try the oss again
xirotyu
New Member
 
Posts: 5
Joined: Sun Aug 14, 2011 3:26 am

Re: very loud noise when starting oss on archlinux

Postby igorzwx » Mon Aug 15, 2011 1:16 am

xirotyu wrote: i think i have to use alsa.... without pulseaudio :P (rebuilding some package to disable pulse audio). maybe next time when i can grab some cd... or usb flashdrive i try the oss again


USB Audio devices are not likely to work with OSS4. You have to know this, if you read the OSS4 manual in Arch Linux Wiki. There is a special Arch Linux forum for those who do not want to read the Arch Wiki: https://bbs.archlinux.org/viewforum.php?id=23

Since ALSA driver for your soundcard does not support "hardware mixing", you may need something instead of PulseAudio, a kind of ESound, for example.
To improve sound quality with ALSA, you may want to disable the evil "linear resampler" of ALSA, see: viewtopic.php?f=3&t=4387 If you do not know, how to disable that resampler, you may ask for help on Arch Linux forum: https://bbs.archlinux.org/viewforum.php?id=23
igorzwx
Moderator
 
Posts: 1005
Joined: Sun Jun 28, 2009 9:31 pm

Re: very loud noise when starting oss on archlinux

Postby xirotyu » Mon Aug 15, 2011 9:18 pm

igorzwx wrote:USB Audio devices are not likely to work with OSS4. You have to know this, if you read the OSS4 manual in Arch Linux Wiki. There is a special Arch Linux forum for those who do not want to read the Arch Wiki: https://bbs.archlinux.org/viewforum.php?id=23


thanks but i already read the wiki... and managed to make it work on other machine. the device is not usb device... i already list the lspci.... the audio device is listed..... read above
i have 2 audio device... one for analog, the second for hdmi. is it that raised the problem? the default for linux 3.0 radeon audio is disabled

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
01:05.1 Audio device: ATI Technologies Inc RS880 Audio Device [Radeon HD 4200]
xirotyu
New Member
 
Posts: 5
Joined: Sun Aug 14, 2011 3:26 am

Re: very loud noise when starting oss on archlinux

Postby igorzwx » Mon Aug 15, 2011 11:51 pm

xirotyu wrote: 00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)


This card should work with OSS4. This was reported on the Russian Ubuntu forum, Linux Mint forum and on this forum.
Perhaps, you have to attach vmix to it to make it default, see: https://wiki.archlinux.org/index.php/Op ... em#Testing

Code: Select all
$ man vmixctl

But where is your "ossinfo"?

Have you tried to re-install OSS4?
Sometimes it helps to recompile OSS4 (for your particular Linux kernel), see: viewtopic.php?f=3&t=3543&start=30#p15711

https://wiki.archlinux.org/index.php/Op ... io_devices
You'll probably want to setup a program to record/play continously in the background (e.g. ossrecord - for recording or osstest -lV for playing), while changing mixer settings in ossxmix in the foreground.


Code: Select all
$ ossrecord -vl - | ossplay -
Recording wav: Speed 48000Hz 16 bits Stereo
- [.......   ] 7.00 secs VU -------++


It makes sense to test your soundcard with OSS4 on Arch LiveCD: viewtopic.php?f=3&t=3933#p17359
It should work "out of the box", I presume.
igorzwx
Moderator
 
Posts: 1005
Joined: Sun Jun 28, 2009 9:31 pm

Re: very loud noise when starting oss on archlinux

Postby xirotyu » Wed Aug 17, 2011 12:35 pm

woops... solved with

viewtopic.php?f=3&t=3541

high pitched squeel..... *my english is bad :P
i just cant turn off the sound because its laptop internal speaker....

thanks igorzwx for cooperation
xirotyu
New Member
 
Posts: 5
Joined: Sun Aug 14, 2011 3:26 am

Re: very loud noise when starting oss on archlinux

Postby igorzwx » Wed Aug 17, 2011 1:02 pm

xirotyu wrote:woops... solved with

viewtopic.php?f=3&t=3541

high pitched squeel..... *my english is bad :P
i just cant turn off the sound because its laptop internal speaker....

thanks igorzwx for cooperation


Good news!

Does your microphone work?

With this soundcard, you may need to fix it with "trial and error":
https://wiki.archlinux.org/index.php/Op ... io_devices

Code: Select all
$ ossrecord -vl - | ossplay -
Recording wav: Speed 48000Hz 16 bits Stereo
- [.......   ] 7.00 secs VU -------++


Do you have a simple analog microphone?
igorzwx
Moderator
 
Posts: 1005
Joined: Sun Jun 28, 2009 9:31 pm

Re: very loud noise when starting oss on archlinux

Postby Matti » Sat Aug 20, 2011 4:00 pm

I had the same problem OSS 4.2-2005 on Ubuntu 11.04 and Realtek High Definition Audio ALC888 soundcard. Although the sound wasn't loud in my case (it was more like white noise).

I've changed the jack.blue.mode (in ossxmix) from input to rear and that noise disapeared instantly.
Matti
Member
 
Posts: 39
Joined: Sun May 29, 2011 12:34 pm


Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest