Output volume does not match vol control value

OSS specific Linux discussion (x86/amd64)

Moderators: hannu, dev, cesium, kodachi

Re: Output volume does not match vol control value

Postby igorzwx » Mon Sep 12, 2011 3:25 pm

It seems that you are using a problematic soundcard:
05:06.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)


It might be a bug in the driver.
Open Sound System v4.2 build 2005 has been announced for Linux (x86/amd64), Solaris (x86, amd64, sparc), FreeBSD 8 (x86, amd64), UnixWare, and Open Server.
* Added support for Envy24HT PCIe
viewtopic.php?f=19&t=4391


Perhaps, Cesium may explain the problem.

EDIT: You may try the pcm slider.

Another option is to disable vmix (it is a kind of PulseAudio).
It is very probable that your soundcard has HW mixer. In this case, you do not need vmix.
Last edited by igorzwx on Mon Sep 12, 2011 3:48 pm, edited 1 time in total.
igorzwx
Moderator
 
Posts: 1005
Joined: Sun Jun 28, 2009 9:31 pm

Re: Output volume does not match vol control value

Postby hemebond » Mon Sep 12, 2011 3:37 pm

Disabling vmix didn't help. I think there was a reason I was adjusting the master volume instead of PCM; possibly different apps or sinks not using PCM? I can't remember now. I'll try and switch to using PCM for now. Let me know if there's any more info you want.
hemebond
Member
 
Posts: 13
Joined: Sun Sep 11, 2011 3:11 am

Re: Output volume does not match vol control value

Postby igorzwx » Mon Sep 12, 2011 3:45 pm

hemebond wrote:Disabling vmix didn't help. I think there was a reason I was adjusting the master volume instead of PCM; possibly different apps or sinks not using PCM? I can't remember now. I'll try and switch to using PCM for now. Let me know if there's any more info you want.


Yes, PCM is a problem, especially if you are using Sennheiser headphones for audiophiles.
Some apps may rise PCM volume, and you may get a very loud sound to the headphones (this may damage your hearing!!!)
You should always check ossxmix and set volumes to minimum before using headphones for audiophiles.

If you have problems with osstest (stereo, left/right), you may try to plug/unplug your headset or speakers.
Sometimes, it helps to fix the problem, if it is caused by "jack-sensing" .
igorzwx
Moderator
 
Posts: 1005
Joined: Sun Jun 28, 2009 9:31 pm

Re: Output volume does not match vol control value

Postby hemebond » Thu Sep 22, 2011 9:02 pm

Well, turns out my sound is even more broken now, with Adobe Flash now blocking any other application from using audio. Looks like I'll have to reinstall my OS sooner than I'd like.
hemebond
Member
 
Posts: 13
Joined: Sun Sep 11, 2011 3:11 am

Re: Output volume does not match vol control value

Postby igorzwx » Thu Sep 22, 2011 9:52 pm

hemebond wrote:Well, turns out my sound is even more broken now, with Adobe Flash now blocking any other application from using audio. Looks like I'll have to reinstall my OS sooner than I'd like.


It might be sufficient to correct settings in ossxmix and/or re-install OSS4.
If you do not know how to re-install OSS4 correctly, you may study this "howto" viewtopic.php?f=3&t=3543&start=30#p15711
You may train this on Arch Linux LiveCD (Archiso-live or CTKArch) viewtopic.php?f=3&t=3933#p17316
igorzwx
Moderator
 
Posts: 1005
Joined: Sun Jun 28, 2009 9:31 pm

Re: Output volume does not match vol control value

Postby hemebond » Thu Sep 22, 2011 9:58 pm

Thanks, but I think I'll leave it. It at still works for most things (my microphone has also stopped working), so I'll just install a new OS when I get time. Thanks for your help.
hemebond
Member
 
Posts: 13
Joined: Sun Sep 11, 2011 3:11 am

Re: Output volume does not match vol control value

Postby igorzwx » Thu Sep 22, 2011 10:42 pm

hemebond wrote:Thanks, but I think I'll leave it. It at still works for most things (my microphone has also stopped working), so I'll just install a new OS when I get time. Thanks for your help.


Could you post the output of these commands:
Code: Select all
$ ossmix
$ lsmod | grep snd
igorzwx
Moderator
 
Posts: 1005
Joined: Sun Jun 28, 2009 9:31 pm

Re: Output volume does not match vol control value

Postby hemebond » Thu Sep 22, 2011 10:47 pm

Code: Select all
~$ ossmix
Selected mixer 0/Shuttle SN25P (VT1612A)
Known controls are:
vol [<leftvol>:<rightvol>] (currently 62:62)
vol.rec ON|OFF (currently OFF)
pcm [<leftvol>:<rightvol>] (currently 32:32)
speaker <monovol> (currently 0)
line [<leftvol>:<rightvol>] (currently 100:100)
line.rec ON|OFF (currently OFF)
mic <monovol> (currently 0)
mic.rec ON|OFF (currently ON)
cd [<leftvol>:<rightvol>] (currently 0:0)
cd.rec ON|OFF (currently OFF)
igain [<leftvol>:<rightvol>] (currently 60:60)
aux1 [<leftvol>:<rightvol>] (currently 47:47)
aux1.rec ON|OFF (currently OFF)
phone [<leftvol>:<rightvol>] (currently 47:47)
phone.rec ON|OFF (currently OFF)
mono <monovol> (currently 50)
mono.rec ON|OFF (currently OFF)
video [<leftvol>:<rightvol>] (currently 59:59)
video.rec ON|OFF (currently OFF)
depth <monovol> (currently 100)
rear [<leftvol>:<rightvol>] (currently 50:50)
center [<leftvol>:<rightvol>] (currently 50:50)
route.front <DMA|ANALOGIN|DIGITALIN> (currently DMA)
route.c/l <DMA|ANALOGIN|DIGITALIN> (currently DMA)
route.side <DMA|ANALOGIN|DIGITALIN> (currently DMA)
route.spdifout <DMA|ANALOGIN|DIGITALIN> (currently DMA)
envy24.rate <8000|9600|11025|12000|16000|22050|24000|32000|44100|48000> (currently 44100)
envy24.sync <INTERNAL|SPDIF> (currently INTERNAL)
envy24.src ON|OFF (currently OFF)
envy24.ratelock ON|OFF (currently OFF)
envy24.actrate <decimal value> (currently 44100) (Read-only)
spdif.audio <AUDIO|DATA> (currently AUDIO)
spdif.vbit ON|OFF (currently OFF)
spdif.preemph <OFF|50/16usec> (currently OFF)
spdif.mode <CONSUMER|PRO> (currently CONSUMER)
spdif.copyright <YES|NO> (currently YES)
spdif.generat <COPY|ORIGINAL> (currently COPY)
micboost ON|OFF (currently ON)
mixext.spkmode <FRONT|SPREAD> (currently SPREAD)
mixext.mix-lfe2front ON|OFF (currently ON)
mixext.mix-rear2front ON|OFF (currently ON)
vmix0-enable ON|OFF (currently OFF)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 22.8 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm5 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm6 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm7 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm8 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
~$ lsmod | grep snd
~$
Pulse Audio doesn't see/list any recording or input devices.
hemebond
Member
 
Posts: 13
Joined: Sun Sep 11, 2011 3:11 am

Re: Output volume does not match vol control value

Postby igorzwx » Thu Sep 22, 2011 10:58 pm

hemebond wrote:
Code: Select all
~$ ossmix
Selected mixer 0/Shuttle SN25P (VT1612A)
Known controls are:
vol [<leftvol>:<rightvol>] (currently 62:62)
vol.rec ON|OFF (currently OFF)
pcm [<leftvol>:<rightvol>] (currently 32:32)
speaker <monovol> (currently 0)
line [<leftvol>:<rightvol>] (currently 100:100)
line.rec ON|OFF (currently OFF)
mic <monovol> (currently 0)
mic.rec ON|OFF (currently ON)
cd [<leftvol>:<rightvol>] (currently 0:0)
cd.rec ON|OFF (currently OFF)
igain [<leftvol>:<rightvol>] (currently 60:60)
aux1 [<leftvol>:<rightvol>] (currently 47:47)
aux1.rec ON|OFF (currently OFF)
phone [<leftvol>:<rightvol>] (currently 47:47)
phone.rec ON|OFF (currently OFF)
mono <monovol> (currently 50)
mono.rec ON|OFF (currently OFF)
video [<leftvol>:<rightvol>] (currently 59:59)
video.rec ON|OFF (currently OFF)
depth <monovol> (currently 100)
rear [<leftvol>:<rightvol>] (currently 50:50)
center [<leftvol>:<rightvol>] (currently 50:50)
route.front <DMA|ANALOGIN|DIGITALIN> (currently DMA)
route.c/l <DMA|ANALOGIN|DIGITALIN> (currently DMA)
route.side <DMA|ANALOGIN|DIGITALIN> (currently DMA)
route.spdifout <DMA|ANALOGIN|DIGITALIN> (currently DMA)
envy24.rate <8000|9600|11025|12000|16000|22050|24000|32000|44100|48000> (currently 44100)
envy24.sync <INTERNAL|SPDIF> (currently INTERNAL)
envy24.src ON|OFF (currently OFF)
envy24.ratelock ON|OFF (currently OFF)
envy24.actrate <decimal value> (currently 44100) (Read-only)
spdif.audio <AUDIO|DATA> (currently AUDIO)
spdif.vbit ON|OFF (currently OFF)
spdif.preemph <OFF|50/16usec> (currently OFF)
spdif.mode <CONSUMER|PRO> (currently CONSUMER)
spdif.copyright <YES|NO> (currently YES)
spdif.generat <COPY|ORIGINAL> (currently COPY)
micboost ON|OFF (currently ON)
mixext.spkmode <FRONT|SPREAD> (currently SPREAD)
mixext.mix-lfe2front ON|OFF (currently ON)
mixext.mix-rear2front ON|OFF (currently ON)
vmix0-enable ON|OFF (currently OFF)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 22.8 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm5 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm6 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm7 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm8 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
~$ lsmod | grep snd
~$
Pulse Audio doesn't see/list any recording or input devices.


Your mic is set to 0 in the mixer. That is why your mic does not work.
Code: Select all
mic <monovol> (currently 0)

To have mic working, you need these:
Code: Select all
mic <monovol> (currently 70)
mic.rec ON|OFF (currently ON)
igain [<leftvol>:<rightvol>] (currently 60:60)


vmix is also disabled:
Code: Select all
vmix0-enable ON|OFF (currently OFF)

That is why "Adobe Flash is blocking any other application from using audio".

You may want to set "mono" to 0 (you may not need it):
Code: Select all
mono <monovol> (currently 50)


___________________________________________________
It seems that the mixer on my old box looks similar to yours.
My settings:
Code: Select all
$ ossmix
Selected mixer 0/ICH AC97 Mixer (ALC655)
Known controls are:
vol [<leftvol>:<rightvol>] (currently 12:12)
vol.rec ON|OFF (currently OFF)
pcm [<leftvol>:<rightvol>] (currently 40:40)
speaker <monovol> (currently 0)
line [<leftvol>:<rightvol>] (currently 0:0)
line.rec ON|OFF (currently OFF)
mic <monovol> (currently 100)
mic.rec ON|OFF (currently ON)
cd [<leftvol>:<rightvol>] (currently 0:0)
cd.rec ON|OFF (currently OFF)
igain [<leftvol>:<rightvol>] (currently 100:100)
aux1 [<leftvol>:<rightvol>] (currently 0:0)
aux1.rec ON|OFF (currently OFF)
phone [<leftvol>:<rightvol>] (currently 0:0)
phone.rec ON|OFF (currently OFF)
mono <monovol> (currently 0)
mono.rec ON|OFF (currently OFF)
video [<leftvol>:<rightvol>] (currently 0:0)
video.rec ON|OFF (currently OFF)
rear [<leftvol>:<rightvol>] (currently 53:53)
center [<leftvol>:<rightvol>] (currently 53:53)
micboost ON|OFF (currently OFF)
mixext.centervol [<leftvol>:<rightvol>] (currently 100:100)
mixext.rearvol [<leftvol>:<rightvol>] (currently 100:100)
mixext.sidevol [<leftvol>:<rightvol>] (currently 100:100)
mixext.rear2linejack ON|OFF (currently OFF)
mixext.center2micjack ON|OFF (currently OFF)
mixext.spkmode <FRONT|SPREAD> (currently FRONT)
mixext.mix-lfe2front ON|OFF (currently OFF)
mixext.mix-rear2front ON|OFF (currently OFF)
spdout.enable ON|OFF (currently ON)
spdout.adc/dac ON|OFF (currently OFF)
spdout.pro <Consumer|Professional> (currently Consumer)
spdout.audio <AUDIO|DATA> (currently AUDIO)
spdout.copy ON|OFF (currently OFF)
spdout.pre-emph ON|OFF (currently OFF)
spdout.rate <48000|44100|32000> (currently 48000)
spdout.vbit ON|OFF (currently OFF)
spdin.enable ON|OFF (currently ON)
spdin.monitor ON|OFF (currently OFF)
spdin.pro <decimal value> (currently 0) (Read-only)
spdin.audio <decimal value> (currently 0) (Read-only)
spdin.copy <decimal value> (currently 0) (Read-only)
spdin.pre-emph <decimal value> (currently 0) (Read-only)
spdin.mode <decimal value> (currently 0) (Read-only)
spdin.category <decimal value> (currently 0) (Read-only)
spdin.genlevel <decimal value> (currently 0) (Read-only)
spdin.source <decimal value> (currently 0) (Read-only)
spdin.channel <decimal value> (currently 0) (Read-only)
spdin.rate <decimal value> (currently 44100) (Read-only)
spdin.clock <decimal value> (currently 0) (Read-only)
spdin.signal <decimal value> (currently 0) (Read-only)
spdin.vbit <decimal value> (currently 0) (Read-only)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|High+|Production|OFF> (currently Production)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm1 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm2 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm3 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm4 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
Last edited by igorzwx on Thu Sep 22, 2011 11:15 pm, edited 2 times in total.
igorzwx
Moderator
 
Posts: 1005
Joined: Sun Jun 28, 2009 9:31 pm

Re: Output volume does not match vol control value

Postby hemebond » Thu Sep 22, 2011 11:06 pm

igorzwx wrote:Your mic is set to 0 in the mixer. That is why your mic does not work.
Code: Select all
mic <monovol> (currently 0)
That property controls the volume of output from the speakers. If I put that up the sound going into my mic is output from my speakers. Didn't help recording.

igorzwx wrote:vmix is also disabled:
Code: Select all
vmix0-enable ON|OFF (currently OFF)

That is why "Adobe Flash is blocking any other application from using audio".
This was the issue. I disabled it earlier in this thread. Now I see a recording device in Pulse Audio.

Thank you again.
hemebond
Member
 
Posts: 13
Joined: Sun Sep 11, 2011 3:11 am

Re: Output volume does not match vol control value

Postby igorzwx » Thu Sep 22, 2011 11:15 pm

hemebond wrote:
igorzwx wrote:Your mic is set to 0 in the mixer. That is why your mic does not work.
Code: Select all
mic <monovol> (currently 0)
That property controls the volume of output from the speakers. If I put that up the sound going into my mic is output from my speakers. Didn't help recording.


This is very strange. My mic controls are exactly these ones:
Code: Select all
mic <monovol> (currently 70)
mic.rec ON|OFF (currently ON)
igain [<leftvol>:<rightvol>] (currently 60:60)


Perhaps, something wrong with your PulseAudio settings.
If you have two "PulseAudios" installed (vmix and PulseAudio), it might be difficult to configure them correctly.
One of them might be sufficient, the other might be removed.
Last edited by igorzwx on Fri Oct 07, 2011 1:36 am, edited 1 time in total.
igorzwx
Moderator
 
Posts: 1005
Joined: Sun Jun 28, 2009 9:31 pm

Re: Output volume does not match vol control value

Postby hemebond » Fri Oct 07, 2011 1:23 am

FYI, I installed Debian this week, I'm back to ALSA/PA, and the audio problem is terrible. Volume controls doing their own thing, distortion, stuttering. *despair*
hemebond
Member
 
Posts: 13
Joined: Sun Sep 11, 2011 3:11 am

Re: Output volume does not match vol control value

Postby igorzwx » Fri Oct 07, 2011 1:34 am

hemebond wrote:FYI, I installed Debian this week, I'm back to ALSA/PA, and the audio problem is terrible. Volume controls doing their own thing, distortion, stuttering. *despair*


If you want to fix your ALSA/PA, you may ask for help on Arch Linux forum https://bbs.archlinux.org/viewforum.php?id=32
They seem to be busy with such problems now.
igorzwx
Moderator
 
Posts: 1005
Joined: Sun Jun 28, 2009 9:31 pm

Previous

Return to Linux

Who is online

Users browsing this forum: Google [Bot] and 1 guest