No LFE (subwoofer) on High Definition Audio STAC9200 (ICH7)

OSS specific Linux discussion (x86/amd64)

Moderators: hannu, dev, cesium, kodachi

No LFE (subwoofer) on High Definition Audio STAC9200 (ICH7)

Postby Tids » Mon Oct 24, 2011 1:29 am

Hi there. the Open sound system runs much better than alsa here but there is a problem that i cant enable my subwoofer on the LFE output
My ossinfo:
Code: Select all
ossinfo
Version info: OSS 4.2 (b 2005/201108051838) (0x00040100) TRIAL
Platform: Linux/i686 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011

Number of audio devices:        4
Number of audio engines:        8
Number of MIDI devices:         0
Number of mixer devices:        1


Device objects
0: osscore0 OSS core services
1: oss_hdaudio0 Intel HD Audio interrupts=3089 (3089)
    HD Audio controller Intel HD Audio
    Vendor ID    0x808627d8
    Subvendor ID 0x102801cd
     Codec  0: STAC9200 (0x83847690/0x102801cd)
     Codec  1: Conexant2bfa (0x14f12bfa)
2: oss_usb0 USB audio core services

MIDI devices (/dev/midi*)

Mixer devices
0: High Definition Audio STAC9200 (Mixer 0 of device object 1)

Audio devices
HD Audio play pcm                 /dev/oss/oss_hdaudio0/pcm0  (device index 0)
HD Audio play modem-out           /dev/oss/oss_hdaudio0/pcm1  (device index 1)
HD Audio rec select               /dev/oss/oss_hdaudio0/pcmin0  (device index 2)
HD Audio rec modem-out            /dev/oss/oss_hdaudio0/pcmin1  (device index 3)

Nodes
  /dev/dsp -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_in -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_out -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_mmap -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_multich -> /dev/oss/oss_hdaudio0/pcm0


dont know if I can do something. I hope there is some solution :)
Tids
 
Posts: 2
Joined: Mon Oct 24, 2011 1:23 am

Re: No LFE (subwoofer) on High Definition Audio STAC9200 (IC

Postby cesium » Mon Oct 31, 2011 6:19 pm

Can you post output of 'ossmix -a'?
cesium
 
Posts: 903
Joined: Sun Aug 12, 2007 12:51 am

Re: No LFE (subwoofer) on High Definition Audio STAC9200 (IC

Postby Tids » Thu Nov 03, 2011 11:05 am

sure :)
Code: Select all
% ossmix -a
Selected mixer 0/High Definition Audio STAC9200
Known controls are:
jack.black.mode1 <select|input> (currently select)
jack.black.select1 <pcm|select> (currently pcm)
jack.black.select2 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
jack.int-speaker.mode <select|input> (currently select)
jack.black.mode2 <select|input> (currently select)
record.select.select1 [<leftvol>:<rightvol>] (currently 39.9:39.9 dB)
record.select.select2 [<leftvol>:<rightvol>] (currently 19.4:19.4 dB)
misc <-28.-8dB|-19.-2dB|-9.-6dB|0.0dB|mute> (currently 131(too large (a=5)?))
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm4 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm5 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm6 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm7 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)

Selected mixer 1/USB sound device
Known controls are:
rec.mute ON|OFF (currently OFF)
rec.vol <monovol> (currently 0)
rec-altset <OFF|1|2|3|4> (currently 1)
Tids
 
Posts: 2
Joined: Mon Oct 24, 2011 1:23 am

Re: No LFE (subwoofer) on High Definition Audio STAC9200 (IC

Postby cesium » Tue Nov 08, 2011 2:00 pm

Try setting vmix0-channels to "Multich" and outputting to /dev/dsp_multich.
cesium
 
Posts: 903
Joined: Sun Aug 12, 2007 12:51 am


Return to Linux

Who is online

Users browsing this forum: Yahoo [Bot] and 6 guests