mic/line-in passthrough with oss_hdaudio

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

mic/line-in passthrough with oss_hdaudio

Postby adamk » Mon Oct 24, 2011 9:48 pm

Code: Select all

Version info: OSS 4.2 (b 2005/201109062301) (0x00040100) OSS_HG
Hg revision: changeset: 937:998ceefba722 summary: Added tag v4.2-2005 for changeset 11205524a8ce, tag: tip summary: Added tag v4.2-2005 for changeset 11205524a8ce, date: Fri Aug 12 07:59:07 2011 +0300, summary: Added tag v4.2-2005 for changeset 11205524a8ce
Platform: Linux/x86_64 3.0.3 #1 SMP Mon Aug 22 17:53:52 EDT 2011 (sorrow)

Number of audio devices:        3
Number of audio engines:        7
Number of MIDI devices:         0
Number of mixer devices:        2


Device objects
0: osscore0 OSS core services
1: oss_hdaudio0 Intel HD Audio interrupts=920062 (920062)
    HD Audio controller Intel HD Audio
    Vendor ID    0x8086269a
    Subvendor ID 0x102801c1
     Codec  0: STAC9200 (0x83847690/0x102801c1)
2: oss_usb0 USB audio core services
3: usb046d0824-0 USB sound device
4: usb046d0824-1 USB sound device

MIDI devices (/dev/midi*)

Mixer devices
0: High Definition Audio STAC9200 (Mixer 0 of device object 1)
1: USB sound device (Mixer 0 of device object 3)

Audio devices
HD Audio play pcm                 /dev/oss/oss_hdaudio0/pcm0  (device index 0)
HD Audio rec select               /dev/oss/oss_hdaudio0/pcmin0  (device index 1)
USB sound device rec              /dev/oss/usb046d0824-1/pcmin0  (device index 2)

Nodes
  /dev/dsp -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_in -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_out -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_mmap -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_multich -> /dev/oss/oss_hdaudio0/pcm0


Code: Select all

[adamk@sorrow ~]$ ossmix
Selected mixer 0/High Definition Audio STAC9200
Known controls are:
jack.fp-black.mode1 <select|input> (currently input)
jack.fp-black.select1 <pcm|select> (currently pcm)
jack.fp-black.select2 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
jack.green.mode <select|input> (currently select)
jack.blue.mode <select|input> (currently input)
jack.fp-black.mode2 <select|input> (currently input)
record.select.select1 [<leftvol>:<rightvol>] (currently 39.9:39.9 dB)
record.select.select2 <select|select> (currently select)
record.select.select3 [<leftvol>:<rightvol>] (currently 22.4:22.4 dB)
misc <-28.-8dB|-19.-2dB|-9.-6dB|0.0dB|mute> (currently 131(too large (a=5)?))
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 4.3 dB)
vmix0.pcm2 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB) ("oss")
vmix0.pcm3 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm4 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm5 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)


Basically, I can record from my mic/line-in, but I can't actually hear the audio on my speakers till I play back the recorded audio clip. It's always been like this on this machine, but I never thought about it much till I hooked up a TV-tuner to the line-in. I see nothing like a "monitor" control. I've read some things on-line that suggest not all HDA audio chips have this ability which seems... well... silly.

Any suggestions?

Adam
adamk
Member
 
Posts: 78
Joined: Fri Jun 11, 2004 1:50 pm

Re: mic/line-in passthrough with oss_hdaudio

Postby cesium » Mon Oct 31, 2011 6:11 pm

I have a TV tuner with a cable to line-in. line-in is blue jack, and I can hear it some mixer changes**. However, your mixer is very bare. Try adding "hdaudio_noskip=7" line to oss_hdaudio.conf and see if you have more settings.

**
ossmix jack.blue.mode input
ossmix misc.input-mix-mute1 OFF
ossmix misc.linein and misc.front control volume.
cesium
Developer
 
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am

Re: mic/line-in passthrough with oss_hdaudio

Postby adamk » Sat Nov 05, 2011 11:30 pm

I get a few extra mixer controls but the only "misc" control is simply "misc" still:

Code: Select all

[adamk@sorrow ~]$ ossmix
Selected mixer 0/High Definition Audio STAC9200
Known controls are:
jack.internal.mode <spdifout|select> (currently select)
jack.fp-black.mode1 <select|input> (currently input)
jack.fp-black.select1 <pcm|internal|select> (currently pcm)
jack.fp-black.select2 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
jack.green.mode <select|input> (currently select)
jack.blue.mode <select|input> (currently input)
jack.fp-black.mode2 <select|input> (currently input)
jack.internal.select <monovol> (currently 38.9 dB)
record.select.select1 [<leftvol>:<rightvol>] (currently 39.9:39.9 dB)
record.select.select2 <select|select|rec1> (currently select)
record.select.select3 [<leftvol>:<rightvol>] (currently 19.4:19.4 dB)
misc <-28.-8dB|-19.-2dB|-9.-6dB|0.0dB|mute> (currently 131(too large (a=5)?))
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm4 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm5 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm6 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm7 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)


Still no audio passthrough, no matter how I play with ossxmix.

I have, at least for the time being, gotten around this by using 'rec -p | play -p' while recording audio.

Adam
adamk
Member
 
Posts: 78
Joined: Fri Jun 11, 2004 1:50 pm


Return to Linux

Who is online

Users browsing this forum: Bing [Bot], Majestic-12 [Bot] and 1 guest

cron