rec from vmix loop works only first time after oss startup

OSS specific Linux discussion (x86/amd64)

Moderators: hannu, dev, kodachi, cesium

Re: rec from vmix loop works only first time after oss start

Postby igorzwx » Sat Jan 07, 2012 5:00 pm

Have you noticed a contradiction in your settings:
Code: Select all
jack.pink.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-pink.mode <front|rear|center/LFE|side|pcm4|input> (currently input)

See also my previous post.

Let us try to fix your ordinary mic first.
Then you may try something else.

Most interesting:
Some Azalia codecs support front panel connectors and so if you see
fp-green and fp-pink connectors, then these are for front panel speaker and mic/line-in Jacks.
http://manuals.opensound.com/usersguide ... audio.html

This seems to mean that such HDA soundcards are capable of "hardware mixing", but it is not supported by Linux drivers (because Linux is PulseAudio by definition). It is much easier to create a kind of buggy PulseAudio than to make good drivers for a few (very old) soundcards.

Read this once more:
Code: Select all
jack.green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.pink.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-pink.mode <front|rear|center/LFE|side|pcm4|input> (currently input)

It can only mean that both "jack.green" and "jack.pink" can be used for playback and recording simultaneously (that is, for HW mixing). Otherwise, such a strange construction does not make any sense. This HW mixing feature of HDA soundcards is not supported by Linux drivers, simply because it is much easier to fool Ubuntu/Arch Linux users than to fix buggy drivers.
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: rec from vmix loop works only first time after oss start

Postby Matti » Sat Jan 07, 2012 8:36 pm

You are right about that both jack.green and jack.pink can switch roles. I've set jack.pink to front (both of them) and jack.green to input and I've changed my headphones connection (pink to green and green to pink jack) and I could listen to my music. The only drawback is that it was quiet, or more precisely muffled.

I've finally managed to get clear recording, but it is to quiet. I wonder is there a possibility to change ossrecord volume.

Current mixer settings:
Code: Select all
$ ossmix
Selected mixer 0/High Definition Audio ALC888
Known controls are:
jack.green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.green.mute ON|OFF (currently OFF)
jack.black.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.black [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
jack.black.mute ON|OFF (currently ON)
jack.orange.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.orange [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
jack.orange.mute ON|OFF (currently ON)
jack.gray.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.gray [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
jack.gray.mute ON|OFF (currently ON)
jack.pink.mode <front|rear|center/LFE|side|pcm4|input> (currently input)
jack.pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.pink.mute ON|OFF (currently OFF)
jack.fp-pink.mode <front|rear|center/LFE|side|pcm4|input> (currently input)
jack.fp-pink [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
jack.fp-pink.mute ON|OFF (currently ON)
jack.blue.mode <front|rear|center/LFE|side|pcm4|input> (currently input)
jack.blue [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
jack.blue.mute ON|OFF (currently ON)
jack.fp-green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-green.mute ON|OFF (currently OFF)
record.mix.mute.mic1 ON|OFF (currently ON)
record.mix.mute.fp-mic1 ON|OFF (currently ON)
record.mix.mute.linein1 ON|OFF (currently ON)
record.mix.mute.fp-headphone1 ON|OFF (currently ON)
record.mix.mute.int-cd1 ON|OFF (currently ON)
record.mix.mute.green1 ON|OFF (currently ON)
record.mix.mute.black1 ON|OFF (currently ON)
record.mix.mute.orange1 ON|OFF (currently ON)
record.mix.mute.gray1 ON|OFF (currently ON)
record.mix.mute.input-mix1 ON|OFF (currently ON)
record.mix1 [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
record.mix.mute.mic2 ON|OFF (currently ON)
record.mix.mute.fp-mic2 ON|OFF (currently OFF)
record.mix.mute.linein2 ON|OFF (currently ON)
record.mix.mute.fp-headphone2 ON|OFF (currently ON)
record.mix.mute.int-cd2 ON|OFF (currently ON)
record.mix.mute.green2 ON|OFF (currently ON)
record.mix.mute.black2 ON|OFF (currently ON)
record.mix.mute.orange2 ON|OFF (currently ON)
record.mix.mute.gray2 ON|OFF (currently ON)
record.mix.mute.input-mix2 ON|OFF (currently OFF)
record.mix2 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.mic [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.fp-mic [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.linein [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.fp-headphone [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.int-cd [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.green [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.black [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.orange [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.gray [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.input-mix <mic|fp-mic|linein|int-cd> (currently fp-mic)
misc.front-mute ON|OFF (currently OFF)
misc.input-mix-mute1 ON|OFF (currently ON)
misc.front1 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.front2 <front|input-mix> (currently front)
misc.rear-mute ON|OFF (currently ON)
misc.input-mix-mute2 ON|OFF (currently ON)
misc.rear1 [<leftvol>:<rightvol>] (currently 28.4:28.4 dB)
misc.rear2 <rear|input-mix> (currently rear)
misc.center/lfe-mute ON|OFF (currently ON)
misc.input-mix-mute3 ON|OFF (currently ON)
misc.center/lfe1 [<leftvol>:<rightvol>] (currently 28.4:28.4 dB)
misc.center/lfe2 <center/LFE|input-mix> (currently center/LFE)
misc.side-mute ON|OFF (currently ON)
misc.input-mix-mute4 ON|OFF (currently ON)
misc.side1 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.side2 <side|input-mix> (currently side)
misc.pcm4-mute ON|OFF (currently ON)
misc.input-mix-mute5 ON|OFF (currently ON)
misc.pcm41 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.pcm42 <pcm4|input-mix> (currently pcm4)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 192000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|High+|Production|OFF> (currently Production)
vmix0-outvol <monovol> (currently 22.4 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm9 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB) ("gmusicbrowser")
vmix0.pcm10 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB) ("Steam.exe")
vmix0.pcm11 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm12 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)$ ossmix
Selected mixer 0/High Definition Audio ALC888
Known controls are:
jack.green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.green.mute ON|OFF (currently OFF)
jack.black.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.black [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
jack.black.mute ON|OFF (currently ON)
jack.orange.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.orange [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
jack.orange.mute ON|OFF (currently ON)
jack.gray.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.gray [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
jack.gray.mute ON|OFF (currently ON)
jack.pink.mode <front|rear|center/LFE|side|pcm4|input> (currently input)
jack.pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.pink.mute ON|OFF (currently OFF)
jack.fp-pink.mode <front|rear|center/LFE|side|pcm4|input> (currently input)
jack.fp-pink [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
jack.fp-pink.mute ON|OFF (currently ON)
jack.blue.mode <front|rear|center/LFE|side|pcm4|input> (currently input)
jack.blue [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
jack.blue.mute ON|OFF (currently ON)
jack.fp-green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-green.mute ON|OFF (currently OFF)
record.mix.mute.mic1 ON|OFF (currently ON)
record.mix.mute.fp-mic1 ON|OFF (currently ON)
record.mix.mute.linein1 ON|OFF (currently ON)
record.mix.mute.fp-headphone1 ON|OFF (currently ON)
record.mix.mute.int-cd1 ON|OFF (currently ON)
record.mix.mute.green1 ON|OFF (currently ON)
record.mix.mute.black1 ON|OFF (currently ON)
record.mix.mute.orange1 ON|OFF (currently ON)
record.mix.mute.gray1 ON|OFF (currently ON)
record.mix.mute.input-mix1 ON|OFF (currently ON)
record.mix1 [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
record.mix.mute.mic2 ON|OFF (currently ON)
record.mix.mute.fp-mic2 ON|OFF (currently OFF)
record.mix.mute.linein2 ON|OFF (currently ON)
record.mix.mute.fp-headphone2 ON|OFF (currently ON)
record.mix.mute.int-cd2 ON|OFF (currently ON)
record.mix.mute.green2 ON|OFF (currently ON)
record.mix.mute.black2 ON|OFF (currently ON)
record.mix.mute.orange2 ON|OFF (currently ON)
record.mix.mute.gray2 ON|OFF (currently ON)
record.mix.mute.input-mix2 ON|OFF (currently OFF)
record.mix2 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.mic [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.fp-mic [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.linein [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.fp-headphone [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.int-cd [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.green [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.black [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.orange [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.gray [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.input-mix <mic|fp-mic|linein|int-cd> (currently fp-mic)
misc.front-mute ON|OFF (currently OFF)
misc.input-mix-mute1 ON|OFF (currently ON)
misc.front1 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.front2 <front|input-mix> (currently front)
misc.rear-mute ON|OFF (currently ON)
misc.input-mix-mute2 ON|OFF (currently ON)
misc.rear1 [<leftvol>:<rightvol>] (currently 28.4:28.4 dB)
misc.rear2 <rear|input-mix> (currently rear)
misc.center/lfe-mute ON|OFF (currently ON)
misc.input-mix-mute3 ON|OFF (currently ON)
misc.center/lfe1 [<leftvol>:<rightvol>] (currently 28.4:28.4 dB)
misc.center/lfe2 <center/LFE|input-mix> (currently center/LFE)
misc.side-mute ON|OFF (currently ON)
misc.input-mix-mute4 ON|OFF (currently ON)
misc.side1 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.side2 <side|input-mix> (currently side)
misc.pcm4-mute ON|OFF (currently ON)
misc.input-mix-mute5 ON|OFF (currently ON)
misc.pcm41 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.pcm42 <pcm4|input-mix> (currently pcm4)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 192000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|High+|Production|OFF> (currently Production)
vmix0-outvol <monovol> (currently 22.4 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm9 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB) ("gmusicbrowser")
vmix0.pcm10 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB) ("Steam.exe")
vmix0.pcm11 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm12 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
Matti
 
Posts: 38
Joined: Sun May 29, 2011 12:34 pm

Re: rec from vmix loop works only first time after oss start

Postby igorzwx » Sat Jan 07, 2012 9:18 pm

Matti wrote:I've finally managed to get clear recording, but it is to quiet. I wonder is there a possibility to change ossrecord volume.


Yes. If, for example, you replace your headset with Sennheiser PC 131 Headset.
You might have learned in the primary school that copper and gold are good conductors of electric current, especially pure copper and pure gold. That is why Sennheiser headphones and microphones are extremely loud. There is always a warning that you can easily make yourself deaf with Sennheiser devices, if you are stupid enough to ignore instructions and do not set loudness to minimal levels. Furthermore, Sennheiser microphones do not have "noise filters". This is another reason for their loudness.

Moreover, Sennheiser headphones for audiophiles do not have any "in-line volume controls", because such things reduce sound quality (and they also reduce loudness). Even the cheapest Sennheiser HD 201 Headphones (22 EURO in amazon.de) do not have any "in-line volume controls" (they are extremely loud).

In any case, the general rule is: short cables and clean contacts.

Sennheiser PC 131 Headset (42 Euro in amazon.de)
http://www.amazon.de/Sennheiser-PC-131- ... 418&sr=8-1
Sennheiser PC 131 Headset
http://www.sennheiser.com/sennheiser/ho ... s_pc_music
Keep in mind that it is not robust (otherwise, it might be much more expensive).
It was reported that is can be easily broken, if you carry it around without precautions.
If you need something more reliable, you may try more expensive ones (the key words are "voice recognition").

But is it really so quiet? From my experience, it is perfectly possible to record sound with any cheap analog mic on a notebook with HDA and OSS4. My wife is perfectly happy with Logitech ANALOG DESKTOP Mikrofon (13 Euro). It seems to be robust. It has noise filter. The mic is omni-directional http://www.amazon.de/Logitech-980240-09 ... 141&sr=1-2

Usually, OSS4 mixers have one (or even two) additional "controls" with which to regulate loudness of the mic.
On my old box, there are three controls for mic loudness:
Code: Select all
mic <monovol> (currently 100)
igain [<leftvol>:<rightvol>] (currently 100:100)
micboost ON|OFF (currently OFF)

I do not use "micboost", because it amplifies noise.
Both "mic" and "igain" are set to maximum for Sennheiser microphone (!).
On this particular old box mic is relatively quiet. On other old boxes mics are too loud (with OSS4).

If a signal is very weak it should be "muffled". You need a signal which is much louder than electro-magnetic noise, than the evil 50Hz (or 60Hz in US), and background noise. If, for example, I record with Sennheiser uni-directional mic (that of Sennheiser PC 131 Headset), the evil 50Hz are below -70dB (after normalization!). This mean that noise is not audible, you do not need to apply any noise removal, or "notch filter", but you have to remove DC offset. This can be done with Audacity: Effect → Normalize (DC offset removal is enabled by default).

Your mic controls might be these ones:
Code: Select all
jack.pink.mode <front|rear|center/LFE|side|pcm4|input> (currently input)
jack.pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.pink.mute ON|OFF (currently OFF)
jack.fp-pink.mode <front|rear|center/LFE|side|pcm4|input> (currently input)
jack.fp-pink [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
jack.fp-pink.mute ON|OFF (currently ON)
record.mix.mute.input-mix1 ON|OFF (currently ON)
record.mix1 [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
record.mix.mute.input-mix2 ON|OFF (currently OFF)
record.mix2 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.mic [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.fp-mic [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)

You have to study them with "trial and error".

Your guides are your "ossmix", "ossinfo" and "ossinfo -v9". You have to study them and try to understand the "secret esoteric meaning" of each line. Otherwise, the ritual of "trial and error" may go astray.

This is strange:
Code: Select all
jack.fp-pink [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
jack.fp-pink.mute ON|OFF (currently ON)

Why did you mute it and set to zero? Does it produce noise?

Have you tried to record from "mic"?
It seems that you are recording from "fp-mic":
Code: Select all
misc.input-mix <mic|fp-mic|linein|int-cd> (currently fp-mic)


This is also strange:
Code: Select all
record.mix.mute.input-mix1 ON|OFF (currently ON)
record.mix1 [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)

Which device is used for recording?
Your recording devices are:
Code: Select all
HD Audio rec mix                  /dev/oss/oss_hdaudio0/pcmin0  (device index 6) → /dev/dsp_in
HD Audio rec mix                  /dev/oss/oss_hdaudio0/pcmin1  (device index 7)

"6" is your default /dev/dsp → /dev/dsp_in
It is preferable to record from "6" directly (-d6), because /dev/dsp is attached to the virtual mixer (vmix). Notice that "vmix" is a kind of PulseAudio, it may produce noise.
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: rec from vmix loop works only first time after oss start

Postby konst1089 » Sat Jan 28, 2012 10:15 am

My problem is gone. After experiments with OSS mixer I got my sound recorded with ossmix aux1.rec ON ; ossmix record.pcm 100 ; ossmix record.vol 100 (vmix is enabled). At some time I read forums about my sound card, and I know its design is not good and somewhat complicated. So I'm satisfied that it just works. But I think this bug should be fixed or wiki page should be updated to provide information that vmix loopback devices are highly not recommended because they are buggy and not well-supported.
Last edited by konst1089 on Wed Feb 01, 2012 4:01 pm, edited 1 time in total.
konst1089
 
Posts: 8
Joined: Wed Jan 04, 2012 2:59 pm

Re: rec from vmix loop works only first time after oss start

Postby igorzwx » Sat Jan 28, 2012 11:35 am

konst1089 wrote:My problem is gone. After experiments with OSS mixer I get my sound recorded with ossmix aux1.rec ON ; ossmix record.pcm 100 ; ossmix record.vol 100 (vmix is enabled). At some time I read forums about my sound card, and I know its design is not good and somewhat complicated. So I'm satisfied that it just works. But I think this bug should be fixed or wiki page should be updated to provide information that vmix loopback devices are highly not recommended because they are buggy and not well-supported.


Could you please publish a "howto" for this particular soundcard?
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: rec from vmix loop works only first time after oss start

Postby konst1089 » Wed Feb 01, 2012 4:04 pm

Do you mean adding information here?
konst1089
 
Posts: 8
Joined: Wed Jan 04, 2012 2:59 pm

Re: rec from vmix loop works only first time after oss start

Postby igorzwx » Wed Feb 01, 2012 4:36 pm

konst1089 wrote:Do you mean adding information here?


Not. I mean a new thread with a title like this:
[HOWTO] Creative Audigy 4 with OSS4
or
[HOWTO] Recording total mixed output with OSS4
or
[HOWTO] Recording podcast with Skype and OSS4
or else.
1. It should be easy to find.
2. It should contain all the information Ubuntu users may need (screenshots, etc.).
This might be very useful knowledge.
It might be discussed and elaborated.
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: rec from vmix loop works only first time after oss start

Postby konst1089 » Thu Feb 02, 2012 9:53 pm

konst1089
 
Posts: 8
Joined: Wed Jan 04, 2012 2:59 pm

Re: rec from vmix loop works only first time after oss start

Postby igorzwx » Thu Feb 02, 2012 11:17 pm

konst1089 wrote:Created.

Thanks! It seems to be exactly what is needed.

Have you tried to record Skype?
This means "recording total mixed output together with input". It works with ancient soundcards with AC'97 codec (of 1997) http://en.wikipedia.org/wiki/AC%2797

Skype-oss (standalone) is here:
http://www.4front-tech.com/forum/viewto ... 469#p14468
You can simply unpack it and run.

On Arch Linux, Skype-oss can be installed from the official repository:
Code: Select all
$ yaourt skype-oss
1 community/skype-oss 2.0.0.72-2 [installed]
    P2P software for high-quality voice communication (OSS-compatible version)
2 aur/bin32-skype-oss 2.0.0.72-4 (60)
    P2P software for high-quality voice communication (OSS-compatible version)
==> Enter n° of packages to be installed (ex: 1 2 3 or 1-3)
==> -------------------------------------------------------
==>
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: rec from vmix loop works only first time after oss start

Postby konst1089 » Fri Feb 03, 2012 7:44 am

Unfortunately, I haven't a microphone to test Skype. Theoretically input should be mixed with output if you use 'mic', 'pcm' and 'vol' together in the 'record' section, and if you record through 'aux1' as I described in my howto.
konst1089
 
Posts: 8
Joined: Wed Jan 04, 2012 2:59 pm

Re: rec from vmix loop works only first time after oss start

Postby igorzwx » Fri Feb 03, 2012 2:26 pm

konst1089 wrote:Unfortunately, I haven't a microphone to test Skype. Theoretically input should be mixed with output if you use 'mic', 'pcm' and 'vol' together in the 'record' section, and if you record through 'aux1' as I described in my howto.


Yes. In theory, everything should work. In practice, it may depend on the driver.
In any case, it is a good step forward. Such howtos may prevent others from reinventing the wheel http://en.wikipedia.org/wiki/Reinventing_the_wheel

Linux today is becoming increasingly time-consuming. Usually, it is a waste of time. You have to learn how to remove PulseALSA and other "open-source" crap. It is, of course, a sort of "stupid business". That is why many Unix/Linux veterans have already switched to Windows or Mac OS. The number of Linux users is already comparable with the number of the deaf and with the number of schizophrenics
http://blogs.adobe.com/open/2011/06/foc ... lient.html
http://research.gallaudet.edu/Demographics/deaf-US.php
http://www.schizophrenia.com
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Previous

Return to Linux

Who is online

Users browsing this forum: Bing [Bot] and 3 guests