oss_hdaudio codec 0x1aec8800

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

oss_hdaudio codec 0x1aec8800

Postby jorgefm » Mon May 14, 2012 9:14 am

Hi all,

This is my first post in this mailing list. I would like to get help in order to support the Wolfson 8860 HDA codec in
oss. I've developed a patch for the alsa system and I would like to know how to do the same for the OSS4.
I've attached the patch_wolfson.c if useful...

I've implemented a little hdaudio_wolfson.c in kernel/drv/oss_hdaudio using the hdaudio_eeepc.c and
I've modified hdaudio_codecids.h to register the 0x1aec8800 id but osstest always returns

1: oss_hdaudio0 nVidia HD Audio interrupts=215 (215)
HDA Audio controller nVidia HD Audio
Vendor ID: 0x10de0ac0
Subvendor ID: 0x10decb84
Codec 0: Unknown (0x1aec8800/0x00000100)

Any hint is welcome!
Jorge
Attachments
patch_wolfson.c
(6.07 KiB) Downloaded 532 times
jorgefm
New Member
 
Posts: 1
Joined: Mon May 14, 2012 9:02 am

Re: oss_hdaudio codec 0x1aec8800

Postby cesium » Mon May 14, 2012 4:30 pm

Hi there,

Well, this isn't the mailing list. That would be here, and I suggest sending an email there (the devs don't usually check the forum). That said, I'm sure this forum will be happy to help too...

As for the ids, the trick is that hdaudio_codecids.h has the "codec_desc_t codecs[]" array used to identify the codec. Pci ids will require changing oss_hdaudio.c and the ".devices" file (the latter is all too easy to miss). If you could attach your modification perhaps we could look at them too... Also I suggest posting to the sourceforge list as well.
cesium
Developer
 
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am


Return to Linux

Who is online

Users browsing this forum: Google [Bot] and 1 guest