b44 problem

OSS specific Solaris discussion (x86/SPARC)

Moderators: hannu, dev, kodachi, cesium

b44 problem

Postby mbejan » Tue Jul 25, 2006 11:08 am

Code: Select all
uname -a
SunOS alcatraz 5.11 NexentaOS_20060717 i86pc i386 i86pc Solaris


I have a nx6125 laptop and the latest oss-amd64 build (4-159),

Code: Select all
Jul 25 13:54:50 alcatraz genunix: [ID 819705 kern.notice] /platform/i86pc/kernel/drv/amd64//atiaudio: undefined symbol
Jul 25 13:54:50 alcatraz genunix: [ID 826211 kern.notice]  'VIRT_TO_BUS'
Jul 25 13:54:50 alcatraz genunix: [ID 472681 kern.notice] WARNING: mod_load: cannot load module 'atiaudio'


Code: Select all
ossdetect:
...................
add_drv -m '* 0666 root sys' -i '"pci1002,4370"' atiaudio
devfsadm: driver failed to attach: atiaudio
Warning: Driver (atiaudio) successfully added to system but failed to attach
..................

Any ideas.... please.... with b43 kernel and/or oss-amd64 build 4-158 was working fine... I upgrated my kernel and oss build and I don't have sound anymore.

Thank you.

Marius Bejan
mbejan
 
Posts: 1
Joined: Tue Jul 25, 2006 10:59 am

Re: b44 problem

Postby dev » Tue Aug 01, 2006 5:10 am

mbejan wrote:
Code: Select all
uname -a
SunOS alcatraz 5.11 NexentaOS_20060717 i86pc i386 i86pc Solaris


I have a nx6125 laptop and the latest oss-amd64 build (4-159),

Code: Select all
Jul 25 13:54:50 alcatraz genunix: [ID 819705 kern.notice] /platform/i86pc/kernel/drv/amd64//atiaudio: undefined symbol
Jul 25 13:54:50 alcatraz genunix: [ID 826211 kern.notice]  'VIRT_TO_BUS'
Jul 25 13:54:50 alcatraz genunix: [ID 472681 kern.notice] WARNING: mod_load: cannot load module 'atiaudio'


Code: Select all
ossdetect:
...................
add_drv -m '* 0666 root sys' -i '"pci1002,4370"' atiaudio
devfsadm: driver failed to attach: atiaudio
Warning: Driver (atiaudio) successfully added to system but failed to attach
..................

Any ideas.... please.... with b43 kernel and/or oss-amd64 build 4-158 was working fine... I upgrated my kernel and oss build and I don't have sound anymore.

Thank you.

Marius Bejan



It will take a week before we can look into this problem as the engineer is on summer vacation.


regards
Dev Mazumdar
dev
 
Posts: 576
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby dev » Mon Aug 07, 2006 6:34 pm

Hi,

OSS build 160 is now available for Solaris x86 and Sparc and the problem with the ATI audio driver is fixed.


Thanks for your patience in this matter.



best regards
Dev Mazumdar
dev
 
Posts: 576
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA


Return to Solaris

Who is online

Users browsing this forum: No registered users and 2 guests