intelpci_rate_tuning

OSS specific Solaris discussion (x86/SPARC)

Moderators: hannu, dev, cesium, kodachi

intelpci_rate_tuning

Postby swmackie » Mon Jul 02, 2007 4:13 pm

I have encountered the problem described in the ICH manual page regarding playback speeds (Compaq Deskpro EN).

# ossinfo
Version info: OSS 4.0 (build 1003/200706130337) (0x00040002)
Platform: SunOS/i86pc 5.10 Generic_118855-33

Number of audio devices: 2
Number of audio engines: 6
Number of MIDI devices: 0
Number of mixer devices: 2


Device objects
0: oss0 OSS core services
1: ossusb0 USB audio/MIDI device
2: softoss0 OSS Virtual Mixer v3.0
3: sadasupport0 SADA compatibility layer
4: ich0 Intel ICH2 (2445)

MIDI devices (/dev/midi*)

Mixer devices (/dev/mixer*)
0: ICH AC97 Mixer (AD1885) (Mixer 0 of device object 4)
1: Virtual Mixer (Mixer 0 of device object 2)

Audio devices
/dev/oss/ich0/pcm0 Intel ICH2 (2445) (device index 0)
/dev/oss/softoss0/pcm0 OSS Virtual Mixer v3.0 Playback (device index 1)


Running "osstest -V" reports:

Sound subsystem and version: OSS 4.0 (build 1003/200706130337) (0x00040002)
Platform: SunOS/i86pc 5.10 Generic_118855-33

*** Scanning sound adapter #-1 ***
/dev/oss/ich0/pcm0 (audio engine 0): Intel ICH2 (2445)
- Performing audio playback test...
left OK right OK stereo OK measured srate 55847.00 Hz (16.35%)

*** Scanning sound adapter #4 ***
/dev/oss/softoss0/pcm0 (audio engine 2): OSS Virtual Mixer v3.0 Playback
- Performing audio playback test...
left OK right OK stereo OK measured srate 55779.00 Hz (16.21%)

*** All tests completed OK ***

The sample rate is 16%. Using this information I make the "intelpci_rate_tuning" value in "/usr/lib/oss/conf/ich.conf" 280.

I have tried several combinations of "soundoff", "soundon", "ossdetect", rebooting, "init 6" but am unable to alter the playback speed. "osstest" will still report the srate value of 16%.

I've run the above as root from the console. I normally have JDS disabled (svcadm disable cde-login) and use "xinit" from the console to load Xsun and Windowmaker.

"realplay" still plays BBC News way too fast and "jmplay" whizzes through .ogg's.


Any ideas?


Cheers,

Stuart
swmackie
New Member
 
Posts: 5
Joined: Sun Jun 17, 2007 7:28 pm

Postby dev » Mon Jul 02, 2007 4:24 pm

You need to run ossdetect again so that the the drivers are reinstalled with the new settings.



regards
Dev Mazumdar
dev
Developer
 
Posts: 580
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby swmackie » Mon Jul 02, 2007 4:36 pm

[quote="dev"]You need to run ossdetect again so that the the drivers are reinstalled with the new settings.



regards
Dev Mazumdar[/quote]


After editing the "ich.conf" file to reflect the sample rate, I've tried running "ossdetect" and then "osstest" but always get the same problem.

I've tried:

"ossdetect", "osstest".
"ossdetect", reboot, "osstest".
"soundoff", "ossdetect", reboot, "osstest".
"soundoff", "ossdetect", reboot, "soundon", "osstest".

... and such combinations. It's as if my changes to "/usr/lib/oss/conf/ich.conf" are being ignored. I am currently trying random values (like 700, etc). Will persevere...
swmackie
New Member
 
Posts: 5
Joined: Sun Jun 17, 2007 7:28 pm

Postby swmackie » Mon Jul 02, 2007 6:02 pm

Hi,

I've installed the audio drivers from:

http://www.tools.de/opensource/solaris/audio/

Following the instructions in "/platform/i86pc/kernel/drv/audioi810.conf" I have been able to solve the problem - multimedia apps now behave as expected.

I used the setting:

ac97_codec_clockrate=55813


HTH,

Stuart.
swmackie
New Member
 
Posts: 5
Joined: Sun Jun 17, 2007 7:28 pm


Return to Solaris

Who is online

Users browsing this forum: No registered users and 1 guest

cron