Soundcard IRQs

OSS specific Solaris discussion (x86/SPARC)

Moderators: cesium, dev, kodachi, hannu

Soundcard IRQs

Postby alarcher » Sat Nov 24, 2007 5:16 pm

Hi,
I run Opensolaris and installed OSS 4.0 v1009.

My card is recognized as:


Code: Select all
bash-3.2$ ossinfo
Version info: OSS 4.0 (b1009/200711141733) (0x00040003)
Platform: SunOS/i86pc 5.11 opensol-20071119 (charon)

Number of audio devices:        3
Number of audio engines:        11
Number of MIDI devices:         0
Number of mixer devices:        1


Device objects
0: hdaudio0 Intel HD Audio
    HD Audio controller Intel HD Audio
    Vendor ID    0x80862668
    Subvendor ID 0x101405b7
     Codec  0: AD1981 (0x11d41981/0x10140597)
     Codec  1: Unknown (0x14f12bfa)
1: sadasupport0 SADA compatibility layer
2: osscore0 OSS common devices
3: ossusb0 USB audio/MIDI device
4: vmix0 OSS transparent virtual support

MIDI devices (/dev/midi*)

Mixer devices (/dev/mixer*)
0: Intel HD Audio AD1981 (Mixer 0 of device object 0)

Audio devices
/dev/oss/hdaudio0/pcm0  Intel HD Audio play  (device index 0)
/dev/oss/hdaudio0/pcm1  Intel HD Audio <null>  (device index 1)
/dev/oss/hdaudio0/pcmin0        Intel HD Audio rec  (device index 2)



I had no problems to configure the soundcard but my system is now rather slow and sound is interupting temporarily when I switch from an application to another (web browser mainly).

intrstat shows that interrupt is shared between USB, networking card, pcmcia and soundcard... is it a problem and how can i get rid of it ?

Thanks in advance,

Aurelien
alarcher
New Member
 
Posts: 1
Joined: Sat Nov 24, 2007 5:07 pm

Return to Solaris

Who is online

Users browsing this forum: No registered users and 1 guest

cron