Installing OSS for Solaris on EeePC

OSS specific Solaris discussion (x86/SPARC)

Moderators: cesium, dev, kodachi, hannu

Installing OSS for Solaris on EeePC

Postby masafumi_ohta » Sat Apr 05, 2008 5:43 am

hi all,
I tried to install OSS driver for Solaris(oss-solaris-v4.0-1015-i386.pkg) on EeePC,
but it was succeed in installing but failed to attach:-(

Seeing /var/adm/messages;there were 'WARNINGS' about it as follows;

Apr 5 07:13:21 EeePC audiosup: [ID 686142 kern.warning] WARNING: audiohd0: unsu
pported HD codec: vid=0x10ec0662, rev=0x00100101
Apr 5 07:13:21 EeePC audiosup: [ID 493330 kern.warning] WARNING: audiohd0: audi
ohd_attach() couldn't create codec

(by the way,EeePC used Realtek ALC6626 HD Audio)

I'd appreciated if you could give me some advice to me.

-Sincerely

masafumi_ohta
masafumi_ohta
New Member
 
Posts: 2
Joined: Sat Apr 05, 2008 5:19 am

Re: Installing OSS for Solaris on EeePC

Postby dev » Sat Apr 05, 2008 3:49 pm

masafumi_ohta wrote:hi all,
I tried to install OSS driver for Solaris(oss-solaris-v4.0-1015-i386.pkg) on EeePC,
but it was succeed in installing but failed to attach:-(

Seeing /var/adm/messages;there were 'WARNINGS' about it as follows;

Apr 5 07:13:21 EeePC audiosup: [ID 686142 kern.warning] WARNING: audiohd0: unsu
pported HD codec: vid=0x10ec0662, rev=0x00100101
Apr 5 07:13:21 EeePC audiosup: [ID 493330 kern.warning] WARNING: audiohd0: audi
ohd_attach() couldn't create codec

(by the way,EeePC used Realtek ALC6626 HD Audio)

I'd appreciated if you could give me some advice to me.

-Sincerely

masafumi_ohta


This is a message from Solaris' audiohd driver. OSS's driver is called hdaudio.


regards
Dev Mazumdar
dev
Developer
 
Posts: 580
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Re: Installing OSS for Solaris on EeePC

Postby masafumi_ohta » Sat Apr 05, 2008 6:36 pm

dev wrote:
masafumi_ohta wrote:hi all,
I tried to install OSS driver for Solaris(oss-solaris-v4.0-1015-i386.pkg) on EeePC,
but it was succeed in installing but failed to attach:-(

Seeing /var/adm/messages;there were 'WARNINGS' about it as follows;

Apr 5 07:13:21 EeePC audiosup: [ID 686142 kern.warning] WARNING: audiohd0: unsu
pported HD codec: vid=0x10ec0662, rev=0x00100101
Apr 5 07:13:21 EeePC audiosup: [ID 493330 kern.warning] WARNING: audiohd0: audi
ohd_attach() couldn't create codec

(by the way,EeePC used Realtek ALC6626 HD Audio)

I'd appreciated if you could give me some advice to me.

-Sincerely

masafumi_ohta


This is a message from Solaris' audiohd driver. OSS's driver is called hdaudio.


regards
Dev Mazumdar


hi Dev-san

Thanks reply,I'm glad.
my friend helped me so that it could work.

he said I should write driver entry for 'hdaudio',that is,

etc/driver_aliases
hdaudio "pci10ec,0662"

then rebooted EeePC but It didn't work,
so I tried to re-install OSS driver,then tried the command 'osstest'
It worked so fine,and it was recoginized by gnome sound manager:D

Thans again so much your cooparation!

Wooooooow!
masafumi_ohta
New Member
 
Posts: 2
Joined: Sat Apr 05, 2008 5:19 am


Return to Solaris

Who is online

Users browsing this forum: Majestic-12 [Bot] and 1 guest

cron