no audio on solaris 10 except xmms

OSS specific Solaris discussion (x86/SPARC)

Moderators: cesium, dev, kodachi, hannu

no audio on solaris 10 except xmms

Postby inquirest » Wed Mar 02, 2005 5:59 pm

x86 with c-media on board device with OSS drivers can only play sound files, through command line with OSS commands and xmms player.

Java player refuse to play anything with an error "cannot open audio device". Sound control application only shows record settings without playback settings. Gnome system sounds do not work.

Any suggestions how to make the whole system use the OSS drivers.

thanks..
inquirest
 

Re: no audio on solaris 10 except xmms

Postby dev » Wed Mar 02, 2005 7:36 pm

inquirest wrote:x86 with c-media on board device with OSS drivers can only play sound files, through command line with OSS commands and xmms player.

Java player refuse to play anything with an error "cannot open audio device". Sound control application only shows record settings without playback settings. Gnome system sounds do not work.

Any suggestions how to make the whole system use the OSS drivers.

thanks..


Once you install OSS, you need to logout and log back in so that the
JDS audio server can start up.

Right now you can only use XMMS to play media files since JMP isn't
tuned to the OSS API. XMMS is a better media player (after all we
wrote it!)


regards
Dev
dev
Developer
 
Posts: 578
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby Guest » Thu Mar 03, 2005 2:57 pm

Sure XMMS is a better player. The problem is after reboot, the overall system is not aware of the drivers -after soundon command-. The audio control tool does not show any playback settings. So the drivers are usable by XMMS only.
Using the tool that came with OSS drivers to add the initialization script to turn on the drivers in the boot process but that made no difference.
On solaris 10 on which /etc/rc file "soundon" can be added?
What could be the proper way to point the drivers to the whole system?

thanks...
Guest
 

Postby Guest » Sun Mar 06, 2005 5:33 pm

I've found that I have one of two ways to get sound to work:

1) to do a command line login when dtlogin comes up and then run soundon manually as root, then when I login the sound server is enabled and all is well

2) after I login startup a shell, su as root, then run soundon, and then close the terminal, at that point the sound server works (since it's set to startup) and there's sound in all my apps, not just xmms

However, the JDS sound server is not enabled by default if I remember correctly. You'll have to go under Preferences -> Desktop Preferences -> Sound and check the enable sound server startup option.
Guest
 


Return to Solaris

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest