how to use oss drivers with xmms?

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: cesium, dev, kodachi, hannu

how to use oss drivers with xmms?

Postby fart » Thu May 27, 2004 9:58 pm

guess this is a stupid question but.. :oops:

i've just installed oss 3.98, the module is loaded, osstest works fine and so on.. but..

i can't choose the oss 3.98 as output-plugin in xmms :\

it's just the same old oss 1.2.10 driver there :|

anyone know what i've forgot to do? :o
fart
 

Re: how to use oss drivers with xmms?

Postby dev » Fri May 28, 2004 4:52 pm

fart wrote:guess this is a stupid question but.. :oops:

i've just installed oss 3.98, the module is loaded, osstest works fine and so on.. but..

i can't choose the oss 3.98 as output-plugin in xmms :\

it's just the same old oss 1.2.10 driver there :|

anyone know what i've forgot to do? :o


Hit Ctrl P with the mouse in the XMMS window. Then look at
the Output Plugin List and change to XMMS. Hit configure button
and ensure that the output is set to OSS output.


regards
Dev
dev
Developer
 
Posts: 580
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby garry » Tue Jun 01, 2004 12:22 pm

I also have no sound with XMMS, but osstest finishes without errors.

So I also tried to change to the mentioned XMMS output plugin, but it doesn't appear in the list there...?

I have the choice of:

- ALSA 1.2.10
- Disk writer plugin
- esound output plugin
- oss driver 1.2.10 (I chose this one)

with ossctl I have per default all the 8 virtual mixer v2.5 playback channels on top of the others.

Do I need to do something to get "XMMS" listed in the output plugin pulldown-menu?
garry
 

Postby garry » Tue Jun 01, 2004 12:38 pm

maybe some additional information:

kernel 2.6.7-rc1, vanilla sources
soundcard: lynx one (+ onboard via)
driver: oss3991c-linux-i386-v26
garry
 

Postby garri » Tue Jun 01, 2004 1:36 pm

ok, I get XMMS running if I choose exactly the right dsp, in my case /dev/dsp2.

I was expecting that with the virtual mixer everything gets routed to /dev/dsp, in such a way that even more than one application can access /dev/dsp without having each application to deal with a different /dev/dspX. And I saw that all the virtual channels are only for onboard sound, not for my lynx one, which offers only analog/digital in/out.

Is it possible to have a /dev/dsp for my lynx one, so that I don't have to make settings to every program?
garri
 

Postby Guest » Tue Jun 01, 2004 2:34 pm

but,
the "oss driver 1.2.10" in xmms, isn't that a driver that comes default with xmms? not the *new* one that's bought from this site?
Guest
 

Postby garry » Tue Jun 01, 2004 4:36 pm

you're probably right, but I just have no other joices in XMMS...
In my opinion, everything should be set up in a way that every program can access the soundcard via /dev/dsp, but /dev/dsp is not a link and I have no idea what it is good for. The idea behind that is for me that an application works with /dev/dsp as default and no necessary sound ouput configuration like I have to do. Well, let's just wait for qualified answers :wink:
garry
 

Postby Guest » Tue Jun 01, 2004 5:29 pm

garry wrote:maybe some additional information:

kernel 2.6.7-rc1, vanilla sources
soundcard: lynx one (+ onboard via)
driver: oss3991c-linux-i386-v26


Um, isn't this a Linux question rather than a FreeBSD question?
Guest
 

Postby garry » Tue Jun 01, 2004 6:59 pm

ooops, sorry :oops:
I just did a search on XMMS and mainly found this thread here...
garry
 

Postby Guest » Sat Jan 22, 2005 10:31 pm

/usr/porta/audio/xmmsosssurround

And then choose new driver in XMMS preferences,there locate eSound OSS-1.2.10.
Guest
 

poker casino758

Postby poker casino758 » Sun Feb 19, 2006 1:58 am

poker casino758
 


Return to BSD

Who is online

Users browsing this forum: No registered users and 1 guest