Settting up KDE for FreeBSD

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: hannu, dev, kodachi, cesium

Settting up KDE for FreeBSD

Postby dev » Sat Jul 08, 2006 5:47 pm

Many people have complained that with certain drivers KDE doesn't work correctly.

Here's the general settings you can use for KDE (applicable for all OSS device drivers)

1) Select KDE Start -> "Settings" -> "Sound & Multimedia" -> Sound System
2) Under the General tab disable "Run with highest possible priority" - this is not needed
3) Under the Hardware tab select Audio device as : Threaded Open Sound System
then set the Use Custom sampling rate and set it to 48000 Hz
then set the Quality as 16bit.

Save and exit and restart KDE.
Last edited by dev on Thu Mar 22, 2007 4:35 am, edited 1 time in total.
dev
 
Posts: 576
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

sound conflict w/kde

Postby user_42 » Tue Jan 30, 2007 3:56 am

I did this set up and although it gave me sound from kde, it killed sound from realplayer.
I also got the following error in dmesg/messages

kernel: osscore: len=0/4096, total=40960
kernel: osscore: Audio output 0 doesn't drain (114688/73728 0)
co te nezabiji, te posili.
- neitche
user_42
 
Posts: 3
Joined: Tue Jan 30, 2007 3:51 am

Re: sound conflict w/kde

Postby dev » Tue Jan 30, 2007 4:13 am

user_42 wrote:I did this set up and although it gave me sound from kde, it killed sound from realplayer.
I also got the following error in dmesg/messages

kernel: osscore: len=0/4096, total=40960
kernel: osscore: Audio output 0 doesn't drain (114688/73728 0)



What sound card? Raelplayer doesn't use KDE. it talks directly to OSS.


regards
Dev mazumdar
dev
 
Posts: 576
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

soundcard

Postby user_42 » Tue Jan 30, 2007 4:20 am

This is my soundcard.

ich0: <Intel ICH4 (24C5)> port 0x1c00-0x1cff,0x18c0-0x18ff mem 0xd0000c00-0xd0000dff,0xd0000800-0xd00008ff irq 10 at device 31.5 on pci0

I think the problem comes from some kind of conflict. It seems like when kde takes over the dev's it won't share. The system works otherwise if I turn off kde. That includes mplayer.
co te nezabiji, te posili.
- neitche
user_42
 
Posts: 3
Joined: Tue Jan 30, 2007 3:51 am

Re: soundcard

Postby dev » Tue Jan 30, 2007 5:17 am

user_42 wrote:This is my soundcard.

ich0: <Intel ICH4 (24C5)> port 0x1c00-0x1cff,0x18c0-0x18ff mem 0xd0000c00-0xd0000dff,0xd0000800-0xd00008ff irq 10 at device 31.5 on pci0

I think the problem comes from some kind of conflict. It seems like when kde takes over the dev's it won't share. The system works otherwise if I turn off kde. That includes mplayer.


I think you have a conflict between two drivers - you should look at /boot/loader.conf and delete snd=yes and ich=yes and then install OSS and use soundon to activate that audio.


regards
Dev mazumdar
dev
 
Posts: 576
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

conflict

Postby user_42 » Tue Jan 30, 2007 3:55 pm

Dev,

That is exactly how I have it set up. I even just now went back and reinstalled from single-user to make sure, but it was no help.

If kde sound is on, I get sound through kde. But I get no non-kde sound. If I turn kde sound off, everything -- but sounds from kde -- works fine.


Jason
co te nezabiji, te posili.
- neitche
user_42
 
Posts: 3
Joined: Tue Jan 30, 2007 3:51 am


Return to BSD

Who is online

Users browsing this forum: No registered users and 1 guest

cron