IntelHDA: no sound with 4.0rc0-162

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: hannu, dev, kodachi, cesium

IntelHDA: no sound with 4.0rc0-162

Postby anton » Sat Aug 26, 2006 8:26 pm

I've got a problem with my Asus A8Jc laptop. Tried versions 3.994b, 4.0-161 and 4.0-162. The sound card detects, but nothing is heard. Here are outputs:
dmesg:
hdaudio0: <Intel High Definition Audio> mem 0xfebfc000-0xfebfffff irq 21 at device 27.0 on pci0
osscore: Audio output 0 doesn't drain (2621440/2605056 0).
osscore: len=0/2048, total=16384

pciconf -lv
hdaudio0@pci0:27:0: class=0x040300 card=0x11531043 chip=0x27d88086 rev=0x02 hdr=0x00
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) High Definition Audio'
class = multimedia

ossinfo
Version info: OSS 4.0rc0 (build 162/200608251741) (0x00040000)

Number of audio devices: 17
Number of MIDI devices: 0
Number of mixer devices: 2


Device objects
0: hdaudio0 Intel High Definition Audio
1: softoss0 OSS Virtual Mixer v3.0

MIDI devices (/dev/midi*)

Mixer devices (/dev/mixer*)
0: Intel High Definition Audio AD19
(Mixer 0 of device object 0)
1: Virtual Mixer (Mixer 0 of device object 1)

Audio devices (/dev/dsp*)
0: Intel High Definition Audio spdifout output (audio port 0 of device object 0)
1: Intel High Definition Audio pcm1 output (audio port 1 of device object 0)
2: Intel High Definition Audio pcm2 output (audio port 2 of device object 0)
3: Intel High Definition Audio pcm3 output (audio port 3 of device object 0)
4: Intel High Definition Audio rec input (audio port 4 of device object 0)
5: OSS Virtual Mixer v3.0 Playback CH #1 (audio port 0 of device object 1)
6: OSS Virtual Mixer v3.0 Playback CH #2 (audio port 1 of device object 1)
7: OSS Virtual Mixer v3.0 Playback CH #3 (audio port 2 of device object 1)
8: OSS Virtual Mixer v3.0 Playback CH #4 (audio port 3 of device object 1)
9: OSS Virtual Mixer v3.0 Playback CH #5 (audio port 4 of device object 1)
10: OSS Virtual Mixer v3.0 Playback CH #6 (audio port 5 of device object 1)
11: OSS Virtual Mixer v3.0 Playback CH #7 (audio port 6 of device object 1)
12: OSS Virtual Mixer v3.0 Playback CH #8 (audio port 7 of device object 1)
13: Virtual Mixer Loopback Record CH #1 (audio port 8 of device object 1)
14: Virtual Mixer Loopback Record CH #2 (audio port 9 of device object 1)
15: Virtual Mixer Loopback Record CH #3 (audio port 10 of device object 1)
16: Virtual Mixer Loopback Record CH #4 (audio port 11 of device object 1)

ossmix:
Selected mixer 0/
Known controls are:
connector.green1.function <select1|mic-in|line-in> (currently select1)
connector.green1.vol <both/leftvol>[:<rightvol>] (currently 31:31)
connector.green2.function <select2|mic-in|line-in> (currently select2)
connector.green2.vol <both/leftvol>[:<rightvol>] (currently 31:31)
connector.blue1.function <select3|mic-in|line-in> (currently select3)
connector.blue1.vol <both/leftvol>[:<rightvol>] (currently 31:31)
connector.pink1.function <select4|mic-in|line-in> (currently select4)
connector.pink1.vol <both/leftvol>[:<rightvol>] (currently 31:31)
connector.black1.function <select5|mic-in|line-in> (currently select5)
connector.black1.vol <monovol> (currently 31)
connector.pink2 <mic-in|line-in> (currently line-in)
connector.blue2 <mic-in|line-in> (currently line-in)
connector.black2 <mic-in|line-in> (currently line-in)
connector.black3 <mic-in|line-in> (currently line-in)
connector.black4 <mic-in|line-in> (currently line-in)
connector.unused <mic-in|line-in> (currently line-in)
connector.black5 <spdifout|mic-in|line-in> (currently spdifout)
pcm1 <both/leftvol>[:<rightvol>] (currently 31:31)
pcm1mute ON|OFF (currently OFF)
pcm2 <both/leftvol>[:<rightvol>] (currently 31:31)
pcm2mute ON|OFF (currently OFF)
pcm3 <both/leftvol>[:<rightvol>] (currently 31:31)
pcm3mute ON|OFF (currently OFF)
mix3.pcm2 <monovol> (currently 0)
mix3.pcm2.mute ON|OFF (currently OFF)
mix3.pcm3 <monovol> (currently 0)
mix3.pcm3.mute ON|OFF (currently OFF)
mix3.vol <monovol> (currently 0)
mix3.mute ON|OFF (currently OFF)
select1 <mix1|pcm2|pcm3> (currently mix1)
select2 <mix1|pcm2> (currently mix1)
select3 <pcm2|mix1> (currently pcm2)
select4 <pcm3|mix1> (currently pcm3)
select5 <mix1|select8> (currently mix1)
select6.src <pink2|blue2|pink1|pink1|mix4|mix5|mix6|mix7> (currently pink2)
select6.vol <both/leftvol>[:<rightvol>] (currently 3:3)
select7 <blue2|blue1|pink2> (currently blue2)
select8 <select6|select6> (currently select6)
select9.src <select8|black3||black2|select7|mix1|mix1|black4> (currently select8)
select9.vol <both/leftvol>[:<rightvol>] (currently 15:15)
select9.mute ON|OFF (currently OFF)
select10.vol <both/leftvol>[:<rightvol>] (currently 31:31)
select10.mute ON|OFF (currently OFF)
select11.vol <monovol> (currently 31)
select11.mute ON|OFF (currently OFF)
select12.vol <both/leftvol>[:<rightvol>] (currently 31:31)
select12.mute ON|OFF (currently OFF)
select13.vol <both/leftvol>[:<rightvol>] (currently 31:31)
select13.mute ON|OFF (currently OFF)
select14.vol <both/leftvol>[:<rightvol>] (currently 31:31)
select14.mute ON|OFF (currently OFF)
select15.src <beep|unused> (currently beep)
select15.vol <monovol> (currently 0)
select15.mute ON|OFF (currently ON)

osstest
*** Scanning sound adapter #-1 ***
/dev/dsp0 Intel High Definition Audio spdifout output (adapter0, subdev0)
- Performing audio playback test...
<left> OK <right> OK <stereo> OK <real srate 47962.00 Hz (-0.08%)>
/dev/dsp1 Intel High Definition Audio pcm1 output (adapter0, subdev1)
- Performing audio playback test...
<left> OK <right> OK <stereo> OK <real srate 47964.00 Hz (-0.07%)>
/dev/dsp2 Intel High Definition Audio pcm2 output (adapter0, subdev2)
- Performing audio playback test...
<left> OK <right> OK <stereo> OK <real srate 47964.00 Hz (-0.07%)>
/dev/dsp3 Intel High Definition Audio pcm3 output (adapter0, subdev3)
- Performing audio playback test...
<left> OK <right> OK <stereo> OK <real srate 47964.00 Hz (-0.07%)>
/dev/dsp4 Intel High Definition Audio rec input (adapter0, subdev4)
- Skipping input only device

*** Scanning sound adapter #0 ***
/dev/dsp5 OSS Virtual Mixer v3.0 Playback CH #1 (adapter1, subdev0)
- Skipping virtual device (use -V to force test)

*** Scanning sound adapter #0 ***
/dev/dsp6 OSS Virtual Mixer v3.0 Playback CH #2 (adapter1, subdev1)
- Skipping virtual device (use -V to force test)

*** Scanning sound adapter #0 ***
/dev/dsp7 OSS Virtual Mixer v3.0 Playback CH #3 (adapter1, subdev2)
- Skipping virtual device (use -V to force test)

*** Scanning sound adapter #0 ***
/dev/dsp8 OSS Virtual Mixer v3.0 Playback CH #4 (adapter1, subdev3)
- Skipping virtual device (use -V to force test)

*** Scanning sound adapter #0 ***
/dev/dsp9 OSS Virtual Mixer v3.0 Playback CH #5 (adapter1, subdev4)
- Skipping virtual device (use -V to force test)

*** Scanning sound adapter #0 ***
/dev/dsp10 OSS Virtual Mixer v3.0 Playback CH #6 (adapter1, subdev5)
- Skipping virtual device (use -V to force test)

*** Scanning sound adapter #0 ***
/dev/dsp11 OSS Virtual Mixer v3.0 Playback CH #7 (adapter1, subdev6)
- Skipping virtual device (use -V to force test)

*** Scanning sound adapter #0 ***
/dev/dsp12 OSS Virtual Mixer v3.0 Playback CH #8 (adapter1, subdev7)
- Skipping virtual device (use -V to force test)

*** Scanning sound adapter #0 ***
/dev/dsp13 Virtual Mixer Loopback Record CH #1 (adapter1, subdev8)
- Skipping input only device

*** Scanning sound adapter #0 ***
/dev/dsp14 Virtual Mixer Loopback Record CH #2 (adapter1, subdev9)
- Skipping input only device

*** Scanning sound adapter #0 ***
/dev/dsp15 Virtual Mixer Loopback Record CH #3 (adapter1, subdev10)
- Skipping input only device

*** Scanning sound adapter #0 ***
/dev/dsp16 Virtual Mixer Loopback Record CH #4 (adapter1, subdev11)
- Skipping input only device

*** All tests completed OK ***

dmesg -a
FreeBSD 6.1-RELEASE FreeBSD 6.1-RELEASE #0: Fri Aug 25 21:17:25 MSD 2006 root@:/usr/src/sys/i386/compile/GENERIC i386


No sound both in headphones and speakers. In ossmix select15.* and mix3.* are not adjustable. Could you help me?
anton
 
Posts: 4
Joined: Thu Aug 24, 2006 9:05 pm
Location: Moscow

Postby dev » Sun Aug 27, 2006 5:10 pm

Hi,

Try:

ossmix pcm1 127

then ru osstest

Also post the output from cat /dev/sndstat - I need to see the Codec ID of the mixer device.


regards
Dev Mazumdar
dev
 
Posts: 576
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby anton » Mon Aug 28, 2006 5:45 am

Nothing happened. Here is /dev/sndstat:
OSS 4.0rc0 (build 162/200608251741) (C) 4Front Technologies 1996-2006

**** UNREGISTERED VERSION ****

This OSS version will expire after: Mar 2007
Kernel: FreeBSD 6.1-RELEASE #0: Fri Aug 25 21:17:25 MSD 2006
root@:/usr/src/sys/i386/compile/GENERIC


Audio devices:
0: Intel High Definition Audio spdifout output
1: Intel High Definition Audio pcm1 output
2: Intel High Definition Audio pcm2 output
3: Intel High Definition Audio pcm3 output
4: Intel High Definition Audio rec input
5: OSS Virtual Mixer v3.0 Playback CH #1 (GRC3)
6: OSS Virtual Mixer v3.0 Playback CH #2 (GRC3)
7: OSS Virtual Mixer v3.0 Playback CH #3 (GRC3)
8: OSS Virtual Mixer v3.0 Playback CH #4 (GRC3)
9: OSS Virtual Mixer v3.0 Playback CH #5 (GRC3)
10: OSS Virtual Mixer v3.0 Playback CH #6 (GRC3)
11: OSS Virtual Mixer v3.0 Playback CH #7 (GRC3)
12: OSS Virtual Mixer v3.0 Playback CH #8 (GRC3)
13: Virtual Mixer Loopback Record CH #1 (GRC3)
14: Virtual Mixer Loopback Record CH #2 (GRC3)
15: Virtual Mixer Loopback Record CH #3 (GRC3)
16: Virtual Mixer Loopback Record CH #4 (GRC3)

MIDI devices:
*** MIDI support not available in this OSS version ***

Mixers:
0: Intel High Definition Audio AD1986A
1: Virtual Mixer

History:
dsp0: pid 2358 cmd 'osstest' OUT
dsp1: pid 2358 cmd 'osstest' OUT
dsp2: pid 2358 cmd 'osstest' OUT
dsp3: pid 2358 cmd 'osstest' OUT


NOTICE! This /dev/sndstat file is obsolete - use the ossinfo command instead
anton
 
Posts: 4
Joined: Thu Aug 24, 2006 9:05 pm
Location: Moscow

Postby kash » Thu Aug 31, 2006 12:49 am

Try using /dev/dsp3.
kash
 
Posts: 15
Joined: Mon Jul 10, 2006 4:55 am
Location: Far, far away.

Postby dev » Thu Aug 31, 2006 1:27 am

kash wrote:Try using /dev/dsp3.


so audio works from the /dev/dsp3 output?

/dev/dsp0 looks like it's connected to the SPDIF output jack so it's not going to play audio.


regards
dev
dev
 
Posts: 576
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby anton » Thu Aug 31, 2006 8:13 am

No, it does not. Neither osstest, nor xmms/realplayer play no sound. I've linked ln -s /dev/dsp3 /dev/dsp and tried. Nothing in headphones and speakers.
anton
 
Posts: 4
Joined: Thu Aug 24, 2006 9:05 pm
Location: Moscow

Postby dev » Thu Aug 31, 2006 4:32 pm

anton wrote:No, it does not. Neither osstest, nor xmms/realplayer play no sound. I've linked ln -s /dev/dsp3 /dev/dsp and tried. Nothing in headphones and speakers.


OK we'll have to get one of these machines inhouse to test with.


regards
Dev
dev
 
Posts: 576
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby kash » Wed Sep 13, 2006 8:58 pm

dev wrote:
anton wrote:No, it does not. Neither osstest, nor xmms/realplayer play no sound. I've linked ln -s /dev/dsp3 /dev/dsp and tried. Nothing in headphones and speakers.


OK we'll have to get one of these machines inhouse to test with.


regards
Dev


Same problem for me. Sorry dev. I used /dev/dsp3 before and it worked.. now it seemingly doesn't :-/
EDIT: I'm using nVidia Nforce4 audio (HDA)
OSS 4.0rc1 (build 168/200609130310) (C) 4Front Technologies 1996-2006

**** UNREGISTERED VERSION ****

This OSS version will expire after: Mar 2007
Kernel: FreeBSD 6.1-RELEASE #0: Tue Sep 12 20:48:51 CDT 2006
kash@:/usr/src/sys/i386/compile/GENERIC


Audio devices:
0: nVidia nForce4 High Definition Audio spdifout output
1: nVidia nForce4 High Definition Audio pcm1 output
2: nVidia nForce4 High Definition Audio pcm2 output
3: nVidia nForce4 High Definition Audio pcm3 output
4: nVidia nForce4 High Definition Audio rec input
5: OSS Virtual Mixer v3.0 Playback CH #1 (GRC3)
6: OSS Virtual Mixer v3.0 Playback CH #2 (GRC3)
7: OSS Virtual Mixer v3.0 Playback CH #3 (GRC3)
8: OSS Virtual Mixer v3.0 Playback CH #4 (GRC3)
9: OSS Virtual Mixer v3.0 Playback CH #5 (GRC3)
10: OSS Virtual Mixer v3.0 Playback CH #6 (GRC3)
11: OSS Virtual Mixer v3.0 Playback CH #7 (GRC3)
12: OSS Virtual Mixer v3.0 Playback CH #8 (GRC3)
13: Virtual Mixer Loopback Record CH #1 (GRC3)
14: Virtual Mixer Loopback Record CH #2 (GRC3)
15: Virtual Mixer Loopback Record CH #3 (GRC3)
16: Virtual Mixer Loopback Record CH #4 (GRC3)

MIDI devices:
*** MIDI support not available in this OSS version ***

Mixers:
0: nVidia nForce4 High Definition Audio AD1986A
1: Virtual Mixer

History:
dsp2: pid 21975 cmd 'csh' OUT
dsp0: pid 46252 cmd 'osstest' OUT 1 underruns
dsp1: pid 46252 cmd 'osstest' OUT 1 underruns
dsp2: pid 46252 cmd 'osstest' OUT 1 underruns
dsp3: pid 46252 cmd 'osstest' OUT 1 underruns


NOTICE! This /dev/sndstat file is obsolete - use the ossinfo command instead
kash
 
Posts: 15
Joined: Mon Jul 10, 2006 4:55 am
Location: Far, far away.

Postby kash » Fri Sep 15, 2006 8:56 pm

Reply from dev
Hi,

We have just received our Nvidia Nforce4 with AD1986A HD codec and yes it's silent and we are working on the problem now.


best regards
Dev Mazumdar
kash
 
Posts: 15
Joined: Mon Jul 10, 2006 4:55 am
Location: Far, far away.

Thanks

Postby kash » Fri Sep 15, 2006 8:56 pm

Thanks for working on it, dev. I'm now using RC2 and there's now very faint sound. Volume controls in ossmix don't stay set, though. Best of luck.

EDIT: Using ossxmix, I got volumes up. Then proceeded to scare myself to hell by playing a song with the speaker volume at 100%. ossmix is poop now :/

Finale! J'ai les sons!
kash
 
Posts: 15
Joined: Mon Jul 10, 2006 4:55 am
Location: Far, far away.

Postby dev » Fri Sep 22, 2006 1:10 am

kash wrote:Reply from dev
Hi,

We have just received our Nvidia Nforce4 with AD1986A HD codec and yes it's silent and we are working on the problem now.


best regards
Dev Mazumdar


Hi,


We now have the NForce with AD1986A working just fine - get the latest OSS 4.0rc2-build 172 from www.opensound.com/test


We also have the proper /dev/dsp mapping fixed.


best regards
Dev Mazumdar
dev
 
Posts: 576
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA


Return to BSD

Who is online

Users browsing this forum: No registered users and 5 guests