FreeBSD 6.2, ICH OSS4 - no sound

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: cesium, dev, kodachi, hannu

FreeBSD 6.2, ICH OSS4 - no sound

Postby neoline » Mon Feb 19, 2007 11:13 pm

Hello All there,

I have just installed oss 4 build 999 after I had removed my old 3.99 oss version. Unfortunately the 3.99 version caused my Sony Vaio to crash after it was started from cold. Only after a warm reboot I could use sound. That is why I am tried to use oss 4.

After all that new version does not crash my computer but it produces only some kind of hissing/knocking noise. The osstest detects errors during the test. Could somebody hint me how to configure the oss system or what else could be changed to make sound work?

viggo:~ # osstest
Sound subsystem and version: OSS 4.0rc9 (build 999/200702141654) (0x00040002)
Platform: FreeBSD/i386 6.2-RELEASE FreeBSD 6.2-RELEASE #2: Mon Jan 29 19:15:59 CET 2007 root@viggo.lattka.de:/usr/obj/usr/src/sys/VIGGO

*** Scanning sound adapter #-1 ***
/dev/oss/hdaudio0/pcm0 (audio engine 0): Intel HD Audio play output
- Performing audio playback test...
<left> Device returned error: Input/output error
/dev/oss/hdaudio0/spdout0 (audio engine 1): Intel HD Audio digital-out output
- Performing audio playback test...
<left> Device returned error: Input/output error
/dev/oss/hdaudio0/pcmin0 (audio engine 2): Intel HD Audio rec1 input
- Skipping input only device
/dev/oss/hdaudio0/pcmin1 (audio engine 3): Intel HD Audio rec2 input
- Skipping input only device
/dev/oss/hdaudio0/spdin0 (audio engine 4): Intel HD Audio digital-in input
- Skipping input only device

*** Scanning sound adapter #0 ***
/dev/oss/vmix0/pcm0 (audio engine 5): Intel HD Audio play output (VMIX0)
- Performing audio playback test...
<left> Device returned error: Input/output error
/dev/oss/vmix0/pcm1 (audio engine 6): Intel HD Audio play output (VMIX0)
- Skipping device (card already tested)
/dev/oss/vmix0/pcm2 (audio engine 7): Intel HD Audio play output (VMIX0)
- Skipping device (card already tested)
/dev/oss/vmix0/pcm3 (audio engine 8 ): Intel HD Audio play output (VMIX0)
- Skipping device (card already tested)

*** Some errors were detected during the tests ***
viggo:~ #

viggo:~ # ossinfo
Version info: OSS 4.0rc9 (build 999/200702141654) (0x00040002)
Platform: FreeBSD/i386 6.2-RELEASE FreeBSD 6.2-RELEASE #2: Mon Jan 29 19:15:59 CET 2007 root@viggo.lattka.de:/usr/obj/usr/src/sys/VIGGO

Number of audio devices: 9
Number of audio engines: 9
Number of MIDI devices: 0
Number of mixer devices: 1


Device objects
0: hdaudio0 Intel HD Audio
1: vmix0 OSS transparent virtual support

MIDI devices (/dev/midi*)

Mixer devices (/dev/mixer*)
0: Intel HD Audio 0x14f12bfa (Mixer 0 of device object 0)

Audio devices
/dev/oss/hdaudio0/pcm0: Intel HD Audio play output (device index 0)
/dev/oss/hdaudio0/spdout0: Intel HD Audio digital-out output (device index 1)
/dev/oss/hdaudio0/pcmin0: Intel HD Audio rec1 input (device index 2)
/dev/oss/hdaudio0/pcmin1: Intel HD Audio rec2 input (device index 3)
/dev/oss/hdaudio0/spdin0: Intel HD Audio digital-in input (device index 4)
/dev/oss/vmix0/pcm0: Intel HD Audio play output (VMIX0) (device index 5)
/dev/oss/vmix0/pcm1: Intel HD Audio play output (VMIX0) (device index 6)
/dev/oss/vmix0/pcm2: Intel HD Audio play output (VMIX0) (device index 7)
/dev/oss/vmix0/pcm3: Intel HD Audio play output (VMIX0) (device index 8 )
viggo:~ #

viggo:~ # cat /dev/sndstat
OSS 4.0rc9 (build 999/200702141654) (C) 4Front Technologies 1996-2007

**** UNREGISTERED VERSION ****

This OSS version will expire after: Aug 2007
Kernel: FreeBSD 6.2-RELEASE #2: Mon Jan 29 19:15:59 CET 2007
root@viggo.lattka.de:/usr/obj/usr/src/sys/VIGGO


Audio devices:
0: Intel HD Audio play output (OUTPUT)
1: Intel HD Audio digital-out output (OUTPUT)
2: Intel HD Audio rec1 input (INPUT)
3: Intel HD Audio rec2 input (INPUT)
4: Intel HD Audio digital-in input (INPUT)
5: Intel HD Audio play output (VMIX0) (DUPLEX)
6: Intel HD Audio play output (VMIX0) (DUPLEX)
7: Intel HD Audio play output (VMIX0) (DUPLEX)
8: Intel HD Audio play output (VMIX0) (DUPLEX)

Mixers:
0: Intel HD Audio 0x14f12bfa

History:
/dev/oss/hdaudio0/pcm0.00: pid 21464 cmd 'osstest' OUT 1 timeouts
/dev/oss/hdaudio0/spdout0.01: pid 21464 cmd 'osstest' OUT 1 timeouts
/dev/oss/vmix0/pcm0.05: pid 21464 cmd 'osstest' OUT 1 timeouts


NOTICE! This /dev/sndstat file is obsolete - use the ossinfo command instead
viggo:~ #

viggo:~ # uname -a
FreeBSD viggo.lattka.de 6.2-RELEASE FreeBSD 6.2-RELEASE #2: Mon Jan 29 19:15:59 CET 2007 root@viggo.lattka.de:/usr/obj/usr/src/sys/VIGGO i386
viggo:~ #

from dmesg:
....
hdaudio: Unknown HDA codec 0x14f12bfa
hdaudio: Pin widget 15 is EAPD capable.
hdaudio: Pin widget 16 is EAPD capable.
hdaudio0: <Intel HD Audio> mem 0xb0000000-0xb0003fff irq 16 at device 27.0 on pci0
hdaudio: Output timed out on /dev/oss/hdaudio0/pcm0.
hdaudio: Output timed out on /dev/oss/hdaudio0/pcm0.
hdaudio: Output timed out on /dev/oss/hdaudio0/pcm0.
...
hdaudio: Output timed out on /dev/oss/hdaudio0/pcm0.

Thank you! Regards
neoline
New Member
 
Posts: 4
Joined: Thu Feb 23, 2006 8:56 pm

Postby neoline » Mon Feb 19, 2007 11:18 pm

Just forgot to include the output of pciconf:

from pciconf -lv:

hdaudio0@pci0:27:0: class=0x040300 card=0x81bb104d chip=0x26688086 rev=0x03 hdr=0x00
vendor = 'Intel Corporation'
device = '82801FB/FR/FW/FRW Intel High DefiNition Audio Controller'
class = multimedia

Thank you.
neoline
New Member
 
Posts: 4
Joined: Thu Feb 23, 2006 8:56 pm


Return to BSD

Who is online

Users browsing this forum: Google [Bot] and 1 guest