Freebsd 5.3 Drivers cause Kernel Panic

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: cesium, dev, kodachi, hannu

Postby dev » Sat Nov 13, 2004 7:02 pm

Freedevil wrote:Benjamin unhash the scsci part and take a look at NEWKERNEL.txt it works fine as far as i can tell SCSI was the option that stopped it from panicking wweird yeah tell me about it its a pain to fsck 300gb hard disks :)



Hi,

Do you still want me to work on your kernel problem or do you think you can live with this solution?. Sorry I didn't have the time during the week to work on your kernel issue but now I have a few hours.

If you can just wait for the next update of FreeBSD and see if that fixes anything, I'd appreciate it - we're working on some new functionality for OSS and FreeBSD that will really impress you - support for running ALSA audio apps (via libraries for FreeBSD).


best regards
Dev Mazumdar
dev
Developer
 
Posts: 580
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby Freedevil » Sun Nov 14, 2004 7:34 pm

i am okay with it i have fixed it for the most part so no worries i just pointed it out so others can figure it out too i guess. No problems by the way i ahve spoken to you many times before under the email subzodac@hotmail.com and my name is dev too i dont know if you remember cuz 2 years ago i think :) good luck

Also looking forward to sb live 5.1 support
Freedevil
 

Re: Freebsd 5.3 Drivers cause Kernel Panic

Postby dev » Mon Nov 15, 2004 5:12 pm

Freedevil wrote:OSS 3.99.1i oss3991i-freebsd-x86-v5.3-RELEASE.tar.gz used upon running oss-install it detects the cards fine if you run self audio test machine panics and hangs but i was logged into X at that time.

Upon reboot reinstalled them ran soundon

SBLIVE: CANT ALLOCATE PTA TABLE
fault code = supervisor write, page not present
instruction pointer = 0x8:0xc0340f7f
stack pointer = 0x10:0xd885ee28
frame pointer = 0x10:0xd885ee4c
code segment = base 0x0, limit 0xfffff, type 0x1b
=DPL 0, pres 1, def32 1, gran 1
processor eflags = interrupt enabled, resume, IOPL = 0
current process = 599 (sndconf)
trap number = 12
panic: page fault



Hi,


OK we've now fixed the problem and you can test it out. The problem
was that we had adjusted the memory allocation to always request
memory under 256M since some devices like Envy24 can't use memory
over 256M. This fix was recently introduced and now we've got a
proper solution for both types of devices (ie device that can only
use mem < 256M and regular devices that can use full 32bit addressing)


Please download OSS 3.99.1i version again from our website at
http://www.opensound.com/download.cgi and test it out.


Many thanks for bringing the problem to our attention.


best regards
Dev Mazumdar
dev
Developer
 
Posts: 580
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

poker casino567

Postby poker casino567 » Sat Feb 18, 2006 5:08 pm

poker casino567
 

Previous

Return to BSD

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron