ossxmix

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: hannu, dev, kodachi, cesium

ossxmix

Postby mcrosland » Sat Nov 13, 2004 3:22 pm

'm getting the following problems when running ossxmix

bash-2.05b$ ossxmix

Gtk-CRITICAL **: file gtkcombo.c: line 849 (gtk_combo_set_popdown_strings): assertion `strings != NULL' failed.

Gtk-CRITICAL **: file gtkcombo.c: line 849 (gtk_combo_set_popdown_strings): assertion `strings != NULL' failed.

Gtk-CRITICAL **: file gtkcombo.c: line 849 (gtk_combo_set_popdown_strings): assertion `strings != NULL' failed.

Volume sliders have no apparent effect and the rate, sync and spdif mode dropdowns are incomplete.

I also get a spew of messages at bootup about /dev/mixer0 Operation not permitted

I am running 5.3 release/kde 3.3.1.
mcrosland
 
Posts: 7
Joined: Wed Jun 02, 2004 11:04 am

Re: ossxmix

Postby dev » Sat Nov 13, 2004 6:58 pm

mcrosland wrote:'m getting the following problems when running ossxmix

bash-2.05b$ ossxmix

Gtk-CRITICAL **: file gtkcombo.c: line 849 (gtk_combo_set_popdown_strings): assertion `strings != NULL' failed.

Gtk-CRITICAL **: file gtkcombo.c: line 849 (gtk_combo_set_popdown_strings): assertion `strings != NULL' failed.

Gtk-CRITICAL **: file gtkcombo.c: line 849 (gtk_combo_set_popdown_strings): assertion `strings != NULL' failed.

Volume sliders have no apparent effect and the rate, sync and spdif mode dropdowns are incomplete.

I also get a spew of messages at bootup about /dev/mixer0 Operation not permitted

I am running 5.3 release/kde 3.3.1.



Hi,

We are aware of this problem. It should be fixed up in the next release of OSS.



best regards
Dev Mazumdar
dev
 
Posts: 576
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby mcrosland » Sat Nov 13, 2004 9:17 pm

Thanks fo rthe quick reply :)

Is it possible to give any indication of when the next release is due?
mcrosland
 
Posts: 7
Joined: Wed Jun 02, 2004 11:04 am

Postby dev » Sun Nov 14, 2004 2:38 am

mcrosland wrote:Thanks fo rthe quick reply :)

Is it possible to give any indication of when the next release is due?



Usually 4 weeks apart. In the mean time you can use ossmix to set the
specific settings. You will need to look at the device's README files (under the docs directory for specific settings). Eg SBLive supports
FRONT+REAR, FRONT, REAR, DISCRETE - you can set it as
ossmix spkmode FRONT or ossmix spkmode REAR, etc.


best regards
Dev Mazumdar
dev
 
Posts: 576
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby dev » Mon Nov 15, 2004 11:37 pm

mcrosland wrote:Thanks fo rthe quick reply :)

Is it possible to give any indication of when the next release is due?


Hi,

We have now fixed the problem with ossxmix - please update your OSS 3.99.1i version (run ossupdate or ddownload from our website).



best regards
Dev
dev
 
Posts: 576
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby mcrosland » Tue Nov 16, 2004 7:49 am

That's great, thanks :)

I'm still getting a problem with the driver starting at system startup though. This would appear to be because the path in /etc/rc.local points to /usr/local/bin/soundon, whereas the binaries (and everything else) are installed into /usr/lib/oss/bin . Should I (a) change the path or ((b) move the binaries to /usr/local/bin?
mcrosland
 
Posts: 7
Joined: Wed Jun 02, 2004 11:04 am

Postby Freedevil » Tue Nov 16, 2004 2:18 pm

That's great, thanks Smile

I'm still getting a problem with the driver starting at system startup though. This would appear to be because the path in /etc/rc.local points to /usr/local/bin/soundon, whereas the binaries (and everything else) are installed into /usr/lib/oss/bin . Should I (a) change the path or ((b) move the binaries to /usr/local/bin?


I think you are mistaken /etc/rc.local? i wouldnt it start it that way on freebsd....place start up scripts under /usr/local/etc/rc.d/

The simplest shortest way is to link soundon, soundoff etc to your path for example ln -s /usr/lib/oss* or /usr/local/bin/oss* depending on where you installed oss to /usr/bin/

Create a simple script sound.sh
#!/bin/sh
/usr/bin/soundon

chmod u+x sound.sh and you are good to go.
Freedevil
 

Postby mcrosland » Tue Nov 16, 2004 3:30 pm

I think you are mistaken /etc/rc.local? i wouldnt it start it that way on freebsd....place start up scripts under /usr/local/etc/rc.d/


No, I'm not mistaken, the message I get is as I reported. Also using /usr/local/etc/rc.d for startup scripts is deprecated in fbsd 5.*, which is perhaps why the installation did it that way. All the install paths were determined by the installation and then update procedures, not me.
mcrosland
 
Posts: 7
Joined: Wed Jun 02, 2004 11:04 am

Postby dev » Tue Nov 16, 2004 8:01 pm

mcrosland wrote:
I think you are mistaken /etc/rc.local? i wouldnt it start it that way on freebsd....place start up scripts under /usr/local/etc/rc.d/


No, I'm not mistaken, the message I get is as I reported. Also using /usr/local/etc/rc.d for startup scripts is deprecated in fbsd 5.*, which is perhaps why the installation did it that way. All the install paths were determined by the installation and then update procedures, not me.


Hi,

We've also fixed up the automatic boot setup. THe problem was that the rc.local had /usr/local/bin/soundon and the older OSS 3.9.8 used to put a copy of soundon in /usr/local/bin. We've updated the FreeBSD 3.99.1i version with the proper fix - now if you enable automatic boot setup it will add the proper path to soundon in /etc/rc.local


best regards
Dev Mazumdar
dev
 
Posts: 576
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby Freedevil » Wed Nov 17, 2004 2:27 am

Meh.. /etc/rc.local has been long depreciated for years..

No, I'm not mistaken, the message I get is as I reported. Also using /usr/local/etc/rc.d for startup scripts is deprecated in fbsd 5.*,


I think you are very unclear about Freebsd 5.x. /etc/rc.local is non existant on 5.x by default

Read Handbook
http://www.freebsd.org/doc/en_US.ISO885 ... vices.html

Dont come back and tell me thats for port startup scripts only...

You can place startup scripts in /etc/rc.d too but i would not, its fine if they place it in rc.local, as far as i know its not in use but you can create a rc.pleh and it will run if you get the point.
Freedevil
 

Postby mcrosland » Wed Nov 17, 2004 11:53 am

I think you are very unclear about Freebsd 5.x. /etc/rc.local is non existant on 5.x by default


No, I am not unclear about freebsd 5.*, and yes I have read the 'fine' manual thankyou very much. In fact I also read this page

http://www.freebsd.org/doc/en_US.ISO885 ... -rcng.html

The installation of the incorrect path into rc.local is something the installer did, not me. I was merely reporting the problem. I would also not put anything into rc.local, or even create the file. All I did was run the install instructions.

Dont come back and tell me thats for port startup scripts only...


Why for one moment do you imagine I would :?
mcrosland
 
Posts: 7
Joined: Wed Jun 02, 2004 11:04 am

Postby mcrosland » Wed Nov 17, 2004 12:33 pm

now if you enable automatic boot setup it will add the proper path to soundon in /etc/rc.local


The path is indeed now /usr/local/bin/soundon, but the binary is still in /usr/lib/oss/bin/ and not been copied across, meaning that the automatic boot still doesn't work.
mcrosland
 
Posts: 7
Joined: Wed Jun 02, 2004 11:04 am

Postby Guest » Wed Nov 17, 2004 8:56 pm

The installation of the incorrect path into rc.local is something the installer did, not me. I was merely reporting the problem. I would also not put anything into rc.local, or even create the file. All I did was run the install instructions.


I know i wasnt blaming you...I think there maybe a miscommunication from my first post, cuz i did not speak of the soundconf option to install start up scripts rather a do it yourself method. So no hard feelings enjoy :wink:
Guest
 

poker casino443

Postby poker casino443 » Sat Feb 18, 2006 9:00 pm

poker casino443
 


Return to BSD

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 1 guest

cron