osscore: Output timed out on audio engine

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: hannu, dev, cesium, kodachi

osscore: Output timed out on audio engine

Postby Diego Fernandes » Thu Jan 24, 2008 2:22 am

hello,

I have an Audigy LS, on a FreeBSD 6.3-STABLE box, on XMMS it seems to run fine, but if I use any app that requires libxine, like amarok, i get no sound at all, and this error message:

osscore: Output timed out on audio engine 0/'AudigyLS front' (count=0)

have anyone seen this?
specs:
OSS 4.0 (b1012/200801240205) BSD (C) 4Front Technologies 1996-2007
Kernel: FreeBSD 6.3-STABLE

regards.
Diego Fernandes.
Diego Fernandes
 
Posts: 5
Joined: Fri Sep 14, 2007 5:55 pm

Postby seawright » Thu Jan 24, 2008 2:27 am

Can you use gstreamer instead of xine as Amarok's backend?
I find it gives better results on Linux.
regards
Clive
seawright
 
Posts: 88
Joined: Sat Jan 06, 2007 9:10 pm
Location: Hampshire UK

Postby dev » Thu Jan 24, 2008 7:26 am

try this:

rm /dev/dsp;
ln -s /dev/dsp5 /dev/dsp (link /dev/dsp to one of the vmix devices).

Now see if that works.

On FreeBSD the VMIX isn't automatically opened when you open /dev/dsp



regards
Dev Mazumdar
dev
 
Posts: 577
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby Diego Fernandes » Thu Jan 24, 2008 3:36 pm

seawright,

gstreamer backend seems not work on freebsd anymore, so the amarok port just install the libxine as the default engine; maybe I could try to compile amarok with gstreamer engine by hand...

-----------------------
dev,

Yes, that works, I've already tried it. But when I am using the vmix devices I hear a little interruption in the playback every 5 seconds or so.... I have no idea what it is, no error messages, nothing..


regards.

Diego.
Diego Fernandes
 
Posts: 5
Joined: Fri Sep 14, 2007 5:55 pm


Return to BSD

Who is online

Users browsing this forum: No registered users and 1 guest