Encore ENM232-4CTV ES1373-8

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: cesium, dev, kodachi, hannu

Encore ENM232-4CTV ES1373-8

Postby pimenta » Fri Feb 22, 2008 5:19 pm

Hi,

Got an Encore ENM232-4CTV PCI sound card with ES1373-8 chipset and there is no sound. I have removed previous OSS 4.0 build from FreeBSD 6.3 Release for i386 and I have installed new OSS 4.0 build 1013 but there is no sound and I got he same error messages for osstest:

%osstest
Sound subsystem and version: OSS 4.0 (b1013/200802020510) (0x00040003)
Platform: FreeBSD/i386 6.3-RELEASE FreeBSD 6.3-RELEASE #0: Wed Jan 16 04:18:52 U
TC 2008 root@dessler.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC

*** Scanning sound adapter #-1 ***
/dev/oss/apci970/pcm0 (audio engine 0): Creative AudioPCI97 (ES1371) (rev 8)
- Performing audio playback test...
<left> Device returned error: Input/output error
/dev/oss/apci970/pcm1 (audio engine 1): Creative AudioPCI97 (ES1371) (playback o
nly)
- Performing audio playback test...
<left> Device returned error: Input/output error

*** Scanning sound adapter #0 ***
/dev/oss/vmix0/pcm0 (audio engine 2): Creative AudioPCI97 (ES1371) (rev 8) (VMIX
0)
- Performing audio playback test...
<left> Device returned error: Input/output error
/dev/oss/vmix0/pcm1 (audio engine 3): Creative AudioPCI97 (ES1371) (rev 8) (VMIX
0)
- Skipping device (card already tested)
/dev/oss/vmix0/pcm2 (audio engine 4): Creative AudioPCI97 (ES1371) (rev 8) (VMIX
0)
- Skipping device (card already tested)
/dev/oss/vmix0/pcm3 (audio engine 5): Creative AudioPCI97 (ES1371) (rev 8) (VMIX
0)
- Skipping device (card already tested)
/dev/oss/vmix0/pcm4 (audio engine 6): Creative AudioPCI97 (ES1371) (rev 8) (VMIX
0)
- Skipping device (card already tested)
/dev/oss/vmix0/pcm5 (audio engine 7): Creative AudioPCI97 (ES1371) (rev 8) (VMIX
0)
- Skipping device (card already tested)
/dev/oss/vmix0/pcm6 (audio engine 8): Creative AudioPCI97 (ES1371) (rev 8) (VMIX
0)
- Skipping device (card already tested)
/dev/oss/vmix0/pcm7 (audio engine 9): Creative AudioPCI97 (ES1371) (rev 8) (VMIX
0)
- Skipping device (card already tested)

*** Some errors were detected during the tests ***

Also I can not get this sound card to work with FreeBSD modules. I know there is a driver for ES1373-8 but I got error messages for AC97 codec reset time out and dmesg display timeout errors:

%dmesg | grep ES137
apci970: <Creative AudioPCI97 (ES1371)> port 0xb800-0xb83f irq 9 at device 9.0 on pci0
osscore: Output timed out on audio engine 0/'Creative AudioPCI97 (ES1371) (rev 8)' (count=0)
osscore: Output timed out on audio engine 1/'Creative AudioPCI97 (ES1371) (playback only)' (count=0)
osscore: Output timed out on audio engine 2/'Creative AudioPCI97 (ES1371) (rev 8) (VMIX0)' (count=0)
apci970: <Creative AudioPCI97 (ES1371)> port 0xb800-0xb83f irq 9 at device 9.0 on pci0
osscore: Output timed out on audio engine 0/'Creative AudioPCI97 (ES1371) (rev 8)' (count=0)
osscore: Output timed out on audio engine 1/'Creative AudioPCI97 (ES1371) (playback only)' (count=0)
osscore: Output timed out on audio engine 2/'Creative AudioPCI97 (ES1371) (rev 8) (VMIX0)' (count=0)
osscore: Output timed out on audio engine 0/'Creative AudioPCI97 (ES1371) (rev 8)' (count=0)
osscore: Output timed out on audio engine 1/'Creative AudioPCI97 (ES1371) (playback only)' (count=0)
osscore: Output timed out on audio engine 2/'Creative AudioPCI97 (ES1371) (rev 8) (VMIX0)' (count=0)
osscore: Output timed out on audio engine 0/'Creative AudioPCI97 (ES1371) (rev 8)' (count=0)
osscore: Output timed out on audio engine 1/'Creative AudioPCI97 (ES1371) (playback only)' (count=0)
osscore: Output timed out on audio engine 2/'Creative AudioPCI97 (ES1371) (rev 8) (VMIX0)' (count=0)
%

I have tested that sound card with BeOS R5.0.3 and Zeta 1.2 and thought both OS detect and list the card there is no sound. I have not tested with Windows and the manufacturer drivers.

I know there used to be a problem like that for Creative Labs PCI 128 ES1373-B sound cards with different ID and I wonder if this is not the same case: a known chipset, the right driver, one mutant sound card the driver can't control.

Is there any other operation (besides installation)I should try? Does anyone have a (working or not) sound card like that or a sound card with ES1373-8 chipset? What did you make for that card to work?

Thanks,

Luiz.
pimenta
New Member
 
Posts: 1
Joined: Fri Feb 22, 2008 1:44 pm
Location: Brazil

Return to BSD

Who is online

Users browsing this forum: No registered users and 1 guest