Oss say that there is a problem, but I sound work fine.

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: hannu, dev, cesium, kodachi

Oss say that there is a problem, but I sound work fine.

Postby Willits » Thu Jul 14, 2005 2:05 pm

When I load OSS under FreeBSD 5.4, He say that there are an error, and I need to see the log file for more information. (There is a problem is MPU401)

This is my log file:

Starting OSS/FreeBSD 3.99.3a Thu Jul 14 15:29:54 CEST 2005
3:29PM up 6 secs, 0 users, load averages: 1.52, 0.32, 0.11
======= config =====
# Use soundconf to edit this file.
/SECUREAUDIO OFF
/PCIIRQ 1
/IRQEXCLUDE 3 4
/DMAEXCLUDE 2
-PCI24c58086 #Intel ICH4
UART401 ON P310 I9
INTELPCI ON
-softmix #4Front Tech. Virtual Mixer Pro
/CONTROL SOFTSYN parm1=6
SOFTMIX ON
====== pnpres.dat ========
====================
Warning: Some of the devices failed to initialize
OSS/FreeBSD 3.99.3a (C) 4Front Technologies 1996-2004

License serial number: E00000008
**** UNREGISTERED VERSION ****

Drivers: ALL
License will expire after: 08/2005


*** Unregistered version ***

Build: 200507081225
Kernel: FreeBSD 5.4-RELEASE #0: Sun May 8 10:21:06 UTC 2005
root@harlow.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC


Card config:
(MPU-401 (UART) at 0x310 irq 9)
Intel ICH AC97 audio controller at 0xc400 irq 17
OSS Virtual Mixer Pro

Audio devices:
0: Intel ICH4 (24C5) (DUPLEX)
1: Intel ICH4 (24C5) (shadow) (DUPLEX)
2: OSS Virtual Mixer v2.5 Playback CH #0 (GRC3)
3: OSS Virtual Mixer v2.5 Playback CH #1 (GRC3)
4: OSS Virtual Mixer v2.5 Playback CH #2 (GRC3)
5: OSS Virtual Mixer v2.5 Playback CH #3 (GRC3)
6: OSS Virtual Mixer v2.5 Playback CH #4 (GRC3)
7: OSS Virtual Mixer v2.5 Playback CH #5 (GRC3)
8: OSS Virtual Mixer v2.5 Playback CH #6 (GRC3)
9: OSS Virtual Mixer v2.5 Playback CH #7 (GRC3)

Synth devices:
0: OSS Virtual Synth v2.5

Midi devices:

Mixers:
0: AC97 Mixer (ALC650)
1: Virtual Mixer
========== dmesg printout follows ========
Copyright (c) 1992-2005 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD 5.4-RELEASE #0: Sun May 8 10:21:06 UTC 2005
root@harlow.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC
ACPI APIC Table: <IntelR AWRDACPI>
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Pentium(R) 4 CPU 2.40GHz (2402.93-MHz 686-class CPU)
Origin = "GenuineIntel" Id = 0xf27 Stepping = 7
Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
real memory = 536805376 (511 MB)
avail memory = 515633152 (491 MB)
ioapic0 <Version 2.0> irqs 0-23 on motherboard
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <IntelR AWRDACPI> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <Intel 82845G host to AGP bridge> mem 0xd0000000-0xd7ffffff at device 0.0 on pci0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
pci1: <display> at device 0.1 (no driver attached)
uhci0: <Intel 82801DB (ICH4) USB controller USB-A> port 0xb800-0xb81f irq 16 at device 29.0 on pci0
usb0: <Intel 82801DB (ICH4) USB controller USB-A> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <Intel 82801DB (ICH4) USB controller USB-B> port 0xb000-0xb01f irq 19 at device 29.1 on pci0
usb1: <Intel 82801DB (ICH4) USB controller USB-B> on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: <Intel 82801DB (ICH4) USB controller USB-C> port 0xb400-0xb41f irq 18 at device 29.2 on pci0
usb2: <Intel 82801DB (ICH4) USB controller USB-C> on uhci2
usb2: USB revision 1.0
uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
pci0: <serial bus, USB> at device 29.7 (no driver attached)
pcib2: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci2: <ACPI PCI bus> on pcib2
rl0: <RealTek 8139 10/100BaseTX> port 0xa000-0xa0ff mem 0xeb000000-0xeb0000ff irq 19 at device 0.0 on pci2
miibus0: <MII bus> on rl0
rlphy0: <RealTek internal media interface> on miibus0
rlphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
rl0: Ethernet address: 00:50:8d:4a:62:33
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH4 UDMA100 controller> port 0xf000-0xf00f,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at device 31.1 on pci0
ata0: channel #0 on atapci0
ata1: channel #1 on atapci0
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
pci0: <multimedia, audio> at device 31.5 (no driver attached)
acpi_tz0: <Thermal Zone> on acpi0
fdc0: <floppy drive controller> port 0x3f7,0x3f0-0x3f5 irq 6 drq 2 on acpi0
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
sio1: <16550A-compatible COM port> port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
ppc0: <Standard parallel printer port> port 0x778-0x77b,0x378-0x37f irq 7 on acpi0
ppc0: Generic chipset (NIBBLE-only) in COMPATIBLE mode
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse, device ID 3
orm0: <ISA Option ROM> at iomem 0xc0000-0xccfff on isa0
pmtimer0 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 2402932104 Hz quality 800
Timecounters tick every 10.000 msec
ad0: 38172MB <MAXTOR 6L040J2/A93.0500> [77557/16/63] at ata0-master UDMA100
ad1: 38172MB <MAXTOR 6L040J2/A93.0500> [77557/16/63] at ata0-slave UDMA100
acd0: DVDROM <Pioneer DVD-ROM ATAPIModel DVD-114 0206/E2.06F> at ata1-master PIO4
acd1: CDRW <Hewlett-Packard CD-Writer Plus 8200/1.0f> at ata1-slave PIO4
Mounting root from ufs:/dev/ad0s1a
oss: Probing the hardware for MPU-401 (UART) failed.


Willits[/code]
Willits
Member
 
Posts: 13
Joined: Wed Feb 16, 2005 2:27 pm

Postby BSDKaffee » Tue Jul 19, 2005 9:08 pm

You probably have hardware incapable of MIDI support. I get the same error and my hardware does not support MIDI. You can disable the probe in soundconf. Go to "Manual Configuration" (I believe that's what that menu item is called) and disable the UART probe.
User avatar
BSDKaffee
Member
 
Posts: 28
Joined: Tue Jul 19, 2005 7:17 pm


Return to BSD

Who is online

Users browsing this forum: No registered users and 1 guest