sdl_mixer: couldn't set audio blocking mode

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: cesium, dev, kodachi, hannu

sdl_mixer: couldn't set audio blocking mode

Postby LoRd_CJ » Sun Nov 20, 2005 9:32 am

I have a problem with every program I've tried that uses SDL_mixer. Sound doesn't work and the error message couldn't set audio blocking mode can be seen alongside sdl_mixer being initialized.

My system is FreeBSD 6.0, latest OSS drivers and I have a Sound Blaster Audigy2 Value.
LoRd_CJ
New Member
 
Posts: 3
Joined: Sun Feb 22, 2004 7:31 pm

Re: sdl_mixer: couldn't set audio blocking mode

Postby dev » Mon Nov 21, 2005 3:59 am

LoRd_CJ wrote:I have a problem with every program I've tried that uses SDL_mixer. Sound doesn't work and the error message couldn't set audio blocking mode can be seen alongside sdl_mixer being initialized.

My system is FreeBSD 6.0, latest OSS drivers and I have a Sound Blaster Audigy2 Value.



Try setting:

SDL_DSP_NOSELECT=1

Then fireup the app in the terminal window.


regards
Dev Mazumdar
dev
Developer
 
Posts: 577
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby Guest » Tue Nov 22, 2005 3:47 pm

Yes tried it, that didn't help.
Guest
 

Postby dev » Tue Nov 22, 2005 8:57 pm

Anonymous wrote:Yes tried it, that didn't help.


Then you must download the SDL libraries and recompile them.

Tell us how to reporduce your problem?


Are you running a Linux binary game by anychance?. Note that mmap() in Linux is very different from mmap() in BSD so that may not work correctly.



best regards
Dev Mazumdar
dev
Developer
 
Posts: 577
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA


Return to BSD

Who is online

Users browsing this forum: Majestic-12 [Bot] and 1 guest

cron