Freebsd Fails to see /dev/mixer on 5.2.1

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: cesium, dev, kodachi, hannu

Freebsd Fails to see /dev/mixer on 5.2.1

Postby Guest » Tue Apr 27, 2004 5:44 pm

Hey all.

Before I purchase this product, I would like to be able to test it. However, I cannot seem to get it to run under 5.2.1-RELEASE. I get passed all of the screens up until the time of writting the configs and such. The error is:

mknod: /dev/mixer0: No such file or directory


So, you know the rest is going to fail. Is there something I should be running or what? Here is a kldstat output to make sure I am not running something I shouldn't. There aren't any sound drivers compiled into the kernel. This is straight up Generic.

Id Refs Address Size Name
1 8 0xc0100000 5f15b4 kernel
2 1 0xc06f2000 4a30c acpi.ko
3 2 0xc67be000 18000 linux.ko
4 1 0xc6852000 186000 nvidia.ko


Any help would be greatly appreciated.
Guest
 

Whoops

Postby Guest » Tue Apr 27, 2004 5:52 pm

Oh yea. I am using:

oss398e-freebsd-v5.2.1-RELEASE.tar.gz
Guest
 

RE: Freebsd Fails to see /dev/mixer on 5.2.1

Postby nunotex » Sat May 15, 2004 5:54 pm

Hi,

You don't have oss kernel moduled installed! Because of this the divice drivers are not cereated like mixer.

Make sure that you have configured correctly your sound card with sound card and the run soundon to load oss kernel module.

Nuno Teixeira
nunotex
New Member
 
Posts: 5
Joined: Sat May 15, 2004 5:28 pm


Return to BSD

Who is online

Users browsing this forum: Bing [Bot] and 1 guest