OSS driver for solaris x86 64 bit?

OSS specific Solaris discussion (x86/SPARC)

Moderators: cesium, dev, kodachi, hannu

OSS driver for solaris x86 64 bit?

Postby Ron » Sat Jan 22, 2005 5:27 pm

There appears to be an OSS driver for my laptop audio (via 8233) but only in 32 bit mode.

Do you know when 64 bit support will be available?

Thanks,
-ron

# uname -a
SunOS unknown 5.10 s10_74l1 i86pc i386 i86pc

# isainfo -v
64-bit amd64 applications
sse2 sse fxsr amd_3dnowx amd_3dnow amd_mmx mmx cmov amd_sysc cx8 tsc
fpu
32-bit i386 applications
sse2 sse fxsr amd_3dnowx amd_3dnow amd_mmx mmx cmov amd_sysc cx8 tsc
fpu

# ./soundon
No 64-bit version of (oss) found; 32-bit version of this driver exists.
32-bit driver (oss) not loadable on 64-bit kernel.
System configuration files modified but oss driver not loaded or attached.
Failed to load the OSS driver module.
Ron
 

Re: OSS driver for solaris x86 64 bit?

Postby dev » Sat Jan 22, 2005 6:31 pm

Ron wrote:There appears to be an OSS driver for my laptop audio (via 8233) but only in 32 bit mode.

Do you know when 64 bit support will be available?

Thanks,
-ron

# uname -a
SunOS unknown 5.10 s10_74l1 i86pc i386 i86pc

# isainfo -v
64-bit amd64 applications
sse2 sse fxsr amd_3dnowx amd_3dnow amd_mmx mmx cmov amd_sysc cx8 tsc
fpu
32-bit i386 applications
sse2 sse fxsr amd_3dnowx amd_3dnow amd_mmx mmx cmov amd_sysc cx8 tsc
fpu

# ./soundon
No 64-bit version of (oss) found; 32-bit version of this driver exists.
32-bit driver (oss) not loadable on 64-bit kernel.
System configuration files modified but oss driver not loaded or attached.
Failed to load the OSS driver module.



Hi,


We're working on 64bit drivers for AMD64 - right now there's a strange crash in OSS - the same code works perfectly on x86 in 32bit and on Sparc in 64bit mode so we're trying to see if it's an OSS problem or a kernel problem. Stay tuned.....


best regards
Dev Mazumdar
dev
Developer
 
Posts: 577
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby Guest » Fri Feb 11, 2005 3:42 am

Any progress on this issue?

Thanks!
Guest
 

Postby marigan » Fri Feb 11, 2005 10:48 pm

yes :-) are there any progress ?? i have a same problem..
marigan
 

Postby Guest » Tue Feb 22, 2005 8:41 pm

They seem to have posted one recently. Going to try it out now, I'll reply with feedback on it.
Guest
 

Postby Guest » Tue Feb 22, 2005 10:24 pm

Work great so far, I don't have any games or anything, but XMMS and GNOME work...that's good enough for me.
Guest
 

Postby Chrystophe Vergnaud » Thu Feb 23, 2006 11:19 am

I have installed the package driver for solaris on an ultra20 (64bit),
everything goes fine, oss recoder and player works.

But I have made a sys-unconfig, big mistake :
when i boot : the kernel told me that i have errors in driver_classes and driver_aliases and the system reboot after displaying those lines.

I can't remove the drivers in a failsafe session :
Code: Select all
$ pkgrm oss
pkgrm: ERROR: can t open admin file <default> : no such file


...hum... any idea to get a clean boot ?

thanks in advance
Chrystophe Vergnaud
New Member
 
Posts: 4
Joined: Thu Feb 23, 2006 11:01 am

Postby dev » Thu Feb 23, 2006 8:11 pm

Chrystophe Vergnaud wrote:I have installed the package driver for solaris on an ultra20 (64bit),
everything goes fine, oss recoder and player works.

But I have made a sys-unconfig, big mistake :
when i boot : the kernel told me that i have errors in driver_classes and driver_aliases and the system reboot after displaying those lines.

I can't remove the drivers in a failsafe session :
Code: Select all
$ pkgrm oss
pkgrm: ERROR: can t open admin file <default> : no such file


...hum... any idea to get a clean boot ?

thanks in advance


You can run ossdetect and redetect the drivers. Then run soundon


regards
Dev Mazumdar
dev
Developer
 
Posts: 577
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA

Postby bnsmb » Sat Feb 25, 2006 3:19 pm

Chrystophe Vergnaud wrote:I have installed the package driver for solaris on an ultra20 (64bit),
everything goes fine, oss recoder and player works.

But I have made a sys-unconfig, big mistake :
when i boot : the kernel told me that i have errors in driver_classes and driver_aliases and the system reboot after displaying those lines.

I can't remove the drivers in a failsafe session :
Code: Select all
$ pkgrm oss
pkgrm: ERROR: can t open admin file <default> : no such file


...hum... any idea to get a clean boot ?

thanks in advance


To remove a package in failsafe session do:

# mount your boot disk to /a (and /var to /a/var, /usr to /a/usr, etc. if they are on other slices); example:

mount /dev/dsk/c1t0d0s0 /a
mount /dev/dsk/c1t0d0s0 /var

Then do a

pkgrm -R /a oss

regards

Bernd
bnsmb
Member
 
Posts: 12
Joined: Thu Feb 09, 2006 7:08 am

Postby Chrystophe Vergnaud » Tue Mar 07, 2006 2:18 pm

thx for your answers.
it works fine ;)
Chrystophe Vergnaud
New Member
 
Posts: 4
Joined: Thu Feb 23, 2006 11:01 am

OSS can't attach hdaudio

Postby donkanmcleod » Thu Jan 25, 2007 2:00 pm

hi guys,

i hava an acer aspire 5102 with realtek audio card, actually i have installed the 11/06 solaris for amdx64. So, OSS do not work, it says some like "can't attach hdaudio .... "

is there anyone who knows how to make it work?

thanks in advice
Donkan
donkanmcleod
 


Return to Solaris

Who is online

Users browsing this forum: No registered users and 1 guest

cron