I want to use sound as routine!

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: cesium, dev, kodachi, hannu

I want to use sound as routine!

Postby Slesarev » Tue Dec 30, 2008 10:01 pm

I`ve installed OSS from FreeBSD ports, enabeled boot-loading, and now I have several troubles:

1) OSS finds 18 channels on my high definition audio soundcard, including rear, left, right, etc. channels - while I have a laptop with 3 audio slots. Anyway, other channels are failing and ignored. I think, it`s rather strange

2) Gstreamer does not find the sound device, so no system sounds are played, and most of software don`t have sound.

3) the software that does not use Gstreamer to find sound also does not have sound - except XMMS, but, anyway, the sound is very silent.

4) The microphone does not work.

Plesae, help me install sound driver that will not remind me of its existance every minute!
Veritas seu nihil
Slesarev
New Member
 
Posts: 1
Joined: Tue Dec 30, 2008 9:49 pm
Location: Russia

Postby cesium » Wed Dec 31, 2008 12:24 am

GStreamer: The gstreamer-plugins-bad port should make it work since it contains an oss4 plugin.

Mic: try do this: "ossrecord -imic - | ossplay -" in the background and "ossxmix" in the foreground. Change settings in ossxmix until you get echo sound.
cesium
Developer
 
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am


Return to BSD

Who is online

Users browsing this forum: Bing [Bot] and 1 guest