Experiment with Gnome Volume Control on Ubuntu 9.10

OSS specific Linux discussion (x86/amd64)

Moderators: hannu, dev, cesium, kodachi

Experiment with Gnome Volume Control on Ubuntu 9.10

Postby igorzwx » Mon Oct 26, 2009 6:05 pm

Disclaimer: This is just an experiment. I am not responsible for the consequences.

PulseAudio is already removed, and OSS4 is installed.

Step 1: Remove "gnome-media" from Ubuntu 9.10

sudo apt-get remove gnome-media

Step 2: Borrow "gnome-volume-control" from Ubuntu 9.04 Repositories

Download the package "gnome-media" for Ubuntu 9.04
http://packages.ubuntu.com/jaunty/gnome-media

Open it with Archive Manager and extract this file:

gnome-volume-control

Step 3: Borrow "gstreamer-properties" and some other apps from Ubuntu 9.10 Repositories

Download the package "gnome-media" for Ubuntu 9.10
http://packages.ubuntu.com/karmic/gnome-media

Open it with Archive Manager and extract these files:

gnome-audio-profiles-properties
gstreamer-properties
gnome-sound-recorder

Step 4: Install the applications:

sudo cp gnome-volume-control /usr/bin/

sudo cp gnome-audio-profiles-properties /usr/bin/

sudo cp gstreamer-properties /usr/bin/

sudo cp gnome-sound-recorder /usr/bin/


Everything seems to work, except for "gnome-sound-recorder" (it does not work with OSS4 on my Ubuntu 9.04 too).
It should be tested more carefully.

**********************************************************************************************************
Alternatively, you can copy some files before the removal of "gnome-media"

cp /usr/bin/gnome-audio-profiles-properties ~/Desktop
cp /usr/bin/gstreamer-properties ~/Desktop
cp /usr/bin/gnome-sound-recorder ~/Desktop

In this case, you do not need to download the package "gnome-media" for Ubuntu 9.10

**********************************************************************************************************
gconf-editor can be activated in Menu: Application-> System Tools

Icon for Gnome Volume Control:
/usr/share/icons/hicolor/48x48/apps/gnome-volume-control.png

Icon for sound-recorder:
/usr/share/icons/hicolor/48x48/apps/gnome-sound-recorder.png

Name: Sound Recorder
command: gnome-sound-recorder
Comment: Record sound clips

other icons:
/usr/share/icons/hicolor/48x48/apps/gstreamer-properties.png
/usr/share/icons/hicolor/48x48/apps/gconf-editor.png
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: Experiment with Gnome Volume Control on Ubuntu 9.10

Postby igorzwx » Wed Oct 28, 2009 10:09 pm

Experiment 2: RECOMPILATION of the package "gnome-media"

Disclaimer: This is just an experiment. I am not responsible for the consequences.

PulseAudio is already removed, and OSS4 is installed.


Step 1: Remove "gnome-media" from Ubuntu 9.10

sudo apt-get remove gnome-media


Step 2: Get the source archive of "gnome-media" (and unpack it)

Download the source archive of "gnome-media"
http://packages.ubuntu.com/source/karmic/gnome-media

Read list of dependencies on this site.


Step 3: Install tools, dependencies, etc.

sudo apt-get update

sudo apt-get install build-essential checkinstall

sudo apt-get install intltool libgstreamer0.10-dev libgconf2-dev libglade2-dev libgstreamer-plugins-base0.10-dev


Step 4: Read the help file (if you want)

./configure --help


Step 5: Configure the package without PulseAudio:

./configure --disable-pulseaudio --enable-gstmix --enable-gstprops --enable-profiles --enable-grecord


-------------------------------------------------------------------------------------------------------------------------
RESULTS of Configure

gnome-media 2.28.1
============


Prefix: /usr/local
Source code location: .
Compiler: gcc
CFLAGS: -g -O2

Volume Control no [ this is a kind of evil, PulseAudio applet which burns CPU ]

GStreamer properties: yes
GStreamer profiles: yes
Sound recorder: yes

*Deprecated*:

GStreamer mixer: yes
-------------------------------------------------------------------------------------------------------------------------


Step 6: Make the deb-package

make

sudo checkinstall -D --install=no --pkgname=gnome-media-nopulse --maintainer="john.frum@cargo-cult.org.ua"


( Description: gnome-media-nopulse recompiled )


**********************************************************************

Done. The new package has been saved to

~/hack5/gnome-media-2.28.1/gnome-media-nopulse_2.28.1-1_i386.deb
You can install it in your system anytime using:

dpkg -i gnome-media-nopulse_2.28.1-1_i386.deb

**********************************************************************


Step 7: Install the deb-package

sudo dpkg -i gnome-media-nopulse_2.28.1-1_i386.deb


**************************************************************

As a result, these apps have been installed:

gnome-volume-control
gstreamer-properties
gnome-audio-profiles-properties
gnome-sound-recorder

You can run them from Terminal, or create launchers.
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: Experiment with Gnome Volume Control on Ubuntu 9.10

Postby Temüjin » Wed Oct 28, 2009 10:52 pm

I'll have to try this soon. Looks promising. THANKS!
Temüjin
 
Posts: 84
Joined: Tue Jul 24, 2007 7:55 pm
Location: Pennsylvania, USA

Re: Experiment with Gnome Volume Control on Ubuntu 9.10

Postby igorzwx » Wed Oct 28, 2009 10:59 pm

The next step might be to recompile gnome-applets,
using the configure option --enable-mixer-applet
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: Experiment with Gnome Volume Control on Ubuntu 9.10

Postby igorzwx » Thu Oct 29, 2009 8:13 pm

Building the GNOME Desktop from Source
July 2009 (#164) > Article
http://linuxgazette.net/164/laycock.html
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: Experiment with Gnome Volume Control on Ubuntu 9.10

Postby igorzwx » Fri Oct 30, 2009 7:57 pm

Got it working: "gnome-volume-control-applet" and "gnome-volume-control"

Now it looks like before. And it works with OSS4 without PulseAudio on Ubuntu 9.10

Recompiled "gnome-applets" and "gnome-media" packages following this guide:
http://linuxinnovations.blogspot.com/20 ... -with.html

First of all, get all dependencies for both packages:

sudo apt-get build-dep gnome-applets

sudo apt-get build-dep gnome-media

Then recompile them one after another.

-----------------------------------------------------------------------------------------------------------------------------------------------

... /gnome-applets-2.28.0/debian/rules

gedit ./debian/rules

DEB_CONFIGURE_EXTRA_FLAGS += --disable-gtk-doc --disable-scrollkeeper --enable-ipv6 --disable-battstat --enable-mixer-applet --enable-networkmanager --enable-mini-commander

-----------------------------------------------------------------------------------------------------------------------------------------------

... /gnome-media-2.28.1/debian/rules

gedit ./debian/rules

DEB_CONFIGURE_EXTRA_FLAGS += --disable-scrollkeeper --enable-gstmix --enable-gstprops --enable-profiles --enable-grecord

-----------------------------------------------------------------------------------------------------------------------------------------------

Do not forget to edit "depends" before recompilation.

gedit ./debian/control
gedit ./debian/control.in
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: Experiment with Gnome Volume Control on Ubuntu 9.10

Postby cesium » Fri Oct 30, 2009 8:34 pm

Is recompiling all these packages really necessary?
It looks like the main difference is "--enable-gstmix" while rebuilding gnome-media, so maybe only that alone needs to be rebuilt. Or am I missing something?
cesium
 
Posts: 903
Joined: Sun Aug 12, 2007 12:51 am

Re: Experiment with Gnome Volume Control on Ubuntu 9.10

Postby igorzwx » Fri Oct 30, 2009 8:40 pm

Hi Cesium!

I am absolutely stupid now after all these experiments.
You have to rebuild them both, and do not disable pulseaudio (EDIT: it can be disabled, but you have to edit the install script for "gnome-media", I did this already 2009.11.01).
Edit depends. Ans so on.
We may better discuss this tomorrow.

Best,
Igor

----------------------------------------------------------------------------------------------------------
"Though, even that could be addressed building a gnome-mixer-applet package from gnome-applets source, using the configure option --enable-mixer-applet (building a new package permit to not modify the current gnome-applets, built with pulseaudio support in mind); so one gets the old mixer applet too (but I still haven't tried it)."
https://bugs.launchpad.net/ubuntu/+sour ... bug/440465
Last edited by igorzwx on Sun Nov 01, 2009 4:43 am, edited 1 time in total.
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: Experiment with Gnome Volume Control on Ubuntu 9.10

Postby igorzwx » Fri Oct 30, 2009 9:36 pm

If you want to have mixer-applet, you have to enable it in "gnome-applets", and therefore, to rebuild that package too.
Attachments

[The extension png has been deactivated and can no longer be displayed.]

igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: Experiment with Gnome Volume Control on Ubuntu 9.10

Postby igorzwx » Fri Oct 30, 2009 10:24 pm

Hi Cesium!

That PulseAudio applet, "gnome-volume-control-applet" was installed to /usr/bin

/usr/bin/gnome-volume-control-applet

I removed it manually and rebooted.

Everything works as before.
Because it is working that "mixer-applet" which was enabled in the package "gnome-applets".

CONCLUSION: You have to recompile the package "gnome-applets", if you want to have Gnome "mixer-applet" after the removal of PulseAudio.

-------------------------------------------------------------------------------------------------------
Do not forget to disable that evil, PulseAudio's "gnome-volume-control-applet",
in System -> Preferences -> Startup Applications -> Volume Control
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: Experiment with Gnome Volume Control on Ubuntu 9.10

Postby igorzwx » Sat Oct 31, 2009 4:33 pm

The solution needs to be improved.

1. It might be possible to prevent PulseAudio's applet, "gnome-volume-control-applet", from installation to /usr/bin

2. The packages are to be renamed in some way, because they are not immune to upgrade.

Just made:
sudo apt-get update
sudo apt-get upgrade
sudo reboot

and the pulse things were back. Everything was fixed by re-installation of the re-compiled packages.

I have some ideas. Some more experiments.
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: Experiment with Gnome Volume Control on Ubuntu 9.10

Postby cesium » Sat Oct 31, 2009 5:09 pm

Well, you can "hold" the packages to prevent upgrade (e.g. "echo gnome-media hold | dpkg --set-selections").. But all upgrades will have be done by source recompilation...

A pity one can't use the debian packages here - there's no linking to Pulse, and --enable-gstmix is passed to gnome-media.
cesium
 
Posts: 903
Joined: Sun Aug 12, 2007 12:51 am

Re: Experiment with Gnome Volume Control on Ubuntu 9.10

Postby igorzwx » Sat Oct 31, 2009 5:39 pm

Why not rename the packages?

I am going to edit some files in the packages and recompile them once more.
The result should be

gnome-media-nopulse
gnome-applets-nopulse
and so on.

The users may simply install such packages and all problems will be fixed automatically.
igorzwx
 
Posts: 966
Joined: Sun Jun 28, 2009 9:31 pm

Re: Experiment with Gnome Volume Control on Ubuntu 9.10

Postby cesium » Sun Nov 01, 2009 1:28 am

Wouldn't renaming break packages which depend on the renamed packages?
cesium
 
Posts: 903
Joined: Sun Aug 12, 2007 12:51 am

Re: Experiment with Gnome Volume Control on Ubuntu 9.10

Postby Temüjin » Sun Nov 01, 2009 3:11 am

cesium wrote:Wouldn't renaming break packages which depend on the renamed packages?


That's why there's a specific method to naming Ubuntu packages. https://help.launchpad.net/Packaging/PP ... versioning
Temüjin
 
Posts: 84
Joined: Tue Jul 24, 2007 7:55 pm
Location: Pennsylvania, USA

Next

Return to Linux

Who is online

Users browsing this forum: Bing [Bot] and 4 guests