Need Help about Sound blaster audigy value on FreeBSD

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: hannu, dev, cesium, kodachi

Need Help about Sound blaster audigy value on FreeBSD

Postby pratchaya » Fri Mar 12, 2010 4:05 pm

Everything seem to be perfect but no sound.
I found like this,
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
# cat /dev/sndstat
FreeBSD Audio Driver (newpcm: 64bit 2009061500/amd64)
Installed devices:
#
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

I got no sound on my system.
Would u like to help/suggest me ?

Thank you very much for advance
Pratchaya




And Others =
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
# ossinfo -v
Version info: OSS 4.2 (b 2002/201003021144) (0x00040100) BSD
Platform: FreeBSD/amd64 8.0-RELEASE FreeBSD 8.0-RELEASE #0: Wed Mar 10 15:54:15 ICT 2010 note@berlin.bug.in.th:/usr/src/sys/amd64/compile/BERLIN (berlin.bug.in.th)

Number of audio devices: 4
Number of audio engines: 8
Number of MIDI devices: 0
Number of mixer devices: 1


Device objects
0: oss_audigyls0 AudigyLS interrupts=396 (396)

MIDI devices (/dev/midi*)

Mixer devices
0: AudigyLS Mixer (Mixer 0 of device object 0)
Device file /dev/oss/oss_audigyls0/mix0, Legacy device /dev/mixer0
Priority: 1
Caps:

Audio devices
AudigyLS front /dev/oss/oss_audigyls0/pcm0 (device index 0)
Legacy device /dev/dsp0
Caps: DUPLEX TRIGGER MMAP
Modes: IN/OUT
Engine 1: Available for use
Engine 2: Available for use
Engine 3: Available for use
Engine 4: Available for use
Engine 5: Available for use
AudigyLS center/lfe /dev/oss/oss_audigyls0/pcm1 (device index 1)
Legacy device /dev/dsp1
Caps: TRIGGER MMAP
Modes: OUTPUT
Out engine 1: Available for use
AudigyLS surround /dev/oss/oss_audigyls0/pcm2 (device index 2)
Legacy device /dev/dsp2
Caps: TRIGGER MMAP
Modes: OUTPUT
Out engine 1: Available for use
AudigyLS 5.1 output /dev/oss/oss_audigyls0/pcm3 (device index 3)
Legacy device /dev/dsp3
Caps: TRIGGER MMAP
Modes: OUTPUT
Out engine 1: Available for use

Nodes
/dev/dsp -> /dev/oss/oss_audigyls0/pcm0
/dev/dsp_in -> /dev/oss/oss_audigyls0/pcm0
/dev/dsp_out -> /dev/oss/oss_audigyls0/pcm0
/dev/dsp_ac3 -> /dev/oss/oss_audigyls0/pcm0
/dev/dsp_mmap -> /dev/oss/oss_audigyls0/pcm0
/dev/dsp_multich -> /dev/oss/oss_audigyls0/pcm3
#

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
# ossdetect -v
Detected Sound Blaster Audigy LS / Live7.1
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
# uname -a
FreeBSD berlin.bug.in.th 8.0-RELEASE FreeBSD 8.0-RELEASE #0: Wed Mar 10 15:54:15 ICT 2010 note@berlin.bug.in.th:/usr/src/sys/amd64/compile/BERLIN amd64
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
# pciconf -lv
hostb0@pci0:0:0:0: class=0x060000 card=0x01e61028 chip=0x27788086 rev=0x00 hdr=0x00
vendor = 'Intel Corporation'
device = 'E7230/3000/3010 Processor to I/O Controller'
class = bridge
subclass = HOST-PCI
pcib1@pci0:0:1:0: class=0x060400 card=0x01e61028 chip=0x27798086 rev=0x00 hdr=0x01
vendor = 'Intel Corporation'
device = 'E7230/3000/3010 PCIe Root Port'
class = bridge
subclass = PCI-PCI
pcib2@pci0:0:28:0: class=0x060400 card=0x01e61028 chip=0x27d08086 rev=0x01 hdr=0x01
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) PCIe Root Port'
class = bridge
subclass = PCI-PCI
pcib4@pci0:0:28:4: class=0x060400 card=0x01e61028 chip=0x27e08086 rev=0x01 hdr=0x01
vendor = 'Intel Corporation'
device = '82801GR/GH/GHM (ICH7 Family) PCIe Root Port'
class = bridge
subclass = PCI-PCI
pcib5@pci0:0:28:5: class=0x060400 card=0x01e61028 chip=0x27e28086 rev=0x01 hdr=0x01
vendor = 'Intel Corporation'
device = '82801GR/GH/GHM (ICH7 Family) PCIe Root Port'
class = bridge
subclass = PCI-PCI
uhci0@pci0:0:29:0: class=0x0c0300 card=0x01e61028 chip=0x27c88086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) USB Universal Host Controller'
class = serial bus
subclass = USB
uhci1@pci0:0:29:1: class=0x0c0300 card=0x01e61028 chip=0x27c98086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) USB Universal Host Controller'
class = serial bus
subclass = USB
uhci2@pci0:0:29:2: class=0x0c0300 card=0x01e61028 chip=0x27ca8086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) USB Universal Host Controller'
class = serial bus
subclass = USB
ehci0@pci0:0:29:7: class=0x0c0320 card=0x01e61028 chip=0x27cc8086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) USB 2.0 Enhanced Host Controller'
class = serial bus
subclass = USB
pcib6@pci0:0:30:0: class=0x060401 card=0x01e61028 chip=0x244e8086 rev=0xe1 hdr=0x01
vendor = 'Intel Corporation'
device = '82801 Family (ICH2/3/4/5/6/7/8/9,63xxESB) Hub Interface to PCI Bridge'
class = bridge
subclass = PCI-PCI
isab0@pci0:0:31:0: class=0x060100 card=0x01e61028 chip=0x27b88086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = 'Intel 82801GB/GR (ICH7 Family) LPC Interface Controller - 27B8 (945GL)'
class = bridge
subclass = PCI-ISA
atapci0@pci0:0:31:1: class=0x01018a card=0x01e61028 chip=0x27df8086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) Ultra ATA Storage Controller'
class = mass storage
subclass = ATA
atapci1@pci0:0:31:2: class=0x01018f card=0x01e61028 chip=0x27c08086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = '82801GB/GR/GH (ICH7 Family) Serial ATA Storage Controller'
class = mass storage
subclass = ATA
none0@pci0:0:31:3: class=0x0c0500 card=0x01e61028 chip=0x27da8086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = '82801G (ICH7 Family) SMBus Controller'
class = serial bus
subclass = SMBus
em0@pci0:1:0:0: class=0x020000 card=0x135e8086 chip=0x105e8086 rev=0x06 hdr=0x00
vendor = 'Intel Corporation'
device = 'HP NC360T PCIe DP Gigabit Server Adapter (n1e5132)'
class = network
subclass = ethernet
em1@pci0:1:0:1: class=0x020000 card=0x135e8086 chip=0x105e8086 rev=0x06 hdr=0x00
vendor = 'Intel Corporation'
device = 'HP NC360T PCIe DP Gigabit Server Adapter (n1e5132)'
class = network
subclass = ethernet
pcib3@pci0:2:0:0: class=0x060400 card=0x00000000 chip=0x032c8086 rev=0x09 hdr=0x01
vendor = 'Intel Corporation'
device = 'PCI Express-to-PCI Express Bridge (6702PXH)'
class = bridge
subclass = PCI-PCI
oss_audigyls0@pci0:3:2:0: class=0x040100 card=0x100a1102 chip=0x00071102 rev=0x00 hdr=0x00
vendor = 'Creative Technology LTD.'
device = 'Device ID same for both, but Subsystem ID = 0x1012 - Extreme Audio, 0x100A - Audigy SE 7.1 (C6SB0410515017656A)'
class = multimedia
subclass = audio
bge0@pci0:4:0:0: class=0x020000 card=0x01e61028 chip=0x165914e4 rev=0x11 hdr=0x00
vendor = 'Broadcom Corporation'
device = 'NetXtreme Gigabit Ethernet PCI Express (BCM5721)'
class = network
subclass = ethernet
bge1@pci0:5:0:0: class=0x020000 card=0x01e61028 chip=0x165914e4 rev=0x11 hdr=0x00
vendor = 'Broadcom Corporation'
device = 'NetXtreme Gigabit Ethernet PCI Express (BCM5721)'
class = network
subclass = ethernet
vgapci0@pci0:6:5:0: class=0x030000 card=0x01e61028 chip=0x515e1002 rev=0x02 hdr=0x00
vendor = 'ATI Technologies Inc. / Advanced Micro Devices, Inc.'
device = 'Radeon ES1000 (Radeon ES1000)'
class = display
subclass = VGA
Last edited by pratchaya on Fri Mar 12, 2010 4:10 pm, edited 1 time in total.
pratchaya
 
Posts: 5
Joined: Fri Mar 12, 2010 3:49 pm

Re: Need Help about Sound blaster audigy value on FreeBSD

Postby pratchaya » Fri Mar 12, 2010 4:09 pm

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
# osstest
Sound subsystem and version: OSS 4.2 (b 2002/201003021144) (0x00040100)
Platform: FreeBSD/amd64 8.0-RELEASE FreeBSD 8.0-RELEASE #0: Wed Mar 10 15:54:15 ICT 2010 note@berlin.bug.in.th:/usr/src/sys/amd64/compile/BERLIN

*** Scanning sound adapter #-1 ***
/dev/oss/oss_audigyls0/pcm0 (audio engine 0): AudigyLS front
- Performing audio playback test...
<left> OK <right> OK <stereo> OK <measured srate 47990.00 Hz (-0.02%)>
/dev/oss/oss_audigyls0/pcm1 (audio engine 1): AudigyLS center/lfe
- Performing audio playback test...
<left> OK <right> OK <stereo> OK <measured srate 47993.00 Hz (-0.01%)>
/dev/oss/oss_audigyls0/pcm2 (audio engine 2): AudigyLS surround
- Performing audio playback test...
<left> OK <right> OK <stereo> OK <measured srate 47990.00 Hz (-0.02%)>
/dev/oss/oss_audigyls0/pcm3 (audio engine 3): AudigyLS 5.1 output
- Skipping multi channel device

*** All tests completed OK ***

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
pratchaya
 
Posts: 5
Joined: Fri Mar 12, 2010 3:49 pm

Re: Need Help about Sound blaster audigy value on FreeBSD

Postby pratchaya » Fri Mar 12, 2010 4:11 pm

But no sound
pratchaya
 
Posts: 5
Joined: Fri Mar 12, 2010 3:49 pm

Re: Need Help about Sound blaster audigy value on FreeBSD

Postby cesium » Fri Mar 12, 2010 4:40 pm

Please paste the output of "ossmix". Maybe something is muted. Or perhaps setting "ext.spread" to ON in the mixer might help.
cesium
 
Posts: 903
Joined: Sun Aug 12, 2007 12:51 am

Re: Need Help about Sound blaster audigy value on FreeBSD

Postby pratchaya » Tue Mar 23, 2010 2:01 am

#ossmix
Selected mixer 0/AudigyLS Mixer
Known controls are:
pcm [<leftvol>:<rightvol>] (currently 48:48)
rear [<leftvol>:<rightvol>] (currently 0:0)
center [<leftvol>:<rightvol>] (currently 48:48)
ext.spread ON|OFF (currently OFF)
ext.loopback ON|OFF (currently OFF)
ext.recordvol <monovol> (currently 128)
ext.recordsrc <MIC|LINE|AUX> (currently MIC)
ext.monitorvol <monovol> (currently 0)
ext.recmon ON|OFF (currently OFF)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-src <High|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 24.7 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm4 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm5 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm6 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm7 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
pratchaya
 
Posts: 5
Joined: Fri Mar 12, 2010 3:49 pm

Re: Need Help about Sound blaster audigy value on FreeBSD

Postby cesium » Tue Mar 23, 2010 2:05 am

Hmm... Try "ossmix rear 48" and "ossmix ext.spread ON" followed by "osstest".
cesium
 
Posts: 903
Joined: Sun Aug 12, 2007 12:51 am

Re: Need Help about Sound blaster audigy value on FreeBSD

Postby pratchaya » Sat Mar 27, 2010 4:39 am

Still no sound ? sir...

and this is my env. after edited..

berlin# ossmix
Selected mixer 0/AudigyLS Mixer
Known controls are:
pcm [<leftvol>:<rightvol>] (currently 48:48)
rear [<leftvol>:<rightvol>] (currently 50:50)
center [<leftvol>:<rightvol>] (currently 48:48)
ext.spread ON|OFF (currently ON)
ext.loopback ON|OFF (currently OFF)
ext.recordvol <monovol> (currently 128)
ext.recordsrc <MIC|LINE|AUX> (currently MIC)
ext.monitorvol <monovol> (currently 0)
ext.recmon ON|OFF (currently OFF)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-src <High|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 24.7 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm4 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm5 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm6 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm7 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
berlin#


berlin# osstest
Sound subsystem and version: OSS 4.2 (b 2002/201003021144) (0x00040100)
Platform: FreeBSD/amd64 8.0-RELEASE FreeBSD 8.0-RELEASE #0: Wed Mar 10 15:54:15 ICT 2010 note@berlin.bug.in.th:/usr/src/sys/amd64/compile/BERLIN

*** Scanning sound adapter #-1 ***
/dev/oss/oss_audigyls0/pcm0 (audio engine 0): AudigyLS front
- Performing audio playback test...
<left> OK <right> OK <stereo> OK <measured srate 47993.00 Hz (-0.01%)>
/dev/oss/oss_audigyls0/pcm1 (audio engine 1): AudigyLS center/lfe
- Performing audio playback test...
<left> OK <right> OK <stereo> OK <measured srate 47990.00 Hz (-0.02%)>
/dev/oss/oss_audigyls0/pcm2 (audio engine 2): AudigyLS surround
- Performing audio playback test...
<left> OK <right> OK <stereo> OK <measured srate 47990.00 Hz (-0.02%)>
/dev/oss/oss_audigyls0/pcm3 (audio engine 3): AudigyLS 5.1 output
- Skipping multi channel device

*** All tests completed OK ***
berlin#
pratchaya
 
Posts: 5
Joined: Fri Mar 12, 2010 3:49 pm


Return to BSD

Who is online

Users browsing this forum: No registered users and 1 guest