Stuttering and static

OSS specific BSD discussion (FreeBSD/NetBSD/OpenBSD)

Moderators: cesium, dev, kodachi, hannu

Stuttering and static

Postby adamk » Thu Jan 01, 2009 5:16 pm

This is with mplayer:

http://68.45.151.98/example1.ogg
http://68.45.151.98/example2.ogg

With audacious:

http://68.45.151.98/example3.ogg

Code: Select all
[ adamk@sorrow - ~ ]: ossinfo
Version info: OSS 4.2 (b 081213/200901011303) (0x00040100) OSS_HG
Hg revision: changeset: 594:f054e739c2bb, tag: tip, date: Wed Dec 31 00:07:02 2008 +0200, summary: Fixed a typo in oss_ich.c
Platform: FreeBSD/i386 7.1-PRERELEASE FreeBSD 7.1-PRERELEASE #0: Wed Oct 29 13:46:51 EDT 2008     root@sorrow.ashke.com:/usr/obj/usr/src/sys/GENERIC (sorrow.ashke.com)

Number of audio devices:        5
Number of audio engines:        9
Number of MIDI devices:         1
Number of mixer devices:        1


Device objects
0: oss_sblive0 SB Live interrupts=63884 (63884)

MIDI devices (/dev/midi*)
0: SB Live external MIDI (MIDI port 1 of device object 0)

Mixer devices
0: SB Live (STAC9721) (Mixer 0 of device object 0)

Audio devices
SB Live main                      /dev/oss/oss_sblive0/pcm0  (device index 0)
SB Live front out                 /dev/oss/oss_sblive0/pcm1  (device index 1)
SB Live side out                  /dev/oss/oss_sblive0/pcm2  (device index 2)
SB Live center/lfe out            /dev/oss/oss_sblive0/pcm3  (device index 3)
SB Live 5.1 output device         /dev/oss/oss_sblive0/pcm4  (device index 4)


Adam
adamk
Member
 
Posts: 78
Joined: Fri Jun 11, 2004 1:50 pm

Postby cesium » Fri Jan 02, 2009 4:18 pm

Does this happen with vmix disabled too?
cesium
Developer
 
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am

Postby adamk » Fri Jan 02, 2009 8:24 pm

Yes, it definitely continues with vmix disabled.

Adam
adamk
Member
 
Posts: 78
Joined: Fri Jun 11, 2004 1:50 pm

Postby adamk » Sun Jan 11, 2009 6:52 pm

And, BTW, this even happens if I'm not using any audio applications. I can just start ossxmix, put on my headphones, and every now and then I get this static... The monitor in ossxmix even shows a spike when it happens.

Adam
adamk
Member
 
Posts: 78
Joined: Fri Jun 11, 2004 1:50 pm

Postby crux » Sat May 02, 2009 10:08 am

I have the same problem with audigyls after migrating for 64bit.
7.1-7.2RC2, oss-v4.1-build1052
crux
New Member
 
Posts: 2
Joined: Mon Jun 11, 2007 2:44 pm

Re: Stuttering and static

Postby adamk » Sun Feb 07, 2010 9:39 pm

Just so you know, this is still a problem as of OSS 4.2 (b 2002/201002020136)OSS_HG
adamk
Member
 
Posts: 78
Joined: Fri Jun 11, 2004 1:50 pm

Re: Stuttering and static

Postby monty_hall » Wed Feb 17, 2010 8:18 pm

I can confirm to on fbsd 8 and snd_ich6, also I can see on the console that "oss ich fifo error" occur.

Code: Select all
Platform: FreeBSD/i386 8.0-STABLE FreeBSD 8.0-STABLE #1 r203720: Thu Feb 11 10:38:02 EST 2010     root@XXXXX/usr/obj/usr/src/sys/CUSTOM (XXXX)

Number of audio devices:        1
Number of audio engines:        6
Number of MIDI devices:         0
Number of mixer devices:        1


Device objects
0: oss_ich0 Intel ICH6 (266E) interrupts=889050 (1686960)

MIDI devices (/dev/midi*)

Mixer devices
0: ICH AC97 Mixer (STAC9750) (Mixer 0 of device object 0)

Audio devices
Intel ICH6 (266E)                 /dev/oss/oss_ich0/pcm0  (device index 0)

Nodes
  /dev/dsp -> /dev/oss/oss_ich0/pcm0
  /dev/dsp_in -> /dev/oss/oss_ich0/pcm0
  /dev/dsp_out -> /dev/oss/oss_ich0/pcm0
  /dev/dsp_ac3 -> /dev/oss/oss_ich0/pcm0
  /dev/dsp_mmap -> /dev/oss/oss_ich0/pcm0
  /dev/dsp_multich -> /dev/oss/oss_ich0/pcm0
monty_hall
New Member
 
Posts: 1
Joined: Wed Feb 17, 2010 8:15 pm

Re: Stuttering and static

Postby adamk » Fri Mar 26, 2010 12:28 pm

So no ideas?

Adam
adamk
Member
 
Posts: 78
Joined: Fri Jun 11, 2004 1:50 pm

Re: Stuttering and static

Postby adamk » Fri May 14, 2010 2:21 pm

Bump :-) Still a serious issue:

http://68.45.22.62/static.ogg

Adam
adamk
Member
 
Posts: 78
Joined: Fri Jun 11, 2004 1:50 pm

Re: Stuttering and static

Postby adamk » Thu May 27, 2010 11:11 am

So we're forever doomed to have static with oss4/sblive? :-)

Adam
adamk
Member
 
Posts: 78
Joined: Fri Jun 11, 2004 1:50 pm

Re: Stuttering and static

Postby adamk » Thu May 27, 2010 2:02 pm

FYI, here's another example, this time a very loud popping noise every 15-20 seconds when playing NeverWinterNights:

http://68.45.22.62/nwn.ogg
adamk
Member
 
Posts: 78
Joined: Fri Jun 11, 2004 1:50 pm

Re: Stuttering and static

Postby adamk » Mon Jul 26, 2010 11:56 am

Well we're making some progress...

I finally noticed that the stuttering and static only occur when ossxmix is open and running in the foreground. I had a brief conversation with cesium on #oss last night, and he was thinking it might have something to do with the polling.

Adam
adamk
Member
 
Posts: 78
Joined: Fri Jun 11, 2004 1:50 pm


Return to BSD

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest