Realtek ALC268, headphones do not mute speakers, mic issues

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

Realtek ALC268, headphones do not mute speakers, mic issues

Postby soupcan » Sun Sep 05, 2010 4:01 am

I'm trying out OSS as an alternative to ALSA. Everything works fine, aside from the two issues above. When I plug in my headphones, the speakers are not automatically muted. Furthermore, the volume slider that controls the speaker volume also seems to control the volume of my headphones. While testing the internal mic, my voice was audible, but there was lots of static and distortion, and my voice seemed sped up. It seems like there may be issues like this for my specific sound card, but I'd like to know if there's any way to fix this.
soupcan
New Member
 
Posts: 3
Joined: Sun Sep 05, 2010 3:52 am

Re: Realtek ALC268, headphones do not mute speakers, mic issues

Postby igorzwx » Sun Sep 05, 2010 11:31 am

soupcan wrote: It seems like there may be issues like this for my specific sound card


You are probably right. Why not provide more information about your "specific sound card"?

For example:
lspci -vnn
ossinfo
ossmix

You may also consult Arch Linux Wiki http://wiki.archlinux.org/index.php/OSS
and investigate this folder: /usr/lib/oss/conf
For instance, hdaudio_jacksense in /usr/lib/oss/conf/oss_hdaudio.conf
igorzwx
Known Member
 
Posts: 1000
Joined: Sun Jun 28, 2009 9:31 pm

Re: Realtek ALC268, headphones do not mute speakers, mic issues

Postby soupcan » Mon Sep 06, 2010 3:10 am

Of course.
lspci -vnn:
Code: Select all
00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)
   Subsystem: Hewlett-Packard Company Device [103c:30cc]
   Flags: bus master, fast devsel, latency 0, IRQ 22
   Memory at f8600000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: oss_hdaudio



ossinfo:
Code: Select all
Version info: OSS 4.2 (b 2003/201007011539) (0x00040100) GPL
Platform: Linux/x86_64 2.6.35-ARCH #1 SMP PREEMPT Fri Aug 27 17:14:28 CEST 2010 (oxygen)

Number of audio devices:   7
Number of audio engines:   11
Number of MIDI devices:      0
Number of mixer devices:   1


Device objects
0: osscore0 OSS core services
1: oss_hdaudio0 Intel HD Audio interrupts=388289 (388289)
    HD Audio controller Intel HD Audio
    Vendor ID    0x8086284b
    Subvendor ID 0x103c30cc
     Codec  0: ALC268 (0x10ec0268/0x103c30cc)
     Codec  1: Motorola3055 (0x10573055)
2: oss_usb0 USB audio core services

MIDI devices (/dev/midi*)

Mixer devices
0: High Definition Audio ALC268 (Mixer 0 of device object 1)

Audio devices
HD Audio play speaker             /dev/oss/oss_hdaudio0/pcm0  (device index 0)
HD Audio play headphone           /dev/oss/oss_hdaudio0/pcm1  (device index 1)
HD Audio play spdif-out           /dev/oss/oss_hdaudio0/spdout0  (device index 2)
HD Audio play modem               /dev/oss/oss_hdaudio0/mdmout0  (device index 3)
HD Audio rec select               /dev/oss/oss_hdaudio0/pcmin0  (device index 4)
HD Audio rec select               /dev/oss/oss_hdaudio0/pcmin1  (device index 5)
HD Audio rec modem                /dev/oss/oss_hdaudio0/mdmin0  (device index 6)

Nodes
  /dev/dsp -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_in -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_out -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_ac3 -> /dev/oss/oss_hdaudio0/spdout0
  /dev/dsp_mmap -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_multich -> /dev/oss/oss_hdaudio0/pcm0


ossmix:
Code: Select all
Selected mixer 0/High Definition Audio ALC268
Known controls are:
jack.int-speaker.mode <mix|input> (currently input)
jack.int-speaker.mute ON|OFF (currently OFF)
jack.int-speaker.speaker [<leftvol>:<rightvol>] (currently 44.9:44.9 dB)
jack.int-speaker.speaker-mute ON|OFF (currently ON)
jack.black.mode1 <mix|input> (currently mix)
jack.black.mute1 ON|OFF (currently OFF)
jack.black.headphone [<leftvol>:<rightvol>] (currently 49.9:49.9 dB)
jack.black.mute.headphone ON|OFF (currently OFF)
jack.black.mute.speaker ON|OFF (currently OFF)
jack.black.mode2 <speaker|input> (currently input)
jack.black [<leftvol>:<rightvol>] (currently 39.9:39.9 dB)
jack.black.mute2 ON|OFF (currently OFF)
jack.int-mic [<leftvol>:<rightvol>] (currently 39.9:39.9 dB)
record.select.select1 [<leftvol>:<rightvol>] (currently 25.4:25.4 dB)
record.select.select2 <speaker|int-mic> (currently int-mic)
record.select.select3 [<leftvol>:<rightvol>] (currently 23.9:23.9 dB)
record.select.select4 <speaker|int-mic> (currently int-mic)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 192000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|OFF> (currently High)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm7 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB) ("mpd")
vmix0.pcm8 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm9 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm10 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)


I uncommented hdaudio_jacksense and set it to 1, but this didn't seem to change anything. However, I've noticed that the volume of my headphones seems to be controlled by the same slider as the speakers, but I can still manually mute the speakers to have output exclusively from my headphones.
soupcan
New Member
 
Posts: 3
Joined: Sun Sep 05, 2010 3:52 am

Re: Realtek ALC268, headphones do not mute speakers, mic issues

Postby igorzwx » Mon Sep 06, 2010 3:21 am

soupcan wrote:I uncommented hdaudio_jacksense and set it to 1, but this didn't seem to change anything. However, I've noticed that the volume of my headphones seems to be controlled by the same slider as the speakers, but I can still manually mute the speakers to have output exclusively from my headphones.


Could you please test this with Arch LiveCD? This one:
http://godane.wordpress.com/2010/08/25/ ... 5-release/

It has already OSS4 inside. The manual is here:
viewtopic.php?f=3&t=3933
igorzwx
Known Member
 
Posts: 1000
Joined: Sun Jun 28, 2009 9:31 pm

Re: Realtek ALC268, headphones do not mute speakers, mic issues

Postby cesium » Mon Sep 06, 2010 12:48 pm

mic:
Try muting int-speaker slider in ossxmix (same as jack.int-speaker.speaker in ossmix), and try recording again. Also, what happens if you change jack.black.mode1 to "input" or change jack.int-speaker.mode to something else? Another idea is to set hdaudio_noskip=7 in oss_hdaudio.conf and see if any new controls show up in ossmix. Perhaps changing these would help.
cesium
Developer
 
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am

Re: Realtek ALC268, headphones do not mute speakers, mic issues

Postby soupcan » Mon Sep 06, 2010 6:09 pm

cesium wrote:mic:
Try muting int-speaker slider in ossxmix (same as jack.int-speaker.speaker in ossmix), and try recording again. Also, what happens if you change jack.black.mode1 to "input" or change jack.int-speaker.mode to something else? Another idea is to set hdaudio_noskip=7 in oss_hdaudio.conf and see if any new controls show up in ossmix. Perhaps changing these would help.

Did this. Muting the int-speaker slider removed most of the loud static, but I can barely hear my voice and it's still distorted. Changing the other settings did nothing. Tested the same way with an external microphone plugged into the microphone jack, same thing - distorted and barely audible.
igorzwx wrote:Could you please test this with Arch LiveCD? This one:
http://godane.wordpress.com/2010/08/25/ ... 5-release/

It has already OSS4 inside. The manual is here:
http://www.4front-tech.com/forum/viewto ... f=3&t=3933

Same as before.
soupcan
New Member
 
Posts: 3
Joined: Sun Sep 05, 2010 3:52 am

Re: Realtek ALC268, headphones do not mute speakers, mic iss

Postby smthn » Sat Jan 01, 2011 1:46 pm

Hey, everyone, and excuse me for bumping this thread out of a sudden.

Have the same problem with speakers and headphones after installing OSS4 on Ubuntu 10.10 (Maverick) using this guide. My laptop is DELL Inspiron 6400.

lspci -vnn:
Code: Select all
00:1b.0 Audio device [0403]: Intel Corporation N10/ICH 7 Family High Definition Audio Controller [8086:27d8] (rev 01)
   Subsystem: Dell Device [1028:01bd]
   Flags: bus master, fast devsel, latency 0, IRQ 21
   Memory at efebc000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: oss_hdaudio
   Kernel modules: snd-hda-intel


ossinfo:
Code: Select all
Version info: OSS 4.2 (b 2003/201007311944) (0x00040100) GPL
Platform: Linux/i686 2.6.35-24-generic #42-Ubuntu SMP Thu Dec 2 01:41:57 UTC 2010 (Home)

Number of audio devices:   4
Number of audio engines:   8
Number of MIDI devices:      0
Number of mixer devices:   1


Device objects
0: osscore0 OSS core services
1: oss_hdaudio0 Intel HD Audio interrupts=79728 (79728)
    HD Audio controller Intel HD Audio
    Vendor ID    0x808627d8
    Subvendor ID 0x102801bd
     Codec  0: STAC9200 (0x83847690/0x102801bd)
     Codec  1: Conexant2bfa (0x14f12bfa)
2: oss_usb0 USB audio core services

MIDI devices (/dev/midi*)

Mixer devices
0: High Definition Audio STAC9200 (Mixer 0 of device object 1)

Audio devices
HD Audio play pcm                 /dev/oss/oss_hdaudio0/pcm0  (device index 0)
HD Audio play modem-out           /dev/oss/oss_hdaudio0/pcm1  (device index 1)
HD Audio rec select               /dev/oss/oss_hdaudio0/pcmin0  (device index 2)
HD Audio rec modem-out            /dev/oss/oss_hdaudio0/pcmin1  (device index 3)

Nodes
  /dev/dsp -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_in -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_out -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_mmap -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_multich -> /dev/oss/oss_hdaudio0/pcm0


ossmix:
Code: Select all
Selected mixer 0/High Definition Audio STAC9200
Known controls are:
jack.black.mode1 <select|input> (currently select)
jack.black.select1 <pcm|select> (currently pcm)
jack.black.select2 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
jack.int-speaker.mode <select|input> (currently select)
jack.black.mode2 <select|input> (currently select)
record.select.select1 [<leftvol>:<rightvol>] (currently 39.9:39.9 dB)
record.select.select2 [<leftvol>:<rightvol>] (currently 19.4:19.4 dB)
misc <-28.-8dB|-19.-2dB|-9.-6dB|0.0dB|mute> (currently 131(too large (a=5)?))
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 13.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm4 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB) ("source:src")
vmix0.pcm5 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm6 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm7 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)


I've tried setting hdaudio_jacksense to 1 but it didn't help at all. Heard that there is some script that turns on\off speakers if detects headphones' port being used but i wasn't able to find it.

Thanks for any advice in advance :)
smthn
New Member
 
Posts: 1
Joined: Sat Jan 01, 2011 1:05 pm


Return to Linux

Who is online

Users browsing this forum: Exabot [Bot] and 1 guest

cron