How to enable "production quality with extra precision"?

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

Re: How to enable "production quality with extra precision"?

Postby plmegalo » Fri Jul 30, 2010 3:41 pm

Hi Igor !

No prob, you're perfectly right : making package in Debian is actually more complicated than making pkgbuild scripts for Arch, even if we take some objective measurements about complexity, but of course Debian packages are more supposed to be simply used by lazy people like me than made, so clearly the "philosophy" is quite different. Don't worry, I think i was in a "bad day" ;) !! :lol:
I must say I don't make Debian packages most of the time. In fact I only do when the compiling process includes a way to build them easily (I'm clearly lazy).

And many thanks for the information about sid and squeeze packages, I was just making a second boot few days ago with Fedora because I was a bit disappointed at first try of this "squeeze" several months ago, but it seems that now, Debian developers thanks to them!) have integrated even newer versions of every softwares than in Fedora 13 ! A very good surprise. That means I will probably keep Debian for my next personal OS (that probably means also that the next stable version is on its way to be out soon). You know what it is, habbits ! Oh yes, I'm very happy ! I'm on Lenny for the moment and only compilation can be made on that version to get OSSV4.

Thanks again, you're the man :D !
plmegalo
Member
 
Posts: 11
Joined: Fri Sep 25, 2009 7:21 am

Re: How to enable "production quality with extra precision"?

Postby igorzwx » Fri Jul 30, 2010 4:26 pm

plmegalo wrote:Hi Igor !

No prob, you're perfectly right : making package in Debian is actually more complicated than making pkgbuild scripts for Arch, even if we take some objective measurements about complexity, but of course Debian packages are more supposed to be simply used by lazy people like me than made, so clearly the "philosophy" is quite different. Don't worry, I think i was in a "bad day" ;) !! :lol:
I must say I don't make Debian packages most of the time. In fact I only do when the compiling process includes a way to build them easily (I'm clearly lazy).

And many thanks for the information about sid and squeeze packages, I was just making a second boot few days ago with Fedora because I was a bit disappointed at first try of this "squeeze" several months ago, but it seems that now, Debian developers thanks to them!) have integrated even newer versions of every softwares than in Fedora 13 ! A very good surprise. That means I will probably keep Debian for my next personal OS (that probably means also that the next stable version is on its way to be out soon). You know what it is, habbits ! Oh yes, I'm very happy ! I'm on Lenny for the moment and only compilation can be made on that version to get OSSV4.

Thanks again, you're the man :D !


Hi plmegalo!

You see, technical information is of value.
Of course, if you have a working system (Debian, or else), you may better use it as is (without radical reforms).
If you want to study a new system (Arch, Gentoo, or else), you may better install it on another computer and learn it step by step (when you have time for this).

What is special about Arch is its philosophy. Arch is made simple for developers, and not for users. Therefore, ordinary users are invited to use developer tools and read Arch Wiki, if they want to have an "easy Arch".

There is an easy way to create a package for Arch.
1. compile it as usual: configure, make
2. edit PKGBUILD script, and reduce it to a few lines (it should contain "depends" and the like)
3. run "makepkg --noextract", and you get a package.
4. to install it, run: pacman -U [name-of-package]

In a word, there is an installation manual for those OSS4 packages (Debian/Ubuntu):

Installing OSS4 on Trisquel 4.0
http://trisquel.info/en/book/export/html/1010

Step 1 - Install OSS4 packages

I prefer using aptitude to install packages, but as always you can use apt-get if you prefer. The packages you'll need are oss4-base and oss4-source; I also installed oss4-gtk which installs a GTK+ OSS mixer.

$ sudo aptitude install oss4-base oss4-source oss4-gtk

Step 2 - Build OSS4 kernel modules

The oss4-base package will install OSS4 itself, but not the kernel modules needed to interface with your sound card; these are found in source form in oss4-source. You need to use module-assistant program to build these modules (oss4-source depends on it, so it was installed in step 1). First, we need to install the packages module-assistant needs to function:

$ sudo module-assistant prepare

In Trisquel, module-assistant fails to create a symlink necessary for it to build the OSS4 modules; you can work around this by manually creating the symlink first:

$ sudo ln -s /usr/src/linux-headers-$(uname -r | sed s/-generic//g) /lib/modules/$(uname -r)/source

Now we are ready to build the OSS4 kernel modules. Module-assistant makes this very easy to do in one simple step:

$ sudo module-assistant auto-install oss4

Step 3 - Configure OSS as your default sound engine

By default, ALSA will still be configured as the default sound engine. To set this as OSS instead, perform the following command:

$ sudo dpkg-reconfigure linux-sound-base

Then select OSS instead of ALSA in the menu presented. Optionally, you can also remove ALSA from your system:

$ sudo aptitude remove alsa-base alsa-utils

Step 4 - Configure PulseAudio (sic!)

Step 5 - Reboot and start the OSS mixer frontend


On Arch, you can install OSS with one simple command:

pacman -S oss

This is how the philosophy of Arch works in practice.
igorzwx
Supporter
 
Posts: 993
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to enable "production quality with extra precision"?

Postby igorzwx » Mon Sep 06, 2010 2:49 am

Why do we need "extra precision"? Because "production quality" is not good enough to ensure the authenticity of sound. This might be proved with mathematical exactitude.

To clarify the point, I made some experiments with Petrov's "scientific resampler". Sergey delivered his exact resampler in the form of ALSA plugin (together with a magic configuration tool), and I gave it a try.

The results of the test were impressive. You have a complete illusion that you hear real instruments, not a digital ersatz. You can enjoy the magic flute of Hariprasad Chaurasia accompanied with genuine tabla and majestic pakhawaj, and you can easily forget that it is just a recording, a "digital substitute". It is as hypnotizing as a real performance, and it does produce a kind of hallucinogenic effect, you may even have visions and anything of the sort. This music is designed to provoke the so-called "uncontrolled ecstasy". If it does not work (in this sense), you have to fix your sound system.

OSS4 "production quality" does not produce any hallucinogenic effects, although it is very exact in relation to other well known resamplers. "Production quality" is, no doubt, a very good approximation to "nature", but it is not exact enough to produce authentic sound. Although you may not notice audible harmonic distortions with "production quality" enabled, authenticity goes missing, ambiance goes missing, and, in general, genuine music goes missing. Despite "brilliant accuracy", "production quality" is still quite unnatural, in the sense that it sounds rather "digital" than natural. This is because it is simply "production quality", without "extra precision". Scientific exactitude is missing, and, therefore, sound is somehow slightly distorted.

It might be stating the obvious, but the exact digital sound should be equivalent to genuine sound of musical instruments, otherwise, it is not exact by definition. The standard CD format is sufficient for authentic sound, and it was designed to be so, that is, in accord with the Nyquist–Shannon theorem http://en.wikipedia.org/wiki/Nyquist–Shannon_sampling_theorem
What is more, you can get the exact digital sound on an ordinary computer, and processor load can be insignificant, a little bigger than that of OSS4 with "production quality". But this is because of ALSA. If Petrov's "scientific resampler" were correctly realized on OSS4, it would consume much less processor power than "production quality" (it might be unrealistic to expect such miracles to happen).

Petrov's "scientific resampler" seems to be an ideal solution for audiophiles, but it does not seem to be a practical solution for web conferencing, for ALSA is not suitable for the purpose. However, if you have Arch Linux, you can easily switch from OSS4 to ALSA and other way round. It is very simple indeed, execute a script and reboot
http://www.opensound.com/forum/viewtopic.php?f=3&t=3981


For tabla, the difference is dramatic
http://en.wikipedia.org/wiki/Tabla
Playing technique involves extensive use of the fingers and palms in various configurations to create a wide variety of different sounds, reflected in the mnemonic syllables (bol). The heel of the hand is used to apply pressure or in a sliding motion on the larger drum so that the pitch is changed during the sound's decay.

All these go missing.
igorzwx
Supporter
 
Posts: 993
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to enable "production quality with extra precision"?

Postby igorzwx » Wed Sep 15, 2010 11:52 pm

To be fair, it is not a great pleasure to test Petrov's resampler with ALSA. Sometimes you even feel that it is already a kind of "sado-masochism" in terms of Erich Fromm http://en.wikipedia.org/wiki/Erich_Fromm

The problem is that ALSA tends to behave unpredictably, regardless of what is written in ~./asoundrc, especially for sample rates 96kHz and 192kHz with Intel HDA soundcards (e.g. ICH7). ALSA appears to be made "advanced" to such an extend that is already as unpredictable as that famous "strange attractor", a kind of "chaos theory", in other words http://en.wikipedia.org/wiki/Lorenz_attractor

You get a strange diagnostics on terminal, like this:
Code: Select all
Output: 192000 Hz, 2 ch, 's32_le' (0xa): dummy = 0, period = 4096
Rates:  30080 --> 131072 (jitter = 0.09%)

Output: 96000 Hz, 2 ch, 's32_le' (0xa): dummy = 0, period = 4096
Rates:  30096 --> 65536 (jitter = 0.03%)

and you hear strong harmonic distortions.

It was explained that ALSA has a kind of low quality linear resampler inside, and it tends to resample everything with that evil resampler. It seems to be virtually impossible to disable that evil resampler, and, what is more, ALSA also tends to set wrong values for "buffer sizes", completely ignoring your ~./asoundrc. You can never predict the result (think of quasi-chaotic behaviour of a very complex financial market).

In short, you never know exactly what you actually hear with ALSA. Were those distortions caused by that evil linear resampler of ALSA, or the buffer sizes were already reset? Or it was something else?

It was already designed a special scientific test for ALSA. That magic test tells you not to use sample rates 96kHz and 192kHz with Intel HDA ICH7 soundcard. This simply means that there is not much to test. The sample rates 96kHz and 192kHz are not supported for ALSA for Intel HDA soundcards (perhaps, all of them). But they can be tested with OSS4 (!), at least, with those soundcards, which are supported by OSS4.

Sergey Petrov has already created a magic tool in the form of a standalone resampler/player for OSS4 (you can get a testing version directly from the author). I have already made some simple tests. Not surprisingly, with Petrov's standalone resampler/player and OSS4, "Tabla-Tabla Tarang" sounds much better, much more exact and natural than with ALSA and Petrov's resampler plugin.

Some technical details: "ossplay" has a very nice option:
Code: Select all
-R     Disable  redirection  to  virtual  mixer  engines   and   sample rate/format 
        conversions.  Should  not be used unless absolutely necessary.

You have to know exactly, of course, which formats (e.g. 48kHz 16bit) are supported by your soundcard, if you want to apply such a magic option. And you should be aware of the fact that "by default the application [i.e. ossplay] will try to determine the audio file's format and play audio based on the stored information about sample format, number of channels and sampling rate", see "man ossplay".

The option "-R" does disable resampling in a magic way. It does not change anything in the OSS4 virtual mixer; e.g., production quality remains enabled as before, "vmix0" is not disabled too, and sound quality seems to be exactly the same as if you disable vmix0 in the mixer. It is very convenient not to disable vmix0, because it allows other applications to play sound. In other words, the sound device remains available for all audio applications.

To clarify this fact, I made tests with the special audio file: 10Hz + 20kHz (44100Hz, 16bit) created with Audacity Nyquist tools.

WARNING: Such test files should only be played at a low volume level, even if you hear nothing special! It can be very harmful to equipment and/or your ears. It's strongly recommended to use very cheap (PC) speakers, otherwise you might really ruin your tweeters.

Tests were performed on my ancient computer (of 2001), Arch Linux + OSS4, soundcard:
Code: Select all
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 30)

Commands:
Code: Select all
ossplay 1*.wav
ossplay -R 1*.wav

Results:
1. "direct playback" is better than OSS4 "Fast resampling"
2. "Production quality" is better than "direct playback"

In short:

"Fast" < "High" < "High+" < "direct playback" < "Production quality" < "Petrov's resampler"

NOTE: For this particular VIA sound card, the difference is clearly obvious (for anybody) when the test file is played.

Yes! Petrov's exact resampler is much more exact than OSS4 "Production quality".
It is now proved with mathematical exactitude. It is now an objective scientific truth.


"Production quality" does produce relatively strong harmonic distortions which are clearly audible with the test file. I did hear those distortions from the very beginning, and I was very intrigued to find out whether those distortions were caused by OSS4, or by the VIA soundcard itself, or by Ubuntu, or by something else. Now it is clear. Petrov's resampler/player does not produce such distortions, and the same soundcard is now playing genuine sound with OSS4.

The exact scientific test is easily reproducible.
Requirements:
1. Audacity (with which to create the test file)
2. old VIA sound card VT8233/A/8235/8237 AC97 (or any other soundcard of comparable quality)
3. Petrov's standalone resampler/player (it is now available for OSS4).

Intel ICH4 soundcard, for example, might not be optimal for the purpose.

As it was already mentioned, experiments were performed on a very old PC (of 2001).
Processor load seemed to be insignificant (this, of course, should be tested more carefully). All these allow to presume that a kind of "exact audio player" (with Pertrov's resampler inside) might be a practical solution for "non-professional" soundcards which we have in ordinary computers. It is likely to work well on virtually all ordinary PCs, notebooks, and even netbooks with Arch Linux and OSS4 installed.

There are still many things to clarify. What puzzles me immensely is that incomprehensible "scientific knowledge" which Petrov's resampler/player prints on the terminal during resampling. I am very intrigued to find out what it really means.
Last edited by igorzwx on Thu Sep 16, 2010 2:12 pm, edited 1 time in total.
igorzwx
Supporter
 
Posts: 993
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to enable "production quality with extra precision"?

Postby hiro » Thu Sep 16, 2010 11:31 am

Hah, that's also why I use OSS with the production-quality settings.
I once went to their irc channel because I heard some strong distortions with my audiofire 2 a/d. I was searching for the source and the first thing that came to mind was the fear that there might be some cheap kind of a resampler involved. I asked these people if that could be the case and developers were certainly around and answering, but they refused to tell me the details: it's really a simple linear one. One of them also told me that I shouldn't be hearing it, because the resampler wouldn't be bad at all. Until, I think the guy from xiph.org or so showed up and confirmed my fear... I think he also told me to that OSS has a better resampler, which is definitely true...
hiro
Member
 
Posts: 28
Joined: Tue Sep 14, 2010 6:38 pm

Re: How to enable "production quality with extra precision"?

Postby hiro » Thu Sep 16, 2010 11:34 am

You mean, you don't understand this?

Output: 192000 Hz, 2 ch, 's32_le' (0xa): dummy = 0, period = 4096
Rates: 30080 --> 131072 (jitter = 0.09%)

they seem to be measuring some kind of clock jitter, which is not wise if you don't have a good clock to compare with :D
hiro
Member
 
Posts: 28
Joined: Tue Sep 14, 2010 6:38 pm

Re: How to enable "production quality with extra precision"?

Postby igorzwx » Thu Sep 16, 2010 1:27 pm

hiro wrote:You mean, you don't understand this?

Output: 192000 Hz, 2 ch, 's32_le' (0xa): dummy = 0, period = 4096
Rates: 30080 --> 131072 (jitter = 0.09%)

they seem to be measuring some kind of clock jitter, which is not wise if you don't have a good clock to compare with :D


Hi!

You may better discuss such esoteric matters with Sergey Petrov.
I have no idea what "jitter" is, but it quite obvious that is should be equals to zero.
And it is, in fact, equals to zero for 48kHz 32bit, for example:
Code: Select all
$ aplay Tabla*.wav
Playing WAVE 'Tabla-Tabla_Tarang.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo

Converter: fftrate (build: Sep  5 2010, 18:37:54)
Input:  44100 Hz, 2 ch, 's16_le' (0x2): dummy = 0, period = 1764
Output: 48000 Hz, 2 ch, 's32_le' (0xa): dummy = 0, period = 1920
Rates:  44100 --> 48000 (jitter = 0.00%)
Ok.

For 192kHz 32bit, the correct values for buffer and period are defined in ~/.asoundrc
Code: Select all
slave
{
pcm "hw:Intel,0"

rate 192000
channels 2
format S32_LE

period_size 7680
buffer_size 30720
}

And the result looks very strange:
Code: Select all
$ aplay Tabla*.wav
Playing WAVE 'Tabla-Tabla_Tarang.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo

Converter: fftrate (build: Sep  5 2010, 18:37:54)
Input:  44100 Hz, 2 ch, 's16_le' (0x2): dummy = 0, period = 940
Output: 192000 Hz, 2 ch, 's32_le' (0xa): dummy = 0, period = 4096
Rates:  30080 --> 131072 (jitter = 0.09%)
Ok.

It seems to convert 30080Hz --> 131072Hz, instead of 44100Hz --> 192000 Hz
Period size should be 7680, but it is 4096. And so on.

In short, ALSA behaves unpredictable for 96kHz and 192kHz sample rates. Petrov himself seems to have no idea about how to fix this problem.

Try it yourself. Petrov's resampler v.0.4 contains a special testing tool for ALSA and a magic tool for configuration (it is easy to use).
There is a deb-package as well a package for Arch Linux.
All these can be tested with Arch Linux LiveCD
http://godane.wordpress.com/2010/08/25/ ... 5-release/
PulseAudio should be removed, of course.
You may read this too:
viewtopic.php?f=3&t=3933
igorzwx
Supporter
 
Posts: 993
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to enable "production quality with extra precision"?

Postby hiro » Fri Sep 17, 2010 1:00 pm

Clock jitter is just what it sounds like, sometimes the clock runs faster and sometimes slower than it should.
If I understood theory correctly it can raise the noise floor if it's too high.
But to measure jitter you need a second clock to compare with, a better clock.
That's why I agree that this specific measurement might be more of some kind of esoteric nature. I don't think it indicates an error, your output looks fine to me. But who knows...

And by the way, jitter is never zero...
hiro
Member
 
Posts: 28
Joined: Tue Sep 14, 2010 6:38 pm

Re: How to enable "production quality with extra precision"?

Postby igorzwx » Fri Sep 17, 2010 1:22 pm

hiro wrote:Clock jitter is just what it sounds like, sometimes the clock runs faster and sometimes slower than it should.
If I understood theory correctly it can raise the noise floor if it's too high.
But to measure jitter you need a second clock to compare with, a better clock.
That's why I agree that this specific measurement might be more of some kind of esoteric nature. I don't think it indicates an error, your output looks fine to me. But who knows...

And by the way, jitter is never zero...


Actually, it does not matter what "jitter" is. You can safely name it how you want.
Sergey gave me the resampler-plugin, and told me to run aplay, because, in this case, his resampler would print something incomprehensible on terminal. There would be a magic parameter named "jitter", it should be equal to zero.
In fact, when that esoteric jitter is equal to zero, sound is perfect.


In a word, I have already constructed a kind of "Exact Audio Player" for OSS4, in the form of a simple script.
It works in this way:

FLAC → SoX → Petrov's Exact Resampler → ossplay -R

APE → FFmpeg → Petrov's Exact Resampler → ossplay -R

Sound quality is fantastic.
Last edited by igorzwx on Fri Sep 17, 2010 9:51 pm, edited 1 time in total.
igorzwx
Supporter
 
Posts: 993
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to enable "production quality with extra precision"?

Postby hiro » Fri Sep 17, 2010 5:26 pm

Yeah, I did something compareable, I'm using libsamplerate for 44,1 to 48 kHz conversion and never had/heard any problems.
hiro
Member
 
Posts: 28
Joined: Tue Sep 14, 2010 6:38 pm

Re: How to enable "production quality with extra precision"?

Postby igorzwx » Fri Sep 17, 2010 7:22 pm

hiro wrote:Yeah, I did something compareable, I'm using libsamplerate for 44,1 to 48 kHz conversion and never had/heard any problems.


I tried it too, and we already discussed it here.

The Russian gurus told me that libsamplerate is not "scientific" enough for the purpose. It is, in fact, a very old algorithm from a very old handbook. It is exact in theory, but not in practice. It is exact "at infinity" which is not attainable in reality. Imagine an algorithm which is exact if and only if the "step" is infinitely small, and when the "step" is simply small (e.g. 0.0000001), you get a wrong result. Such phenomena are normally observed with non-linear differential equations, for example. Some very important non-linear structures (e.g. cyclones, or anti-cyclones, or hurricanes) might be missing in the "numerical solution".
If you need a sample rate converter, you may better try SoX http://sox.sourceforge.net/sox.html
In SoX, they tend to use "dithering", or other esoteric techniques to remove strong distortions, but some important details (ambiance, overtones, and, genuine music as such) go missing.

It might be interesting, of course, to compare libsamplerate with Petrov's exact resampler.

From my personal experience, the difference is especially obvious for tabla, violin, flute and "authentic" performances such as:
Ensemble Organum, Le Chant des Templiers, (3) Responsorium: Honor virtus et potestas

It seems that old-fashioned resamplers (libsamplerate, "production quality" and the like) tend to cut off some high frequencies, or overtones, or, perhaps, something else.
igorzwx
Supporter
 
Posts: 993
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to enable "production quality with extra precision"?

Postby igorzwx » Sat Sep 18, 2010 12:24 am

Exact Audio Player for Open Sound System (OSS4)

Exact Audio Player is now available in the form of simple scripts designed for testing Petrov's exact resampler. You can now play FLAC, APE, etc. The procedure is very simple:

WAVE → Petrov's Exact Resampler → ossplay -R

FLAC → SoX → WAVE → Petrov's Exact Resampler → ossplay -R

APE → FFmpeg → WAVE → Petrov's Exact Resampler → ossplay -R

Petrov's exact resampler seems to support any formats one may need:
Bit rate: 8, 16 .. 32, 32f or 64f
Sample rate: from 6000Hz to 192000Hz

You may even play surround sound, if you want:

-c Number of output channels:
1 - mono
2 - stereo
3 - 2/1 surround
4 - 2/2 quadro
5 - 3/2 surround
6 - 3/2+SW dolby

Code: Select all
$ ./pcm_conv -h
Usage: pcm_conv <input file> [output file]
               [-c numb. of channels] [-b numb. of bits]
               [-f frequency] [-i] [-h]

Options:
input file    Input WAVE file
output file   Output WAVE file (by default is "convert.wav")

-c            Number of output channels:
               1 - mono
               2 - stereo
               3 - 2/1 surround
               4 - 2/2 quadro
               5 - 3/2 surround
               6 - 3/2+SW dolby

-b            Number of output bits: 8, 16 .. 32, 32f or 64f
-f            Output sample rate (in Hz). Tested: from 6000 to 192000
-i            Show wide modules information
-h            Show this message

The scripts are easy to use. You do not need to install anything.
Just run commands like these:
Code: Select all
./petrov-resampler-wave *.wav
./petrov-resampler-sox *.flac
./petrov-resampler-ffmpeg *.ape
./petrov-resampler-sox *.flac 96000 32

DEFAULT Values:
Sample rate = 48000Hz
Bit rate = 16bit

Sound is played directly to the sound device through the help of "ossplay -R".
You do not need, therefore, to disable resampling in OSS Mixer, but you have to know exactly which formats are supported by your soundcard.

Some information you may get in this way:
Code: Select all
$ ossinfo -a -v9
    Input formats (0x00000418):
      AFMT_U8        - 8 bit unsigned
      AFMT_S16_LE    - 16 bit signed little endian
      AFMT_AC3        - AC3 (Dolby Digital) encoded audio
    Output formats (0x00000418):
      AFMT_U8        - 8 bit unsigned
      AFMT_S16_LE    - 16 bit signed little endian
      AFMT_AC3        - AC3 (Dolby Digital) encoded audio
    Device handle: PCIa1391297-0000:00:11.5-au01
    Related mixer dev: 0
    Sample rate source: 0
    Preferred channel configuration: Not indicated
    Supported number of channels (min - max): 2 - 6
    Native sample rates (min - max): 8000 - 48000

If you have Ubuntu, you may need to install sox plugins and recompile FFmpeg to enable more audio formats http://ubuntuforums.org/showthread.php?t=786095

Content of the archive "exact-audio-player.tar.bz2":
pcm_conv
petrov-resampler-wave
petrov-resampler-sox
petrov-resampler-ffmpeg

Code: Select all
$ md5sum exact-audio-player.tar.bz2
ce7039c264b1f5b154ba1319787f3b11  exact-audio-player.tar.bz2
Attachments
exact-audio-player.tar.bz2
Petrov's exact resampler + surround
md5: ce7039c264b1f5b154ba1319787f3b11
(21.63 KiB) Downloaded 824 times
Last edited by igorzwx on Sat Sep 18, 2010 9:10 pm, edited 1 time in total.
igorzwx
Supporter
 
Posts: 993
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to enable "production quality with extra precision"?

Postby hiro » Sat Sep 18, 2010 2:08 am

Dithering? I thought it's only used for creating bigger dynamic ranges, are you using it in the other domain?? I always thought this would be audible and even more annoying.

You are right that information theory has little to do with audio technology. But when you claim perfection I want to hear it first. I don't buy it and neither do I like Swiss Army knifes.

I just came back from drinking with russians, and the sound system was not very good. I'm tired and going to sleep now, but when I can either confirm or refute your claim I will tell :wink:
Last edited by hiro on Sat Sep 18, 2010 2:30 am, edited 1 time in total.
hiro
Member
 
Posts: 28
Joined: Tue Sep 14, 2010 6:38 pm

Re: How to enable "production quality with extra precision"?

Postby igorzwx » Sat Sep 18, 2010 2:26 am

hiro wrote:You are right that information theory has little to do with audio technology. But when you claim perfection I want to hear it first. I don't buy it and neither do I like Swiss Army knifes.
I'm going to bed now, but when I can either confirm or refute this I will tell... :wink:


It might be very subjective, of course. What is more, it may also depend on objective circumstances
http://en.wikipedia.org/wiki/Sound#Perception_of_sound
For humans, hearing is normally limited to frequencies between about 12 Hz and 20,000 Hz (20 kHz)[2], although these limits are not definite. The upper limit generally decreases with age. Other species have a different range of hearing.
igorzwx
Supporter
 
Posts: 993
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to enable "production quality with extra precision"?

Postby hiro » Sat Sep 18, 2010 2:33 am

By the way, I like that you russians don't give up fighting, feels like home!
And at the end you're awarded with something better...
hiro
Member
 
Posts: 28
Joined: Tue Sep 14, 2010 6:38 pm

PreviousNext

Return to Linux

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron