mixer values

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

mixer values

Postby sev » Tue Sep 28, 2010 12:07 pm

Hi Folks
When I first installed OSS,the mixer sliders werent on maximum but just below.Does anyone know what these values would have been for the below soundcard.particularly the mon section? I currently have them at max.
What would be the terminal command be to change these values?


sevy@sevy-desktop:~$ ossmix
Selected mixer 0/M Audio Audiophile 2496
Known controls are:
mon.out1/2 [<leftvol>:<rightvol>] (currently 144.0:144.0 dB)
mon.spdout [<leftvol>:<rightvol>] (currently 144.0:144.0 dB)
mon.in1/2 [<leftvol>:<rightvol>] (currently 144.0:144.0 dB)
mon.spdin [<leftvol>:<rightvol>] (currently 144.0:144.0 dB)
route.out1/2 <DMA|MONITOR|IN1/2|SPDIF> (currently DMA)
route.spdif <DMA|MONITOR|IN1/2|SPDIF> (currently DMA)
gain.out1/2 <+4DB|CONSUMER|-10DB> (currently -10DB)
envy24.rate <8000|9600|11025|12000|16000|22050|24000|32000|44100|48000|88200|96000> (currently 44100)
envy24.sync <INTERNAL|SPDIF> (currently INTERNAL)
envy24.ratelock ON|OFF (currently ON)
envy24.actrate <decimal value> (currently 44100) (Read-only)
spdif.mode <CONSUMER|PRO> (currently CONSUMER)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 44100) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm7 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm8 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm9 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm10 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)

thanks
sev
New Member
 
Posts: 9
Joined: Sun Jun 13, 2010 9:33 pm

Re: mixer values

Postby igorzwx » Tue Sep 28, 2010 12:34 pm

sev wrote:Hi Folks
When I first installed OSS,the mixer sliders werent on maximum but just below.Does anyone know what these values would have been for the below soundcard.particularly the mon section? I currently have them at max.
What would be the terminal command be to change these values?


sevy@sevy-desktop:~$ ossmix
Selected mixer 0/M Audio Audiophile 2496
Known controls are:
mon.out1/2 [<leftvol>:<rightvol>] (currently 144.0:144.0 dB)
mon.spdout [<leftvol>:<rightvol>] (currently 144.0:144.0 dB)
mon.in1/2 [<leftvol>:<rightvol>] (currently 144.0:144.0 dB)
mon.spdin [<leftvol>:<rightvol>] (currently 144.0:144.0 dB)
route.out1/2 <DMA|MONITOR|IN1/2|SPDIF> (currently DMA)
route.spdif <DMA|MONITOR|IN1/2|SPDIF> (currently DMA)
gain.out1/2 <+4DB|CONSUMER|-10DB> (currently -10DB)
envy24.rate <8000|9600|11025|12000|16000|22050|24000|32000|44100|48000|88200|96000> (currently 44100)
envy24.sync <INTERNAL|SPDIF> (currently INTERNAL)
envy24.ratelock ON|OFF (currently ON)
envy24.actrate <decimal value> (currently 44100) (Read-only)
spdif.mode <CONSUMER|PRO> (currently CONSUMER)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 44100) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm7 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm8 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm9 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm10 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)

thanks


Does osstest play sound?

You may try something like this:

Code: Select all
man ossmix
ossmix mon.out1/2 100.0:100.0
ossmix | grep mon.out1
igorzwx
Supporter
 
Posts: 987
Joined: Sun Jun 28, 2009 9:31 pm

Re: mixer values

Postby sev » Tue Sep 28, 2010 12:43 pm

I have no problem with sound,I would just like the volumes at there default
sev
New Member
 
Posts: 9
Joined: Sun Jun 13, 2010 9:33 pm

Re: mixer values

Postby igorzwx » Tue Sep 28, 2010 12:56 pm

sev wrote:I have no problem with sound,I would just like the volumes at there default


I do not think that there is an ideal "default" which is perfectly suitable for this card.
You may test your soundcard with Risset Bell, or else, and set those mixer values which you need.

Mixer settings are usually here:
/usr/lib/oss/etc/mixer.save
igorzwx
Supporter
 
Posts: 987
Joined: Sun Jun 28, 2009 9:31 pm

Re: mixer values

Postby sev » Tue Sep 28, 2010 1:38 pm

Ok
My other soundblaster card defaults at 75 of 100 when first installed,Ill set it similar for my m-audio
Thanks igorzwx
sev
New Member
 
Posts: 9
Joined: Sun Jun 13, 2010 9:33 pm

Re: mixer values

Postby cesium » Wed Sep 29, 2010 9:45 am

You can erase mixer.save file and restart OSS - the values will return to the default.
[Edit: thanks igrozwx. Do "sudo soundoff" and then erase mixer.save. Otherwise OSS will autosave mixer values on shutdown. Then do "sudo soundon"]
cesium
Developer
 
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am

Re: mixer values

Postby igorzwx » Wed Sep 29, 2010 1:35 pm

cesium wrote:You can erase mixer.save file and restart OSS - the values will return to the default.


You forgot to mention a small detail (which you explained me some months ago):

Code: Select all
man soundoff

       By  default soundoff will save the current mixer and control panel set‐
       tings automatically each time soundoff is executed. The saved  settings
       will be restored automatically when soundon is executed next time.

       This    automatic   save   feature   can   be   disabled   by   editing
       /usr/lib/oss/etc/userdefs  and  by   changing   the   line   containing
       "autosave_mixer  yes" to "autosave_mixer no". After this the mixer set‐
       tings will only be saved when the savemixer  command  is  executed  (by
       super user).
igorzwx
Supporter
 
Posts: 987
Joined: Sun Jun 28, 2009 9:31 pm


Return to Linux

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron