How to make Google Voice (Talk) plugin to work with OSS4?

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

How to make Google Voice (Talk) plugin to work with OSS4?

Postby shmerl » Mon Jan 03, 2011 10:03 pm

Google Voice (Talk) Firefox plugin for Linux seems to be oblivious to OSS4 usage (it probably uses ALSA instead of some more flexible way to be API independent). Did anyone manage to make it work with OSS4? Emulation didn't work, at least for me on current Debian testing.
shmerl
New Member
 
Posts: 2
Joined: Mon Jan 03, 2011 9:59 pm

Re: How to make Google Voice (Talk) plugin to work with OSS4

Postby igorzwx » Mon Jan 03, 2011 10:11 pm

shmerl wrote:Google Voice (Talk) Firefox plugin for Linux seems to be oblivious to OSS4 usage (it probably uses ALSA instead of some more flexible way to be API independent). Did anyone manage to make it work with OSS4? Emulation didn't work, at least for me on current Debian testing.


If I am not mistaken, somebody has already asked a similar question on this forum (it has been ignored)
viewtopic.php?f=3&t=3976

If you have Arch, you may try this:
viewtopic.php?f=3&t=3981

EDIT: Google Voice/Video chat is not encrypted (!)
This problem can be easily fixed with ZFone http://en.wikipedia.org/wiki/Zfone

You may try Twinkle (it works well with OSS4) http://en.wikipedia.org/wiki/Twinkle_(software)
Last edited by igorzwx on Mon Jan 03, 2011 10:24 pm, edited 1 time in total.
igorzwx
Known Member
 
Posts: 1000
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to make Google Voice (Talk) plugin to work with OSS4

Postby shmerl » Mon Jan 03, 2011 10:23 pm

igorzwx wrote:Google Voice/Video chat is not encrypted (!)
This problem can be easily fixed with ZFone http://en.wikipedia.org/wiki/Zfone


That's interesting. It means it works with Jingle? I general I think Jingle will be better than SIP. It should include encryption too, but I'm not sure if it's already implemented or used.
shmerl
New Member
 
Posts: 2
Joined: Mon Jan 03, 2011 9:59 pm

Re: How to make Google Voice (Talk) plugin to work with OSS4

Postby igorzwx » Mon Jan 03, 2011 10:31 pm

shmerl wrote:
igorzwx wrote:Google Voice/Video chat is not encrypted (!)
This problem can be easily fixed with ZFone http://en.wikipedia.org/wiki/Zfone


That's interesting. It means it works with Jingle?


I am not a specialist on such things, but Zfone does encrypt Google Chat (both audio and video).
It also encrypts Twinkle (and any other VOIP). [But is does not work with Skype.]
And it is very impressive indeed, see animation here: http://zfoneproject.com/prod_zfone.html
In a word, ZFone was created by that same Phil Zimmermann and a team of Russian hackers.
igorzwx
Known Member
 
Posts: 1000
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to make Google Voice (Talk) plugin to work with OSS4

Postby igorzwx » Tue Mar 15, 2011 8:52 pm

shmerl wrote:Google Voice (Talk) Firefox plugin for Linux seems to be oblivious to OSS4 usage (it probably uses ALSA instead of some more flexible way to be API independent). Did anyone manage to make it work with OSS4? Emulation didn't work, at least for me on current Debian testing.


Yes, I did.

Yate supports Google Voice (Talk) and Chat, and you can use it with OSS4 and ALSA emulation, see:
viewtopic.php?f=3&t=4306#p17087

I have already tested this method. It works well. You can even run conferences, for example:

(n + 1) participants with GMail accounts + (k + 1) participants with SIP Phones.

Yate is "open source". This means that the problem is solved.

The question is: How to make Yate working with OSS4 (without ALSA emulation)?

ANSWER: Yate works with OSS4 (without ALSA emulation), but you have to configure it propely.
See: viewtopic.php?f=3&t=4306#p17087
igorzwx
Known Member
 
Posts: 1000
Joined: Sun Jun 28, 2009 9:31 pm


Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest

cron