ossmix Can't Change Volume

OSS specific Linux discussion (x86/amd64)

Moderators: hannu, dev, cesium, kodachi

ossmix Can't Change Volume

Postby whustech » Fri Apr 08, 2011 3:05 pm

Hello,

I am trying to setup sound for my icecast server and unfortunately whenever I try to change the volume using
Code: Select all
ossmix vol 100

or anything of the sort, the return is:
Code: Select all
Value of mixer control vol set o 0.0:0.0

ignoring the changes I have attempted to make.
I get similar responses when I try to change other volume settings. The result of:
Code: Select all
ossmix -a

may be found at http://codepad.org/iDNDQPPt
The result of lspci ( I am using a pci soundcard) may be found at http://codepad.org/TG5f62jk
Please request any other information which may be useful in diagnosing the problem

I mostly just need to be able to get any sound from the input so I can stream it. On a slightly unrelated note, is there an oss equivalent of alsa's arecord? I would like away to test my input aside from attempting to stream from the server.
whustech
 
Posts: 4
Joined: Fri Apr 08, 2011 2:52 pm

Re: ossmix Can't Change Volume

Postby whustech » Fri Apr 08, 2011 3:13 pm

Update:

Though
Code: Select all
ossmix vol 100

and
Code: Select all
ossmix -d 0 vol 100

both return with the response I described earlier (with the changes ignores and vol still at 0)

Code: Select all
ossmix -d 1 vol 100

returns with the volume correctly set to the new value. It seems then, that the problem exists only for the device 0 mixer.
whustech
 
Posts: 4
Joined: Fri Apr 08, 2011 2:52 pm

Re: ossmix Can't Change Volume

Postby cesium » Fri Apr 08, 2011 4:01 pm

IIRC, in this driver mixer 1 controls input, so that's what you want. If you want to change output volume, try changing vmix0-outvol. OSS's equivalent to arecord is 'ossrecord' program - not sure what you want to try, but the manpage might help you.
cesium
 
Posts: 903
Joined: Sun Aug 12, 2007 12:51 am

Re: ossmix Can't Change Volume

Postby whustech » Fri Apr 08, 2011 9:06 pm

Okay, changing what you've suggested for output allowed the volume to change in the settings. Unfortunately, I still don't seem to be able to record from input. I tried
Code: Select all
ossrecord -t 5 tacos.wav

Then I used sftp to retrieve the file. When I played it here there was no sound. Do you have any suggestions for troubleshooting? Is there any other relevant information I could supply?
whustech
 
Posts: 4
Joined: Fri Apr 08, 2011 2:52 pm

Re: ossmix Can't Change Volume

Postby cesium » Fri Apr 08, 2011 11:26 pm

Is the right recording source set? Make sure the correct x.rec knob is ON in ossmix (ossrecord also has a '-i' switch to select it, but most programs don't use that API, so it's best to have the right source set). If you want to record output on the server than it's vol.rec.
cesium
 
Posts: 903
Joined: Sun Aug 12, 2007 12:51 am

Re: ossmix Can't Change Volume

Postby whustech » Sat Apr 09, 2011 2:54 pm

I have tried each one of the .rec switches and none of them work. Is the volume for -d 0 totally independent of the record? Why is it not allowing me to change the volume for d 0 anyway? Is there anything else you might suggest I try? To clarify, what I want to record is labeled as line-in on the sound card itself.
whustech
 
Posts: 4
Joined: Fri Apr 08, 2011 2:52 pm


Return to Linux

Who is online

Users browsing this forum: No registered users and 11 guests