sound blaster x fi xtrememusic 5.1 surround sound

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

sound blaster x fi xtrememusic 5.1 surround sound

Postby 3dfx » Mon Oct 31, 2011 11:03 pm

I tried this glide but it dons not work

I went thought the hold gild but nothing changed
I'm on Ubuntu 10.04 and have a sound blaster x fi xtrememusic

Code: Select all
ossplay -Rlv 6_Channel_ID.wav
Playing WAVE file 6_Channel_ID.wav, 16 bits/6 channels/44100 Hz
/dev/dsp doesn't support 6 channels (2).


Code: Select all
ossinfo
Version info: OSS 4.2 (b 2005/201108051847) (0x00040100) TRIAL
Platform: Linux/x86_64 2.6.32-34-generic #77-Ubuntu SMP Tue Sep 13 19:39:17 UTC 2011 (tux-desktop)

Number of audio devices:   2
Number of audio engines:   6
Number of MIDI devices:      0
Number of mixer devices:   1


Device objects
0: osscore0 OSS core services
1: oss_sbxfi0 Sound Blaster X-Fi interrupts=13749 (13749)
    PCI device 1102:0005, subdevice 1102:1003
2: oss_usb0 USB audio core services

MIDI devices (/dev/midi*)

Mixer devices
0: Sound Blaster X-Fi (Mixer 0 of device object 1)

Audio devices
Sound Blaster X-Fi output         /dev/oss/oss_sbxfi0/pcm0  (device index 0)
Sound Blaster X-Fi input          /dev/oss/oss_sbxfi0/pcmin0  (device index 1)

Nodes
  /dev/dsp -> /dev/oss/oss_sbxfi0/pcm0
  /dev/dsp_in -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_out -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_ac3 -> /dev/oss/oss_hdaudio0/spdout0
  /dev/dsp_mmap -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_multich -> /dev/oss/oss_hdaudio0/pcm0




any help?
3dfx
New Member
 
Posts: 9
Joined: Thu Feb 10, 2011 1:28 am

Re: sound blaster x fi xtrememusic 5.1 surround sound

Postby cesium » Mon Oct 31, 2011 11:49 pm

IIRC the oss_sbxfi driver does not support 5.1...
cesium
Developer
 
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am

Re: sound blaster x fi xtrememusic 5.1 surround sound

Postby 3dfx » Tue Nov 01, 2011 1:24 am

cesium wrote:IIRC the oss_sbxfi driver does not support 5.1...

well that sucks :(
what about 4.0 or 5.0?

will it ever be sported any time soon?
3dfx
New Member
 
Posts: 9
Joined: Thu Feb 10, 2011 1:28 am

Re: sound blaster x fi xtrememusic 5.1 surround sound

Postby dev » Tue Nov 01, 2011 5:23 am

3dfx wrote:
cesium wrote:IIRC the oss_sbxfi driver does not support 5.1...

well that sucks :(
what about 4.0 or 5.0?

will it ever be sported any time soon?


Your best bet is to go with Creative's ALSA driver. This card is far too complicated and since a driver for Linux exists there's really no point in doing another driver.


regards
Dev
dev
Developer
 
Posts: 577
Joined: Fri Sep 12, 2003 6:08 am
Location: Culver City, CA


Return to Linux

Who is online

Users browsing this forum: Bing [Bot] and 1 guest