Xonar STX headphone output

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

Xonar STX headphone output

Postby execute.method » Sun Jan 01, 2012 5:40 pm

Hi,
Could someone please tell me how to change to the headphone output, as I don't have any sound there right now, only line out.

Thanks in advance.
execute.method
New Member
 
Posts: 9
Joined: Sun Jan 01, 2012 4:46 pm

Re: Xonar STX headphone output

Postby execute.method » Sun Jan 01, 2012 6:03 pm

I may have found the issue....

Gonna compile from HG. Looks like there are some recent changes for CMI878X.
Namely:
Code: Select all
+    mixer_ext_set_strings (dev, ctl, "Speaker Headphone FrontHeadphone", 0);


I'll report back
execute.method
New Member
 
Posts: 9
Joined: Sun Jan 01, 2012 4:46 pm

Re: Xonar STX headphone output

Postby execute.method » Sun Jan 01, 2012 6:19 pm

Nope didn't do it.

This is my mixer currently:
Code: Select all
$ ossmix -a
Selected mixer 0/CMedia CMI8788
Known controls are:
pcm [<leftvol>:<rightvol>] (currently 48:48)
ext.monitor.analog ON|OFF (currently ON)
ext.monitor.spdif ON|OFF (currently ON)
ext.monitor.inputsrc <Line|Mic> (currently Line)
ext.routing.speaker-spread ON|OFF (currently OFF)
ext.routing.spdif-loopback ON|OFF (currently ON)
spdif-out.enable ON|OFF (currently ON)
spdif-out.adc/dac ON|OFF (currently ON)
spdif-out.pro <Consumer|Professional> (currently Consumer)
spdif-out.audio <Audio|Data> (currently Audio)
spdif-out.copy ON|OFF (currently ON)
spdif-out.pre-emph ON|OFF (currently ON)
spdif-out.rate <44.1KHz|48KHz|32KHz|88.2KHz|96KHz|64KHz|176.4KHz|192KHz> (currently 48KHz)
spdif-out.vbit ON|OFF (currently OFF)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|OFF> (currently High)
vmix0-outvol <monovol> (currently 22.4 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm1 [<leftvol>:<rightvol>] (currently 20.0:20.0 dB)
vmix0.pcm2 [<leftvol>:<rightvol>] (currently 19.6:19.6 dB)
vmix0.pcm3 [<leftvol>:<rightvol>] (currently 19.2:19.2 dB)
vmix0.pcm4 [<leftvol>:<rightvol>] (currently 19.4:19.4 dB)

Selected mixer 1/AC97 Input Mixer (CMI9780)
Known controls are:
vol [<leftvol>:<rightvol>] (currently 46:46)
vol.rec ON|OFF (currently ON)
pcm [<leftvol>:<rightvol>] (currently 75:75)
speaker <monovol> (currently 0)
line [<leftvol>:<rightvol>] (currently 32:32)
line.rec ON|OFF (currently OFF)
mic <monovol> (currently 0)
mic.rec ON|OFF (currently OFF)
cd [<leftvol>:<rightvol>] (currently 75:75)
cd.rec ON|OFF (currently OFF)
igain [<leftvol>:<rightvol>] (currently 70:70)
aux1 [<leftvol>:<rightvol>] (currently 32:32)
aux1.rec ON|OFF (currently OFF)
phone [<leftvol>:<rightvol>] (currently 36:36)
phone.rec ON|OFF (currently OFF)
mono <monovol> (currently 75)
mono.rec ON|OFF (currently OFF)
video [<leftvol>:<rightvol>] (currently 0:0)
video.rec ON|OFF (currently OFF)
rear [<leftvol>:<rightvol>] (currently 75:75)
center [<leftvol>:<rightvol>] (currently 75:75)


and OSS info:
Code: Select all
$ ossinfo
Version info: OSS 4.2 (b 2005/201111292009) (0x00040100) GPL
Platform: Linux/x86_64 3.1.6-1-ARCH #1 SMP PREEMPT Thu Dec 22 09:11:48 CET 2011 (zillah)

Number of audio devices:   2
Number of audio engines:   7
Number of MIDI devices:      0
Number of mixer devices:   2


Device objects
0: osscore0 OSS core services
1: oss_cmi878x0 Asus Xonar Essence STX (AV100) interrupts=14684 (14684)
2: oss_usb0 USB audio core services

MIDI devices (/dev/midi*)

Mixer devices
0: CMedia CMI8788 (Mixer 0 of device object 1)
1: AC97 Input Mixer (CMI9780) (Mixer 1 of device object 1)

Audio devices
Asus Xonar Essence STX (AV100) (MultiChannel)  /dev/oss/oss_cmi878x0/pcm0  (device index 0)
Asus Xonar Essence STX (AV100) (SPDIF)  /dev/oss/oss_cmi878x0/pcm1  (device index 1)

Nodes
  /dev/dsp -> /dev/oss/oss_cmi878x0/pcm0
  /dev/dsp_in -> /dev/oss/oss_cmi878x0/pcm0
  /dev/dsp_out -> /dev/oss/oss_cmi878x0/pcm0
  /dev/dsp_ac3 -> /dev/oss/oss_cmi878x0/pcm1
  /dev/dsp_mmap -> /dev/oss/oss_cmi878x0/pcm0
  /dev/dsp_multich -> /dev/oss/oss_cmi878x0/pcm0
execute.method
New Member
 
Posts: 9
Joined: Sun Jan 01, 2012 4:46 pm

Re: Xonar STX headphone output

Postby execute.method » Sun Jan 01, 2012 6:21 pm

execute.method wrote:I may have found the issue....

Gonna compile from HG. Looks like there are some recent changes for CMI878X.
Namely:
Code: Select all
+    mixer_ext_set_strings (dev, ctl, "Speaker Headphone FrontHeadphone", 0);


I'll report back


Does this not mean there should be an option in the mixer for this?
execute.method
New Member
 
Posts: 9
Joined: Sun Jan 01, 2012 4:46 pm

Re: Xonar STX headphone output

Postby execute.method » Sun Jan 01, 2012 6:25 pm

It looks like this was implemented a year ago already, why is it not there. Or....am I just not doing it right?

http://permalink.gmane.org/gmane.comp.audio.oss.devel/1114
execute.method
New Member
 
Posts: 9
Joined: Sun Jan 01, 2012 4:46 pm

Re: Xonar STX headphone output

Postby cesium » Sun Jan 01, 2012 7:05 pm

The patch wasn't applied to the repository for some reason, but I'm told it does work (Micheal tested it..)
cesium
Developer
 
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am

Re: Xonar STX headphone output

Postby Michal » Sun Jan 01, 2012 7:52 pm

There were a bunch of fixes for ST/STX including switching the output: http://opensound.hg.sourceforge.net/hgw ... 0ff65ca911
execute.method: You need at least v4.2-2006.
Gentoo ~AMD64 | Audacious
Michal
Member
 
Posts: 16
Joined: Sat Sep 22, 2007 1:29 pm
Location: Lublin, POL

Re: Xonar STX headphone output

Postby execute.method » Sun Jan 01, 2012 8:55 pm

Michal wrote:There were a bunch of fixes for ST/STX including switching the output: http://opensound.hg.sourceforge.net/hgw ... 0ff65ca911
execute.method: You need at least v4.2-2006.


I saw that. I am on archlinux. The oss-hg package pulls from sourceforge.
I checked the source during the build, and the correct oss_cmi878x.c file is there, but it still shows v -2005 in ossinfo.

Any Ideas?

Here is the PKGBUILD:
http://aur.archlinux.org/packages/os/oss-hg/PKGBUILD.
execute.method
New Member
 
Posts: 9
Joined: Sun Jan 01, 2012 4:46 pm

Re: Xonar STX headphone output

Postby execute.method » Sun Jan 01, 2012 9:09 pm

edit irrelevant
execute.method
New Member
 
Posts: 9
Joined: Sun Jan 01, 2012 4:46 pm

Re: Xonar STX headphone output

Postby Michal » Mon Jan 02, 2012 12:26 am

Try to remove current modules.
Code: Select all
# soundoff
# rm -rf /lib/modules/$(uname -r)/kernel/oss/
# soundon
Gentoo ~AMD64 | Audacious
Michal
Member
 
Posts: 16
Joined: Sat Sep 22, 2007 1:29 pm
Location: Lublin, POL

Re: Xonar STX headphone output

Postby execute.method » Mon Jan 02, 2012 12:49 am

Michal wrote:Try to rem
    ove current modules.
    Code: Select all
    # soundoff
    # rm -rf /lib/modules/$(uname -r)/kernel/oss/
    # soundon


    Still says build 2005, and no change to the mixer.
    I've even removed the package, oss dir, reenabled alsa, rebooted, tested, and then reinstalled fresh. This also did not produce a change. Is there anything else on my system that would be hanging onto the old version, or is it a problem with the source?

    Thanks for your help so far.
    execute.method
    New Member
     
    Posts: 9
    Joined: Sun Jan 01, 2012 4:46 pm

    Re: Xonar STX headphone output

    Postby Michal » Tue Jan 03, 2012 12:42 pm

    execute.method: I have no idea, sorry. Talk to your distribution.
    Gentoo ~AMD64 | Audacious
    Michal
    Member
     
    Posts: 16
    Joined: Sat Sep 22, 2007 1:29 pm
    Location: Lublin, POL

    Re: Xonar STX headphone output

    Postby execute.method » Wed Jan 04, 2012 1:49 pm

    This is now fixed.

    I patched the official package to the hg source, and all is right in the world.

    Now we just need the ability to change the output impedance to accommodate different impedance headphones.
    execute.method
    New Member
     
    Posts: 9
    Joined: Sun Jan 01, 2012 4:46 pm


    Return to Linux

    Who is online

    Users browsing this forum: Bing [Bot] and 1 guest