rec from vmix loop works only first time after oss startup

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

rec from vmix loop works only first time after oss startup

Postby konst1089 » Thu Jan 05, 2012 8:30 am

Hello,
I have a problem with recording from vmix loop device. As described here, ossrecord, or recordmydesktop, or just cat /dev/oss/oss_sblive0/loop0 > somefile work fine first time after oss startup (or restart), but then loop0 becomes producing only constant loud noise with little artefacts. I have Creative Audigy 4 sound card which hasn't hardware mixer, and have to use vmix loopback devices or something else to record sound from apps.
Is it reproducible on other systems (mine is Ubuntu 10.10 64bit with 3.2.0-rc5 kernel, oss 4.2 build 2006 from hg, Audigy4 (oss_sblive drv), alsa and pulse are completely removed), or is there any simple and good solution to avoid this problem?
konst1089
New Member
 
Posts: 8
Joined: Wed Jan 04, 2012 2:59 pm

Re: rec from vmix loop works only first time after oss start

Postby igorzwx » Thu Jan 05, 2012 5:51 pm

konst1089 wrote:Hello,
I have a problem with recording from vmix loop device. As described here, ossrecord, or recordmydesktop, or just cat /dev/oss/oss_sblive0/loop0 > somefile work fine first time after oss startup (or restart), but then loop0 becomes producing only constant loud noise with little artefacts. I have Creative Audigy 4 sound card which hasn't hardware mixer, and have to use vmix loopback devices or something else to record sound from apps.
Is it reproducible on other systems (mine is Ubuntu 10.10 64bit with 3.2.0-rc5 kernel, oss 4.2 build 2006 from hg, Audigy4 (oss_sblive drv), alsa and pulse are completely removed), or is there any simple and good solution to avoid this problem?


"loopback" is a kind of PulseAudio.

If you are not a masochist, you may better try a cheap soundcard which has "hardware mixing" with OSS4.

If I am not mistaken, the general situation is about as follows:
1. New professional soundcards do not have Linux drivers.
2. Ancient soundcards (before 2000) have HW mixing with Linux drivers.
3. Newer souncards (from 2004) do not have HW mixing with Linux drivers, because Linux is PulseAudio (by definition).

Intel HDA standard was created in 2004 http://en.wikipedia.org/wiki/Intel_High ... tion_Audio
Intel HDA soundcards (e.g. Intel HDA ICH7) are not likely to have HW mixing with Linux drivers.

AC'97 (short for Audio Codec '97) standard was created in 1997; soundcards: Intel ICH, ICH2, ICH3, ICH4, old VIA, and the like http://en.wikipedia.org/wiki/AC'97
Such soundcards have HW mixing with Linux drivers.

The Envy24 chipset was developed before 2000; soundcards: ICE1712 and the like http://en.wikipedia.org/wiki/VIA_Envy
Such soundcards may have HW mixing with OSS4 (I have not tried them yet).
Code: Select all
    38 oss_envy24   pci1412,1712   Generic ENVY24 based device
    39 oss_envy24   pcs1412,d630   M Audio Delta 1010
    40 oss_envy24   pcs1412,d631   M Audio Delta DiO 2496
    41 oss_envy24   pcs1412,d632   M Audio Delta 66
    42 oss_envy24   pcs1412,d633   M Audio Delta 44
    43 oss_envy24   pcs1412,d634   M Audio Audiophile 2496
    44 oss_envy24   pcs1412,d635   M Audio Delta TDIF
    45 oss_envy24   pcs1412,d638   M Audio Delta 410
    46 oss_envy24   pcs1412,d63b   M Audio Delta 1010LT
    47 oss_envy24   pcs153b,1115   Terratec EWS88MT
    48 oss_envy24   pcs153b,112b   Terratec EWS88D
    49 oss_envy24   pcs153b,1130   Terratec EWX 24/96
    50 oss_envy24   pcs153b,1138   Terratec DMX 6Fire
    51 oss_envy24ht   pci1412,1724   Generic ENVY24HT based sound card
    52 oss_envy24ht   pcs1412,3630   M Audio Revolution 7.1
    53 oss_envy24ht   pcs1412,3631   M Audio Revolution 5.1
    54 oss_envy24ht   pcs1412,6321   M Audio Audiophile 192
    55 oss_envy24ht   pcs153b,1145   Terratec Aureon 7.1 Space
    56 oss_envy24ht   pcs153b,1147   Terratec Aureon 7.1 Sky
    57 oss_envy24ht   pcs153b,1149   Terratec PHASE 28
    58 oss_envy24ht   pcs153b,1153   Terratec Aureon 7.1 Universe
    59 oss_envy24ht   pcs3031,4553   Ego Systems Juli@ *BETA*
    60 oss_envy24ht   pcs4933,4553   Audiotrak Prodigy 7.1
    61 oss_envy24ht   pcs3137,4154   Audiotrak Prodigy HD2
    62 oss_envy24ht   pcs1412,2401   Audiotrak Prodigy HD2 Advance DE
http://opensound.hg.sourceforge.net/hgweb/opensound/opensound/file/3db750724c2d/devlists/Linux


You may ask somebody whether envy24 soundcards have HW mixing with OSS4 or not.
Attachments
OSS Mixer - recording total mixed output.png.tar.gz
(13.75 KiB) Downloaded 642 times
igorzwx
Supporter
 
Posts: 994
Joined: Sun Jun 28, 2009 9:31 pm

Re: rec from vmix loop works only first time after oss start

Postby konst1089 » Fri Jan 06, 2012 5:38 pm

I think setting up one option in the config file isn't any kind of masochism. I really don't need to record something every day (especially from sound mixer). And don't care much about quality of such records (I tried to record some moments from a game to share with friends). Recording from other sources (line in, ac97) works. OSS provides the best sound quality for playing music with my soundcard (compared with Windows native driver, Windows KX driver, Linux ALSA/Pulseaudio), that is why I use it. And I think it's a bit inconvenient to have Pulse only for such little work or even change my sound card. Thus I'm searching for another solution.
konst1089
New Member
 
Posts: 8
Joined: Wed Jan 04, 2012 2:59 pm

Re: rec from vmix loop works only first time after oss start

Postby igorzwx » Fri Jan 06, 2012 8:07 pm

konst1089 wrote:I think setting up one option in the config file isn't any kind of masochism. I really don't need to record something every day (especially from sound mixer). And don't care much about quality of such records (I tried to record some moments from a game to share with friends). Recording from other sources (line in, ac97) works. OSS provides the best sound quality for playing music with my soundcard (compared with Windows native driver, Windows KX driver, Linux ALSA/Pulseaudio), that is why I use it. And I think it's a bit inconvenient to have Pulse only for such little work or even change my sound card. Thus I'm searching for another solution.


You told that you need a "simple and good solution". Right?
The simplest and the best solution is a soundcard with HW mixing. Just check "rec" under the "vol" (see the screenshoot above) and everything will be recorded (microphone, playback, etc.). Any other solution is not simple.

You may try JACK. It was working with OSS4 in 2009. Today it may need to be recompiled and patched, perhaps viewtopic.php?f=3&t=4452#p17854
You may also try to find an old deb-package and its source code:
http://packages.ubuntu.com/hardy/jackd
http://packages.ubuntu.com/hardy/qjackctl

Have you already tried to recompile Ubuntu packages using the Debian Build System?
If not, you may try this manual http://www.4front-tech.com/forum/viewto ... =15#p13781
It is much easy, of course, to solve such problems with Arch Linux (for example: http://www.opensound.com/forum/viewtopi ... =30#p15703 ).
igorzwx
Supporter
 
Posts: 994
Joined: Sun Jun 28, 2009 9:31 pm

Re: rec from vmix loop works only first time after oss start

Postby Matti » Fri Jan 06, 2012 9:56 pm

I have the same problem and I can't figured it out. I've attached screenshot of my ossxmix. Could you tell what should I change. When I run the ossrecord desktop.wav the output result is very quiet with lots of static noise. Using the loop device I get recording wihich is loud, but not clear.

I'm also wondering about recording sound in general (not only with ossrecord). Should I make another thread for that.
Attachments
ossxmix_089.jpeg.tar.bz2
OSS Mixer - High Definition Audio ALC888
(100.66 KiB) Downloaded 659 times
Matti
Member
 
Posts: 39
Joined: Sun May 29, 2011 12:34 pm

Re: rec from vmix loop works only first time after oss start

Postby igorzwx » Fri Jan 06, 2012 11:01 pm

Matti wrote:I have the same problem and I can't figured it out. I've attached screenshot of my ossxmix. Could you tell what should I change. When I run the ossrecord desktop.wav the output result is very quiet with lots of static noise. Using the loop device I get recording wihich is loud, but not clear.

I'm also wondering about recording sound in general (not only with ossrecord). Should I make another thread for that.


Matti wrote:Should I make another thread for that.

Yes. You may post the output of "ossmix", "ossinfo", "lspci -v"

Matti wrote:When I run the ossrecord desktop.wav the output result is very quiet with lots of static noise.

This may happen, if you have wrong settings. The correct settings might be found by the method of "trial and error" https://wiki.archlinux.org/index.php/OS ... io_devices
You have to study your "ossinfo" to find out which "recording devices" are available. Then you can run a magic command like this:
Code: Select all
$ ossrecord -vl - | ossplay -

or (if "3" [/dev/dsp3] is your recording device)
Code: Select all
$ ossrecord -d3 -vl - | ossplay -

and try different settings in the mixer.
See also "man ossrecord"

EXAMPLE [Dell Latitude D531 notebook]:
Code: Select all
$ lspci -v
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
   Subsystem: Dell Device 0206
   Kernel driver in use: oss_hdaudio


Code: Select all
$ ossinfo
Version info: OSS 4.2 (b 2005/201112162250) (0x00040100) GPL
Platform: Linux/i686 3.1.7-1-ARCH #1 SMP PREEMPT Wed Jan 4 08:34:05 UTC 2012 (vanuatu)

Audio devices
HD Audio play front               /dev/oss/oss_hdaudio0/pcm0  (device index 0)
HD Audio play rear                /dev/oss/oss_hdaudio0/pcm1  (device index 1)
HD Audio play modem-out           /dev/oss/oss_hdaudio0/pcm2  (device index 2)
HD Audio rec rec1-mux             /dev/oss/oss_hdaudio0/pcmin0  (device index 3)
HD Audio rec rec2-mux             /dev/oss/oss_hdaudio0/pcmin1  (device index 4)
HD Audio rec modem-out            /dev/oss/oss_hdaudio0/pcmin2  (device index 5)

Nodes
  /dev/dsp -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_in -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_out -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_ac3 -> /dev/oss/oss_hdaudio0/spdout0
  /dev/dsp_mmap -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_multich -> /dev/oss/oss_hdaudio0/pcm0

Code: Select all
$ ossrecord -i?

Possible recording sources for the selected device:

   rec1-mux (currently selected)

$ ossrecord -d3 -i?

Possible recording sources for the selected device:

   rec1-mux (currently selected)

$ ossrecord -d4 -i?

Possible recording sources for the selected device:

   rec2-mux (currently selected)


The first step is to switch off "internal speakers".
You have to use analog earphones to avoid "auto-oscillations".
It makes sense to try both internal and external mics (one of them may not work).

In a word, Sennheiser PC 131 Headset works wonders, but it is not robust and can be easily broken. The quality of recording is incredibly good. The mic is uni-directional, only your voice is recorded, all noise around is cancelled, no noise removal is required. The signal is so strong that you do not even need to remove the evil 50Hz (or 60Hz in US) in the recordings (but you have to remove DC offset, of course).
http://www.sennheiserusa.com/headset-ph ... sic-500912
You may try more expensive Sennheiser (analog) headsets. The key words are: perfect for voice recognition.
http://www.sennheiserusa.com/headset-phones-music-headset-pc-music-500912
General Description
$39.95
The [Sennheiser] PC 131 is an over-the-head, double-sided headset. Ideal for gaming, voice recognition internet telephony and other voiceover IP applications.
Features
Noise cancelling microphone
Microphone rest position
Stereo headset with single sided cable
Robust microphone for high speech intelligibility
Internet telephony compatible
Perfect for voice recognition
In-line volume control and microphone mute switch
Usable with CD/DVD/MP3 players
Skype certified
** For Mac use, please order the UUSB 1 accessory adapter or use PC 136 **
Delivery Includes
PC 131
2 x 3.5mm stereo jacks for both voice and mic PC sockets


Matti wrote:I'm also wondering about recording sound in general.

If you need to record music or voice, or else, or digitize a vinyl LP, you may try Olympus LS-11. Read more: viewtopic.php?f=3&t=4387
igorzwx
Supporter
 
Posts: 994
Joined: Sun Jun 28, 2009 9:31 pm

Re: rec from vmix loop works only first time after oss start

Postby Matti » Sat Jan 07, 2012 12:41 pm

Thank you for your help, but unfortunately I still didn't manage to capture sound properly.

This is my audio device:
Code: Select all
$ lspci -v
00:06.1 Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)
   Subsystem: Giga-byte Technology Device a002
   Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 21
   Memory at fc100000 (32-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: oss_hdaudio
   Kernel modules: snd-hda-intel


Code: Select all
$ ossinfo
Version info: OSS 4.2 (b 2005/201108201621) (0x00040100) OSS_HG
Hg revision: changeset: 937:998ceefba722 summary: Added tag v4.2-2005 for changeset 11205524a8ce, tag: tip summary: Added tag v4.2-2005 for changeset 11205524a8ce, date: Fri Aug 12 07:59:07 2011 +0300, summary: Added tag v4.2-2005 for changeset 11205524a8ce
Platform: Linux/i686 3.0.0-15-generic #25-Ubuntu SMP Mon Jan 2 17:45:26 UTC 2012 (mateusz-desktop)

Number of audio devices:   10
Number of audio engines:   14
Number of MIDI devices:      0
Number of mixer devices:   1


Device objects
0: osscore0 OSS core services
1: oss_hdaudio0 nVidia HD Audio interrupts=410237 (410429)
    HD Audio controller nVidia HD Audio
    Vendor ID    0x10de0371
    Subvendor ID 0x1458a002
     Codec  0: ALC888 (0x10ec0888/0x1458e601)
2: oss_usb0 USB audio core services

MIDI devices (/dev/midi*)

Mixer devices
0: High Definition Audio ALC888 (Mixer 0 of device object 1)

Audio devices
HD Audio play front               /dev/oss/oss_hdaudio0/pcm0  (device index 0)
HD Audio play rear                /dev/oss/oss_hdaudio0/pcm1  (device index 1)
HD Audio play center/LFE          /dev/oss/oss_hdaudio0/pcm2  (device index 2)
HD Audio play side                /dev/oss/oss_hdaudio0/pcm3  (device index 3)
HD Audio play pcm4                /dev/oss/oss_hdaudio0/pcm4  (device index 4)
HD Audio play spdif-out           /dev/oss/oss_hdaudio0/spdout0  (device index 5)
HD Audio rec mix                  /dev/oss/oss_hdaudio0/pcmin0  (device index 6)
HD Audio rec mix                  /dev/oss/oss_hdaudio0/pcmin1  (device index 7)
HD Audio rec spdifin              /dev/oss/oss_hdaudio0/spdin0  (device index 8)
HD Audio play front (vmix) loopback record  /dev/oss/oss_hdaudio0/loop0  (device index 9)

Nodes
  /dev/dsp -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_in -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_out -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_ac3 -> /dev/oss/oss_hdaudio0/spdout0
  /dev/dsp_mmap -> /dev/oss/oss_hdaudio0/pcm0
  /dev/dsp_multich -> /dev/oss/oss_hdaudio0/pcm0


Code: Select all
$ ossrecord -i?

Possible recording sources for the selected device:

   mix (currently selected)

$ ossrecord -d6 -i?

Possible recording sources for the selected device:

   mix (currently selected)

$ ossrecord -d7 -i?

Possible recording sources for the selected device:

   mix (currently selected)

$ ossrecord -d8 -i?

Possible recording sources for the selected device:

   spdifin (currently selected)


This command produces only a very loud noise:
Code: Select all
$ ossrecord -vl - | ossplay -


That noise almost disappear when I set fp-green to mute, but then sound from my music player goes very low. The best result is still when using the loopback device, but only for one sound at time. Playing two sounds results in unclear recording.
Matti
Member
 
Posts: 39
Joined: Sun May 29, 2011 12:34 pm

Re: rec from vmix loop works only first time after oss start

Postby igorzwx » Sat Jan 07, 2012 1:00 pm

Matti wrote:This command produces only a very loud noise:
Code: Select all
$ ossrecord -vl - | ossplay -



It is perfectly O.K. It also produces a very loud noise on my Dell notebook, if the internal speaker is on.
EXPLANATION: It seems to be "auto-oscillations", or, more precisely, a kind of "non-linear resonance"
http://en.wikipedia.org/wiki/Resonance
A similar phenomenon may happen if two Linux/OSS4 users speak by Skype (skype-oss) and both use external speakers and omni-directional microphones (such as "internal mic" or ordinary external microphones). To avoid such troubles, you have to use earphones (if the so-called "echo-cancellation" is not available).

The true secret of the ancient magic ritual of "trial and error": If you apply the method of "trial and error" and observe a strange phenomenon, such as "a very loud noise", you have to try to find out the reason (cause) for it, or, at least, to create a kind of explanation in the form of quasi-scientific mythology (such as "quantum theory", for example). Otherwise, it is a kind of "stupid business" rather than a scientific ritual of "trial and error".

To switch off the internal speaker, I have to change "jack.int-speaker.mode" to "input".
When the internal speaker is off, I can record with the internal mic. Sound quality is good.
You may post the output of your "ossmix" (on terminal).

It is very probable that your mic is already working, you may only need to switch off the internal speaker.
Last edited by igorzwx on Sat Jan 07, 2012 2:29 pm, edited 1 time in total.
igorzwx
Supporter
 
Posts: 994
Joined: Sun Jun 28, 2009 9:31 pm

Re: rec from vmix loop works only first time after oss start

Postby Matti » Sat Jan 07, 2012 2:26 pm

That's what ossmix outputs in the terminal:
Code: Select all
$ ossmix
Selected mixer 0/High Definition Audio ALC888
Known controls are:
jack.green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.green.mute ON|OFF (currently OFF)
jack.black.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.black [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.black.mute ON|OFF (currently OFF)
jack.orange.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.orange [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.orange.mute ON|OFF (currently OFF)
jack.gray.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.gray [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.gray.mute ON|OFF (currently OFF)
jack.pink.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.pink.mute ON|OFF (currently OFF)
jack.fp-pink.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-pink.mute ON|OFF (currently OFF)
jack.blue.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.blue [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
jack.blue.mute ON|OFF (currently ON)
jack.fp-green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-green.mute ON|OFF (currently OFF)
record.mix.mute.mic1 ON|OFF (currently OFF)
record.mix.mute.fp-mic1 ON|OFF (currently OFF)
record.mix.mute.linein1 ON|OFF (currently ON)
record.mix.mute.fp-headphone1 ON|OFF (currently OFF)
record.mix.mute.int-cd1 ON|OFF (currently ON)
record.mix.mute.green1 ON|OFF (currently OFF)
record.mix.mute.black1 ON|OFF (currently OFF)
record.mix.mute.orange1 ON|OFF (currently OFF)
record.mix.mute.gray1 ON|OFF (currently OFF)
record.mix.mute.input-mix1 ON|OFF (currently OFF)
record.mix1 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
record.mix.mute.mic2 ON|OFF (currently OFF)
record.mix.mute.fp-mic2 ON|OFF (currently OFF)
record.mix.mute.linein2 ON|OFF (currently ON)
record.mix.mute.fp-headphone2 ON|OFF (currently OFF)
record.mix.mute.int-cd2 ON|OFF (currently ON)
record.mix.mute.green2 ON|OFF (currently OFF)
record.mix.mute.black2 ON|OFF (currently OFF)
record.mix.mute.orange2 ON|OFF (currently OFF)
record.mix.mute.gray2 ON|OFF (currently OFF)
record.mix.mute.input-mix2 ON|OFF (currently OFF)
record.mix2 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.mic [<leftvol>:<rightvol>] (currently 35.9:35.9 dB)
misc.fp-mic [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.linein [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.fp-headphone [<leftvol>:<rightvol>] (currently 35.9:35.9 dB)
misc.int-cd [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.green [<leftvol>:<rightvol>] (currently 37.4:38.9 dB)
misc.black [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.orange [<leftvol>:<rightvol>] (currently 37.4:37.4 dB)
misc.gray [<leftvol>:<rightvol>] (currently 35.9:35.9 dB)
misc.input-mix <mic|fp-mic|linein|int-cd> (currently mic)
misc.front-mute ON|OFF (currently OFF)
misc.input-mix-mute1 ON|OFF (currently OFF)
misc.front1 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.front2 <front|input-mix> (currently front)
misc.rear-mute ON|OFF (currently OFF)
misc.input-mix-mute2 ON|OFF (currently OFF)
misc.rear1 [<leftvol>:<rightvol>] (currently 28.4:28.4 dB)
misc.rear2 <rear|input-mix> (currently rear)
misc.center/lfe-mute ON|OFF (currently OFF)
misc.input-mix-mute3 ON|OFF (currently OFF)
misc.center/lfe1 [<leftvol>:<rightvol>] (currently 28.4:28.4 dB)
misc.center/lfe2 <center/LFE|input-mix> (currently center/LFE)
misc.side-mute ON|OFF (currently OFF)
misc.input-mix-mute4 ON|OFF (currently OFF)
misc.side1 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.side2 <side|input-mix> (currently side)
misc.pcm4-mute ON|OFF (currently OFF)
misc.input-mix-mute5 ON|OFF (currently OFF)
misc.pcm41 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.pcm42 <pcm4|input-mix> (currently pcm4)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 192000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|High+|Production|OFF> (currently Production)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm9 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB) ("gmusicbrowser")
vmix0.pcm10 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm11 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm12 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)$ ossmix
Selected mixer 0/High Definition Audio ALC888
Known controls are:
jack.green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.green.mute ON|OFF (currently OFF)
jack.black.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.black [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.black.mute ON|OFF (currently OFF)
jack.orange.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.orange [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.orange.mute ON|OFF (currently OFF)
jack.gray.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.gray [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.gray.mute ON|OFF (currently OFF)
jack.pink.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.pink.mute ON|OFF (currently OFF)
jack.fp-pink.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-pink.mute ON|OFF (currently OFF)
jack.blue.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.blue [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
jack.blue.mute ON|OFF (currently ON)
jack.fp-green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-green.mute ON|OFF (currently OFF)
record.mix.mute.mic1 ON|OFF (currently OFF)
record.mix.mute.fp-mic1 ON|OFF (currently OFF)
record.mix.mute.linein1 ON|OFF (currently ON)
record.mix.mute.fp-headphone1 ON|OFF (currently OFF)
record.mix.mute.int-cd1 ON|OFF (currently ON)
record.mix.mute.green1 ON|OFF (currently OFF)
record.mix.mute.black1 ON|OFF (currently OFF)
record.mix.mute.orange1 ON|OFF (currently OFF)
record.mix.mute.gray1 ON|OFF (currently OFF)
record.mix.mute.input-mix1 ON|OFF (currently OFF)
record.mix1 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
record.mix.mute.mic2 ON|OFF (currently OFF)
record.mix.mute.fp-mic2 ON|OFF (currently OFF)
record.mix.mute.linein2 ON|OFF (currently ON)
record.mix.mute.fp-headphone2 ON|OFF (currently OFF)
record.mix.mute.int-cd2 ON|OFF (currently ON)
record.mix.mute.green2 ON|OFF (currently OFF)
record.mix.mute.black2 ON|OFF (currently OFF)
record.mix.mute.orange2 ON|OFF (currently OFF)
record.mix.mute.gray2 ON|OFF (currently OFF)
record.mix.mute.input-mix2 ON|OFF (currently OFF)
record.mix2 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.mic [<leftvol>:<rightvol>] (currently 35.9:35.9 dB)
misc.fp-mic [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.linein [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.fp-headphone [<leftvol>:<rightvol>] (currently 35.9:35.9 dB)
misc.int-cd [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.green [<leftvol>:<rightvol>] (currently 37.4:38.9 dB)
misc.black [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.orange [<leftvol>:<rightvol>] (currently 37.4:37.4 dB)
misc.gray [<leftvol>:<rightvol>] (currently 35.9:35.9 dB)
misc.input-mix <mic|fp-mic|linein|int-cd> (currently mic)
misc.front-mute ON|OFF (currently OFF)
misc.input-mix-mute1 ON|OFF (currently OFF)
misc.front1 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.front2 <front|input-mix> (currently front)
misc.rear-mute ON|OFF (currently OFF)
misc.input-mix-mute2 ON|OFF (currently OFF)
misc.rear1 [<leftvol>:<rightvol>] (currently 28.4:28.4 dB)
misc.rear2 <rear|input-mix> (currently rear)
misc.center/lfe-mute ON|OFF (currently OFF)
misc.input-mix-mute3 ON|OFF (currently OFF)
misc.center/lfe1 [<leftvol>:<rightvol>] (currently 28.4:28.4 dB)
misc.center/lfe2 <center/LFE|input-mix> (currently center/LFE)
misc.side-mute ON|OFF (currently OFF)
misc.input-mix-mute4 ON|OFF (currently OFF)
misc.side1 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.side2 <side|input-mix> (currently side)
misc.pcm4-mute ON|OFF (currently OFF)
misc.input-mix-mute5 ON|OFF (currently OFF)
misc.pcm41 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.pcm42 <pcm4|input-mix> (currently pcm4)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 192000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|High+|Production|OFF> (currently Production)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm9 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB) ("gmusicbrowser")
vmix0.pcm10 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm11 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm12 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
Matti
Member
 
Posts: 39
Joined: Sun May 29, 2011 12:34 pm

Re: rec from vmix loop works only first time after oss start

Postby igorzwx » Sat Jan 07, 2012 2:38 pm

Matti wrote:That's what ossmix outputs in the terminal:
Code: Select all
$ ossmix
Selected mixer 0/High Definition Audio ALC888
Known controls are:
jack.green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.green.mute ON|OFF (currently OFF)
jack.black.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.black [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.black.mute ON|OFF (currently OFF)
jack.orange.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.orange [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.orange.mute ON|OFF (currently OFF)
jack.gray.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.gray [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.gray.mute ON|OFF (currently OFF)
jack.pink.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.pink.mute ON|OFF (currently OFF)
jack.fp-pink.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-pink.mute ON|OFF (currently OFF)
jack.blue.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.blue [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
jack.blue.mute ON|OFF (currently ON)
jack.fp-green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-green.mute ON|OFF (currently OFF)
record.mix.mute.mic1 ON|OFF (currently OFF)
record.mix.mute.fp-mic1 ON|OFF (currently OFF)
record.mix.mute.linein1 ON|OFF (currently ON)
record.mix.mute.fp-headphone1 ON|OFF (currently OFF)
record.mix.mute.int-cd1 ON|OFF (currently ON)
record.mix.mute.green1 ON|OFF (currently OFF)
record.mix.mute.black1 ON|OFF (currently OFF)
record.mix.mute.orange1 ON|OFF (currently OFF)
record.mix.mute.gray1 ON|OFF (currently OFF)
record.mix.mute.input-mix1 ON|OFF (currently OFF)
record.mix1 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
record.mix.mute.mic2 ON|OFF (currently OFF)
record.mix.mute.fp-mic2 ON|OFF (currently OFF)
record.mix.mute.linein2 ON|OFF (currently ON)
record.mix.mute.fp-headphone2 ON|OFF (currently OFF)
record.mix.mute.int-cd2 ON|OFF (currently ON)
record.mix.mute.green2 ON|OFF (currently OFF)
record.mix.mute.black2 ON|OFF (currently OFF)
record.mix.mute.orange2 ON|OFF (currently OFF)
record.mix.mute.gray2 ON|OFF (currently OFF)
record.mix.mute.input-mix2 ON|OFF (currently OFF)
record.mix2 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.mic [<leftvol>:<rightvol>] (currently 35.9:35.9 dB)
misc.fp-mic [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.linein [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.fp-headphone [<leftvol>:<rightvol>] (currently 35.9:35.9 dB)
misc.int-cd [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.green [<leftvol>:<rightvol>] (currently 37.4:38.9 dB)
misc.black [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.orange [<leftvol>:<rightvol>] (currently 37.4:37.4 dB)
misc.gray [<leftvol>:<rightvol>] (currently 35.9:35.9 dB)
misc.input-mix <mic|fp-mic|linein|int-cd> (currently mic)
misc.front-mute ON|OFF (currently OFF)
misc.input-mix-mute1 ON|OFF (currently OFF)
misc.front1 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.front2 <front|input-mix> (currently front)
misc.rear-mute ON|OFF (currently OFF)
misc.input-mix-mute2 ON|OFF (currently OFF)
misc.rear1 [<leftvol>:<rightvol>] (currently 28.4:28.4 dB)
misc.rear2 <rear|input-mix> (currently rear)
misc.center/lfe-mute ON|OFF (currently OFF)
misc.input-mix-mute3 ON|OFF (currently OFF)
misc.center/lfe1 [<leftvol>:<rightvol>] (currently 28.4:28.4 dB)
misc.center/lfe2 <center/LFE|input-mix> (currently center/LFE)
misc.side-mute ON|OFF (currently OFF)
misc.input-mix-mute4 ON|OFF (currently OFF)
misc.side1 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.side2 <side|input-mix> (currently side)
misc.pcm4-mute ON|OFF (currently OFF)
misc.input-mix-mute5 ON|OFF (currently OFF)
misc.pcm41 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.pcm42 <pcm4|input-mix> (currently pcm4)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 192000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|High+|Production|OFF> (currently Production)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm9 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB) ("gmusicbrowser")
vmix0.pcm10 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm11 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm12 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)$ ossmix
Selected mixer 0/High Definition Audio ALC888
Known controls are:
jack.green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.green.mute ON|OFF (currently OFF)
jack.black.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.black [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.black.mute ON|OFF (currently OFF)
jack.orange.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.orange [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.orange.mute ON|OFF (currently OFF)
jack.gray.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.gray [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.gray.mute ON|OFF (currently OFF)
jack.pink.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.pink.mute ON|OFF (currently OFF)
jack.fp-pink.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-pink.mute ON|OFF (currently OFF)
jack.blue.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.blue [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
jack.blue.mute ON|OFF (currently ON)
jack.fp-green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-green.mute ON|OFF (currently OFF)
record.mix.mute.mic1 ON|OFF (currently OFF)
record.mix.mute.fp-mic1 ON|OFF (currently OFF)
record.mix.mute.linein1 ON|OFF (currently ON)
record.mix.mute.fp-headphone1 ON|OFF (currently OFF)
record.mix.mute.int-cd1 ON|OFF (currently ON)
record.mix.mute.green1 ON|OFF (currently OFF)
record.mix.mute.black1 ON|OFF (currently OFF)
record.mix.mute.orange1 ON|OFF (currently OFF)
record.mix.mute.gray1 ON|OFF (currently OFF)
record.mix.mute.input-mix1 ON|OFF (currently OFF)
record.mix1 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
record.mix.mute.mic2 ON|OFF (currently OFF)
record.mix.mute.fp-mic2 ON|OFF (currently OFF)
record.mix.mute.linein2 ON|OFF (currently ON)
record.mix.mute.fp-headphone2 ON|OFF (currently OFF)
record.mix.mute.int-cd2 ON|OFF (currently ON)
record.mix.mute.green2 ON|OFF (currently OFF)
record.mix.mute.black2 ON|OFF (currently OFF)
record.mix.mute.orange2 ON|OFF (currently OFF)
record.mix.mute.gray2 ON|OFF (currently OFF)
record.mix.mute.input-mix2 ON|OFF (currently OFF)
record.mix2 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.mic [<leftvol>:<rightvol>] (currently 35.9:35.9 dB)
misc.fp-mic [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.linein [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.fp-headphone [<leftvol>:<rightvol>] (currently 35.9:35.9 dB)
misc.int-cd [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.green [<leftvol>:<rightvol>] (currently 37.4:38.9 dB)
misc.black [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.orange [<leftvol>:<rightvol>] (currently 37.4:37.4 dB)
misc.gray [<leftvol>:<rightvol>] (currently 35.9:35.9 dB)
misc.input-mix <mic|fp-mic|linein|int-cd> (currently mic)
misc.front-mute ON|OFF (currently OFF)
misc.input-mix-mute1 ON|OFF (currently OFF)
misc.front1 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.front2 <front|input-mix> (currently front)
misc.rear-mute ON|OFF (currently OFF)
misc.input-mix-mute2 ON|OFF (currently OFF)
misc.rear1 [<leftvol>:<rightvol>] (currently 28.4:28.4 dB)
misc.rear2 <rear|input-mix> (currently rear)
misc.center/lfe-mute ON|OFF (currently OFF)
misc.input-mix-mute3 ON|OFF (currently OFF)
misc.center/lfe1 [<leftvol>:<rightvol>] (currently 28.4:28.4 dB)
misc.center/lfe2 <center/LFE|input-mix> (currently center/LFE)
misc.side-mute ON|OFF (currently OFF)
misc.input-mix-mute4 ON|OFF (currently OFF)
misc.side1 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.side2 <side|input-mix> (currently side)
misc.pcm4-mute ON|OFF (currently OFF)
misc.input-mix-mute5 ON|OFF (currently OFF)
misc.pcm41 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.pcm42 <pcm4|input-mix> (currently pcm4)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 192000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|High+|Production|OFF> (currently Production)
vmix0-outvol <monovol> (currently 25.0 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm9 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB) ("gmusicbrowser")
vmix0.pcm10 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm11 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm12 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)


Have you enabled all switches with oss_hdaudio config? Or it is your "default mixer"?

Matti wrote:jack.fp-green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-green.mute ON|OFF (currently OFF)

You may try to change jack.fp-green.mode to "input" or "rear", or else, instead of muting it.
You told that "jack.fp-green.mute" somehow affects your "noise". Right?

Matti wrote:That noise almost disappear when I set fp-green to mute, but then sound from my music player goes very low.
Last edited by igorzwx on Sat Jan 07, 2012 2:49 pm, edited 1 time in total.
igorzwx
Supporter
 
Posts: 994
Joined: Sun Jun 28, 2009 9:31 pm

Re: rec from vmix loop works only first time after oss start

Postby Matti » Sat Jan 07, 2012 2:49 pm

That is my default mixer settings. I didn't change anything.

I see in the oss_hdaudio manualthat fp-green is for front panel speakers (I have headphones pluged there with detached microphone). Setting that to input results in no sound from music player. Setting fp-pink to input still gives me noise when running ossrecord -vl - | ossplay - command.
Last edited by Matti on Sat Jan 07, 2012 2:58 pm, edited 1 time in total.
Matti
Member
 
Posts: 39
Joined: Sun May 29, 2011 12:34 pm

Re: rec from vmix loop works only first time after oss start

Postby igorzwx » Sat Jan 07, 2012 2:52 pm

Matti wrote:That is my default mixer settings. I didn't change anything.


You may try to experiment with "jack.fp-green.mode", see my previous post.
Perhaps, "input". And see how it affects your "noise".

You may also try "fp-mic" here:
Code: Select all
misc.input-mix <mic|fp-mic|linein|int-cd> (currently mic)
igorzwx
Supporter
 
Posts: 994
Joined: Sun Jun 28, 2009 9:31 pm

Re: rec from vmix loop works only first time after oss start

Postby Matti » Sat Jan 07, 2012 3:07 pm

I have changed fp-pink to input and misc.input.mix to fp-mic and now running
Code: Select all
$ ossrecord -d7 -vl desktop.wav

produces output that I can hear. Though it's very bad quality.
Matti
Member
 
Posts: 39
Joined: Sun May 29, 2011 12:34 pm

Re: rec from vmix loop works only first time after oss start

Postby igorzwx » Sat Jan 07, 2012 3:13 pm

Matti wrote:I have changed fp-pink to input and misc.input.mix to fp-mic and now running
Code: Select all
$ ossrecord -d7 -vl desktop.wav

produces output that I can hear. Though it's very bad quality.


It is already a "good step forward".
You may also try to use the "earhpnes jack" for mic and other way round.
Set jack.fp-pink.mode to front and plug your earhpnones to the "mic jack",
and plug microphone into the earphones jack and "jack.fp-green.mode" to "input".

For "misc.input-mix", it makes sense to try mic, fp-mic, linein.
You have to find out which switches affects the quality of recordings.
It might be reasonable to "mute" or set to zero everything which you do not need.

1. STANDARD: mic → mic jack, earphones → earphones jack
Code: Select all
jack.pink.mode <front|rear|center/LFE|side|pcm4|input> (currently input)
jack.fp-pink.mode <front|rear|center/LFE|side|pcm4|input> (currently input)
jack.green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)


2. REVERSE: mic → earphones jack, earphones → mic jack
Code: Select all
jack.pink.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-pink.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.green.mode <front|rear|center/LFE|side|pcm4|input> (currently input)
jack.fp-green.mode <front|rear|center/LFE|side|pcm4|input> (currently input)

But you also have:
Code: Select all
misc.input-mix <mic|fp-mic|linein|int-cd> (currently mic) → mic, fp-mic, or linein
misc.front1 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.front2 <front|input-mix> (currently front)

"misc.front2" is likely to be your "front-panel mic".
You may try to set it to "input-mix".

Notice that there are other "mics" to try:
Code: Select all
misc.rear2 <rear|input-mix> (currently rear)
misc.side2 <side|input-mix> (currently side)

It might be possible to use "rear/side" as "front" or "mic".
Last edited by igorzwx on Sat Jan 07, 2012 4:57 pm, edited 1 time in total.
igorzwx
Supporter
 
Posts: 994
Joined: Sun Jun 28, 2009 9:31 pm

Re: rec from vmix loop works only first time after oss start

Postby Matti » Sat Jan 07, 2012 4:54 pm

I've didn't manage to go further (the quality of recording is still very poor). Changing jack.fp-green.mode to input results in no sound from my music player (it's control for the front panel speakers). The second thing (jack.fp-pink.mode) is for front panel mic/line-in (microphone or line in).

Maybe I'm trying to use inappropriate tool for the job. I want to record sound from applications like games (native and wine), music players and other things.

Anyway this is current state of my mixer:
Code: Select all
$ ossmix
Selected mixer 0/High Definition Audio ALC888
Known controls are:
jack.green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.green.mute ON|OFF (currently OFF)
jack.black.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.black [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.black.mute ON|OFF (currently ON)
jack.orange.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.orange [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.orange.mute ON|OFF (currently ON)
jack.gray.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.gray [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.gray.mute ON|OFF (currently ON)
jack.pink.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.pink.mute ON|OFF (currently ON)
jack.fp-pink.mode <front|rear|center/LFE|side|pcm4|input> (currently input)
jack.fp-pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-pink.mute ON|OFF (currently ON)
jack.blue.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.blue [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.blue.mute ON|OFF (currently ON)
jack.fp-green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-green.mute ON|OFF (currently OFF)
record.mix.mute.mic1 ON|OFF (currently ON)
record.mix.mute.fp-mic1 ON|OFF (currently ON)
record.mix.mute.linein1 ON|OFF (currently ON)
record.mix.mute.fp-headphone1 ON|OFF (currently ON)
record.mix.mute.int-cd1 ON|OFF (currently ON)
record.mix.mute.green1 ON|OFF (currently ON)
record.mix.mute.black1 ON|OFF (currently ON)
record.mix.mute.orange1 ON|OFF (currently ON)
record.mix.mute.gray1 ON|OFF (currently ON)
record.mix.mute.input-mix1 ON|OFF (currently OFF)
record.mix1 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
record.mix.mute.mic2 ON|OFF (currently ON)
record.mix.mute.fp-mic2 ON|OFF (currently ON)
record.mix.mute.linein2 ON|OFF (currently ON)
record.mix.mute.fp-headphone2 ON|OFF (currently OFF)
record.mix.mute.int-cd2 ON|OFF (currently ON)
record.mix.mute.green2 ON|OFF (currently ON)
record.mix.mute.black2 ON|OFF (currently ON)
record.mix.mute.orange2 ON|OFF (currently ON)
record.mix.mute.gray2 ON|OFF (currently ON)
record.mix.mute.input-mix2 ON|OFF (currently OFF)
record.mix2 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.mic [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.fp-mic [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.linein [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.fp-headphone [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.int-cd [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.green [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.black [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.orange [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.gray [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.input-mix <mic|fp-mic|linein|int-cd> (currently fp-mic)
misc.front-mute ON|OFF (currently OFF)
misc.input-mix-mute1 ON|OFF (currently ON)
misc.front1 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.front2 <front|input-mix> (currently front)
misc.rear-mute ON|OFF (currently ON)
misc.input-mix-mute2 ON|OFF (currently ON)
misc.rear1 [<leftvol>:<rightvol>] (currently 28.4:28.4 dB)
misc.rear2 <rear|input-mix> (currently rear)
misc.center/lfe-mute ON|OFF (currently ON)
misc.input-mix-mute3 ON|OFF (currently ON)
misc.center/lfe1 [<leftvol>:<rightvol>] (currently 28.4:28.4 dB)
misc.center/lfe2 <center/LFE|input-mix> (currently center/LFE)
misc.side-mute ON|OFF (currently ON)
misc.input-mix-mute4 ON|OFF (currently ON)
misc.side1 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.side2 <side|input-mix> (currently side)
misc.pcm4-mute ON|OFF (currently ON)
misc.input-mix-mute5 ON|OFF (currently ON)
misc.pcm41 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.pcm42 <pcm4|input-mix> (currently pcm4)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 192000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|High+|Production|OFF> (currently Production)
vmix0-outvol <monovol> (currently 22.1 dB)
vmix0-invol <monovol> (currently 20.5 dB)
vmix0.pcm9 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB) ("gmusicbrowser")
vmix0.pcm10 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm11 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm12 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)$ ossmix
Selected mixer 0/High Definition Audio ALC888
Known controls are:
jack.green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.green.mute ON|OFF (currently OFF)
jack.black.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.black [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.black.mute ON|OFF (currently ON)
jack.orange.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.orange [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.orange.mute ON|OFF (currently ON)
jack.gray.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.gray [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.gray.mute ON|OFF (currently ON)
jack.pink.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.pink.mute ON|OFF (currently ON)
jack.fp-pink.mode <front|rear|center/LFE|side|pcm4|input> (currently input)
jack.fp-pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-pink.mute ON|OFF (currently ON)
jack.blue.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.blue [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.blue.mute ON|OFF (currently ON)
jack.fp-green.mode <front|rear|center/LFE|side|pcm4|input> (currently front)
jack.fp-green [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
jack.fp-green.mute ON|OFF (currently OFF)
record.mix.mute.mic1 ON|OFF (currently ON)
record.mix.mute.fp-mic1 ON|OFF (currently ON)
record.mix.mute.linein1 ON|OFF (currently ON)
record.mix.mute.fp-headphone1 ON|OFF (currently ON)
record.mix.mute.int-cd1 ON|OFF (currently ON)
record.mix.mute.green1 ON|OFF (currently ON)
record.mix.mute.black1 ON|OFF (currently ON)
record.mix.mute.orange1 ON|OFF (currently ON)
record.mix.mute.gray1 ON|OFF (currently ON)
record.mix.mute.input-mix1 ON|OFF (currently OFF)
record.mix1 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
record.mix.mute.mic2 ON|OFF (currently ON)
record.mix.mute.fp-mic2 ON|OFF (currently ON)
record.mix.mute.linein2 ON|OFF (currently ON)
record.mix.mute.fp-headphone2 ON|OFF (currently OFF)
record.mix.mute.int-cd2 ON|OFF (currently ON)
record.mix.mute.green2 ON|OFF (currently ON)
record.mix.mute.black2 ON|OFF (currently ON)
record.mix.mute.orange2 ON|OFF (currently ON)
record.mix.mute.gray2 ON|OFF (currently ON)
record.mix.mute.input-mix2 ON|OFF (currently OFF)
record.mix2 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.mic [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.fp-mic [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.linein [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.fp-headphone [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.int-cd [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.green [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.black [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.orange [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.gray [<leftvol>:<rightvol>] (currently 0.0:0.0 dB)
misc.input-mix <mic|fp-mic|linein|int-cd> (currently fp-mic)
misc.front-mute ON|OFF (currently OFF)
misc.input-mix-mute1 ON|OFF (currently ON)
misc.front1 [<leftvol>:<rightvol>] (currently 46.4:46.4 dB)
misc.front2 <front|input-mix> (currently front)
misc.rear-mute ON|OFF (currently ON)
misc.input-mix-mute2 ON|OFF (currently ON)
misc.rear1 [<leftvol>:<rightvol>] (currently 28.4:28.4 dB)
misc.rear2 <rear|input-mix> (currently rear)
misc.center/lfe-mute ON|OFF (currently ON)
misc.input-mix-mute3 ON|OFF (currently ON)
misc.center/lfe1 [<leftvol>:<rightvol>] (currently 28.4:28.4 dB)
misc.center/lfe2 <center/LFE|input-mix> (currently center/LFE)
misc.side-mute ON|OFF (currently ON)
misc.input-mix-mute4 ON|OFF (currently ON)
misc.side1 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.side2 <side|input-mix> (currently side)
misc.pcm4-mute ON|OFF (currently ON)
misc.input-mix-mute5 ON|OFF (currently ON)
misc.pcm41 [<leftvol>:<rightvol>] (currently 38.9:38.9 dB)
misc.pcm42 <pcm4|input-mix> (currently pcm4)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 192000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <Fast|High|High+|Production|OFF> (currently Production)
vmix0-outvol <monovol> (currently 22.1 dB)
vmix0-invol <monovol> (currently 20.5 dB)
vmix0.pcm9 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB) ("gmusicbrowser")
vmix0.pcm10 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm11 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm12 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
Matti
Member
 
Posts: 39
Joined: Sun May 29, 2011 12:34 pm

Next

Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest