oss_hdaudio: HDA codec 0x11060440 not known yet

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

oss_hdaudio: HDA codec 0x11060440 not known yet

Postby hugosthlm » Sun Apr 01, 2012 12:02 am

Hi !

I'm in archlinux with compiz/Gnome 3. I had pulseaudio and alsa. Converted to oss 4.2_2006-1. Converted according to descriptions for archlinux and at oss forums:

https://wiki.archlinux.org/index.php/Open_Sound_System
http://www.opensound.com/wiki/index.php ... S_problems

Sound output is working nicely in firefox/flashplugin, vlc and a 64 bit secondlife clone with gstreamer and openal.
Sound input is loopbacked to the headphones in my Audigy card. With my VIA VT1818 Intel HDA compatible card I didn't find a way to record from the microphone, or even hear myself.

I get this problem when loading the driver:

Mar 31 22:51:12 localhost kernel: [ 21.052212] oss_hdaudio 0000:00:14.2: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Mar 31 22:51:12 localhost kernel: [ 21.055521] oss_hdaudio: HDA codec 0x11060440 not known yet
Mar 31 22:51:12 localhost kernel: [ 21.064953] oss_hdaudio: HDA codec 0x11060440 not known yet
Mar 31 22:51:12 localhost kernel: [ 21.088472] oss_audigyls 0000:02:07.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
Mar 31 22:51:12 localhost kernel: [ 21.107597] usbcore: registered new interface driver oss_usb
Mar 31 22:51:12 localhost kernel: [ 21.527207] fuse init (API version 7.17)
Mar 31 22:51:12 localhost osspd: OSS Proxy v1.3.2 (C) 2008-2010 by Tejun Heo <teheo@suse.de>
Mar 31 22:51:13 localhost osspd: Creating dsp (14:3), adsp (14:12), mixer (14:0)

The problem is reflected in the output from ossinfo -v9:

1: oss_hdaudio0 ATI HD Audio interrupts=1406940 (1406940)
HD Audio controller ATI HD Audio
Vendor ID 0x10024383
Subvendor ID 0x10024383
Codec 0: Unknown (0x11060440/0x10438417)

Some codecs seem to be missing, but how do I get them?

Are the missing codec creating the problem with ossxmix, that there are no selections that causes sound recording as can be seen from the ossrecord and invu meters on ossxmix ?

My card has 6 outputs in the back and 2 in the front of the computer. At least the ones in the front can be switched between input and output.

I run this test:

ossrecord -g200 -vl - | ossplay -

I have three sliders activated under vmix0 - oss, ossplay and ossrecord.

These are the mixer selection choices I have in ossmix:

record.select1.select1 <pcm3|select2|jack6|jack5|mix|jack9> (currently select2)
record.select5.select5 <jack6|jack9> (currently jack9)
misc.select2 <mix|pcm2> (currently pcm2)

pulseaudio is inactivated with pulseaudio --kill, oss and osspd are started.

When activated, pulseaudio output works, but not input. Pulseaudio input is set to an output device. When starting pulseaudio with this line in /etc/pulse/default.pa :

load-module module-oss device="/dev/dsp" sink_name=output source_name=input mmap=0

I get the following information:

Mar 31 22:51:36 localhost pulseaudio[1417]: [pulseaudio] module.c: module-oss is deprecated: Please use module-alsa-card instead of module-oss!

I didn't try to use module-alsa-card because i didn't find any description about how to use it with oss. It seems it can probably only be used with alsa, leaving me with no solution to this problem.

Cheers,

Hugo
Attachments
oss-problem.txt
Related information
(22 KiB) Downloaded 657 times
hugosthlm
New Member
 
Posts: 3
Joined: Sat Mar 31, 2012 11:03 pm

Re: oss_hdaudio: HDA codec 0x11060440 not known yet

Postby igorzwx » Sun Apr 01, 2012 12:34 am

If "codec is unknown", you may want to discuss it with developers.

To remove that crap, you may try this:
Code: Select all
# pacman -Rdd pulseaudio

Then you may install gnome-settings-daemon-nopulse from AUR
Code: Select all
$ yaourt gnome-settings-daemon-nopulse
1 aur/gnome-settings-daemon-nopulse 3.2.2-1 (31)
    The GNOME Settings daemon, without PulseAudio support
==> Enter n° of packages to be installed (ex: 1 2 3 or 1-3)
==> -------------------------------------------------------
==>
igorzwx
Supporter
 
Posts: 993
Joined: Sun Jun 28, 2009 9:31 pm

Re: oss_hdaudio: HDA codec 0x11060440 not known yet

Postby hugosthlm » Sun Apr 01, 2012 1:49 am

Hi !

At least I got rid of the pulseaudio crap. Quite a difference in one application. Thanks ! Still have the missing audio codec note and still no input from microphone.

Cheers,

Hugo
hugosthlm
New Member
 
Posts: 3
Joined: Sat Mar 31, 2012 11:03 pm

Re: oss_hdaudio: HDA codec 0x11060440 not known yet

Postby igorzwx » Sun Apr 01, 2012 1:56 am

hugosthlm wrote:Hi !

At least I got rid of the pulseaudio crap. Quite a difference in one application. Thanks ! Still have the missing audio codec note and still no input from microphone.

Cheers,

Hugo


That "missing audio codec" is a bug in the so-called generic driver, that is, oss_hdaudio
http://manuals.opensound.com/usersguide ... audio.html
http://permalink.gmane.org/gmane.comp.a ... devel/1155

You have to contact the OSS4 developers.
igorzwx
Supporter
 
Posts: 993
Joined: Sun Jun 28, 2009 9:31 pm

Re: oss_hdaudio: HDA codec 0x11060440 not known yet

Postby hugosthlm » Sun Apr 01, 2012 3:56 pm

Hi all!

This patch and the resulting kernel module is ALSA specific?

http://tomoyo.sourceforge.jp/cgi-bin/lx ... atch_via.c

Cheers,

Hugo
hugosthlm
New Member
 
Posts: 3
Joined: Sat Mar 31, 2012 11:03 pm

Re: oss_hdaudio: HDA codec 0x11060440 not known yet

Postby igorzwx » Sun Apr 01, 2012 4:45 pm

hugosthlm wrote:This patch and the resulting kernel module is ALSA specific?
http://tomoyo.sourceforge.jp/cgi-bin/lx ... atch_via.c


Yes. You may ask cesium whether he has a magic patch for your codec.
igorzwx
Supporter
 
Posts: 993
Joined: Sun Jun 28, 2009 9:31 pm


Return to Linux

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest