How to enable/disable INTx emulation OSS v4.2 CentOS 5.8

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

How to enable/disable INTx emulation OSS v4.2 CentOS 5.8

Postby dogbertwrldrulr » Wed Sep 19, 2012 7:22 pm

Hello,

Can someone please tell me the commands to enable or disable INTx emulation on an audio card driver? Or any PCI device for that matter?

As stated in the subject I am using CentOS 5.8 and OSS v4.2 (2007 sources) and the audio device I am using is an M-Audio Delta 1010lt card.

Thanks!
dogbertwrldrulr
Member
 
Posts: 12
Joined: Fri Sep 14, 2012 4:46 pm

Re: How to enable/disable INTx emulation OSS v4.2 CentOS 5.8

Postby cladisch » Thu Sep 20, 2012 11:35 am

In a Linux driver, this would be the pci_disable/enable_msi() functions.
They work only on devices that actually support MSIs; the Delta 1010LT is way too old for that.

Why are you interested in INTx emulation?
cladisch
Member
 
Posts: 28
Joined: Mon Apr 07, 2008 8:14 am
Location: Earth

Re: How to enable/disable INTx emulation OSS v4.2 CentOS 5.8

Postby dogbertwrldrulr » Thu Sep 20, 2012 1:45 pm

Im not interested in it, but I am seeing that INTx (actuall DisINTx-) is one of the control parameters on my card (via lspci) and I dont think it should be. I have a second configuration that works and it does not list INTx as a control parameter so I was wondering how to disable it so I could get a matching configuration. The 2 setups have different hardware setups which I believe is the underlying problem, this was just something to try out.
dogbertwrldrulr
Member
 
Posts: 12
Joined: Fri Sep 14, 2012 4:46 pm

Re: How to enable/disable INTx emulation OSS v4.2 CentOS 5.8

Postby cladisch » Thu Sep 20, 2012 2:15 pm

All PCI 2.3 devices have the DisINTx bit. Older lspci versions might not show it.
cladisch
Member
 
Posts: 28
Joined: Mon Apr 07, 2008 8:14 am
Location: Earth


Return to Linux

Who is online

Users browsing this forum: Google [Bot] and 1 guest